PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896



Calcular el costo de una llamada

04. Dado la duración (en minutos) de una llamada telefónica, calcular su costo, de la siguiente manera: Hasta 5 min el costo es 0.90. Por encima de 5 min el, costo es 0.90+0.20 por cada minuto adicional a los 5 primeros min.


ANÁLISIS :

Para este ejercicio tomamos en cuenta que para llamadas de hasta 5 minutos, multiplicaremos el valor por 0.90; en caso de ser mayor de 5 minutos multiplicamos los primeros 5 * 0.9 y los restantes por 1.1 que es la suma de (0.90 + 0.20), de esa manera sólo aplicamos el costo para conocer el valor de la llamada telefónica.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python





Diagrama de flujo(DFD) para calcular el costo de una llamada:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional04
  Escribir "Ingrese los Minutos de su Llamada : "
  Leer Llamada
  Si (Llamada <= 5) Entonces
    Escribir "COSTO POR LLAMADA ES : ", Llamada * 0.9
  SiNo
    Escribir "COSTO POR LLAMADA ES : ", (5*0.9)+((Llamada - 5)*1.1)
  Fin Si
FinAlgoritmo        
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional04
  Definir Llamada como Entero;
  Escribir "Ingrese los Minutos de su Llamada : ";
  Leer Llamada;
  Si (Llamada <= 5) Entonces
    Escribir "COSTO POR LLAMADA ES : ", Llamada * 0.9;
  SiNo
    Escribir "COSTO POR LLAMADA ES : ", (5*0.9)+((Llamada - 5)*1.1);
  FinSi
FinAlgoritmo        
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
  int llamada;
  printf("Ingrese los Minutos de su Llamada : ");
  scanf("%i",&llamada);
  if ((llamada<=5)) {
    printf("COSTO POR LLAMADA ES : %.2f\n",llamada*0.9);
  } else {
    printf("COSTO POR LLAMADA ES : %.2f\n",(5*0.9)+((llamada-5)*1.1));
  }
  return 0;
}       
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
  int llamada;
  cout << "Ingrese los Minutos de su Llamada : ";
  cin >> llamada;
  if ((llamada<=5)) {
    cout << "COSTO POR LLAMADA ES : " << llamada*0.9 << endl;
  } else {
    cout << "COSTO POR LLAMADA ES : " << (5*0.9)+((llamada-5)*1.1) << endl;
  }
  return 0;
}        
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    llamada = int()
    print("Ingrese los Minutos de su Llamada : ")
    llamada = int(input())
    if (llamada<=5):
        print("COSTO POR LLAMADA ES : ",llamada*0.9)
    else:
        print("COSTO POR LLAMADA ES : ",(5*0.9)+((llamada-5)*1.1))        
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional4 {
    public static void main(String[] args) {
        int llamada;
        Scanner ingreso=new Scanner(System.in);
        System.out.print("Ingrese los minutos de su llamada : ");
        llamada = Integer.parseInt(ingreso.next());
        if(llamada <= 5){
            System.out.println("COSTO DE LLAMADA : " + (llamada * 0.9));
        }else{
            System.out.println("COSTO DE LLAMADA : " + (5*0.9)+((llamada-5)*1.1));
        }
    }
}        
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
<title>Ejercicio Condicional en JS - 04</title>
<script language="JavaScript" type="text/javascript">
    function costo_llamada(){
    var xllamada = ejercicio4.llamada.value;
        if(xllamada <= 5){
            document.getElementById('result').value=parseInt(xllamada)*0.9;
        }else{
            document.getElementById('result').value=(5 * 0.9)+((parseInt(xllamada)-5)*1.1);
        }
}
</script>
</head>
<body>
<form method="get" name="ejercicio4">
    TIEMPO DE LA LLAMADA : <input name="llamada" type="text" > <br>
    <input type="button" value="RESULTADO" onClick="costo_llamada()" > <br>
    SU COSTO POR LLAMADA ES: <input name="result" id="result" type="text" > <br>
</form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module4
    Dim Llamada As Integer
    Sub Main()
    Write("Igrese Tiempo de Duraci贸n de la llamada : ")
    Llamada = ReadLine()
    If (Llamada <= 5) Then
        WriteLine("El Costo de la llamada es : " & Llamada * 0.9)
    Else
        WriteLine("El Costo de la llamada es : " & (5 * 0.9) + ((Llamada - 5) * 1.1))
    End If
    ReadLine()
End Sub
End Module        
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site