PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896



Algoritmo que calcule el descuento

07. Dado un monto de compra calcular su descuento, considerando que por encima de S/.350, el descuento es del 35% y por debajo de 350 es de 10%.


ANÁLISIS :

Para este ejercicio vamos a usar una condicional simple, ya que sólo existe una pregunta, la cual nos dice: Que si el monto de compra es mayor que S/.350 aplicamos un descuento del 35% (Sería DESCUENTO = MONTO * 0.35), caso contrario se aplica un descuento del 10% (DESCUENTO = MONTO * 0.1), obteniendo así el descuento respectivo. Para terminar al monto de compra a pagar, aplicamos el descuento respectivo (MONTO_PAGAR = MONTO - DESCUENTO).


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python





Diagrama de flujo(DFD) para calcular el descuento:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional07
    Escribir "Ingrese Monto : "
    Leer Monto
    Si Monto > 350 Entonces
        Escribir "Tendrá un Descuento del 35% : ", Monto * 0.35
    SiNo
        Escribir "Tendrá un Descuento del 10% : ", Monto * 0.1
    Fin Si
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional07
    Definir Monto como Real;
    Escribir "Ingrese Monto : ";
    Leer Monto;
    Si Monto > 350 Entonces
        Escribir "Tendrá un Descuento del 35% : ", Monto * 0.35;
    SiNo
        Escribir "Tendrá un Descuento del 10% : ", Monto * 0.1;
    FinSi
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
     float monto;
     printf("Ingrese Monto : ");
     scanf("%f",&monto);
     if (monto>350) {
          printf("Tendra un Descuento del 35 Porciento : %.2f\n",monto*0.35);
     } else {
          printf("Tendra un Descuento del 10 Porciento : %.2f\n",monto*0.1);
     }
     return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
     float monto;
     cout << "Ingrese Monto : ";
     cin >> monto;
     if (monto>350) {
          cout << "Tendra un Descuento del 35 Porciento : " << monto*0.35 << endl;
     } else {
          cout << "Tendra un Descuento del 10 Porciento : " << monto*0.1 << endl;
     }
     return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
     print("Ingrese Monto : ")
     monto = float(input())
     if monto>350:
          print("Tendrá un Descuento del 35% : ",monto*0.35)
     else:
          print("Tendrá un Descuento del 10% : ",monto*0.1)
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional7 {
     public static void main(String[] args) {
          Double monto;
          Scanner ingreso=new Scanner(System.in);
          System.out.print("Ingrese un monto : ");
          monto = Double.parseDouble(ingreso.next());
          if(monto > 350){
               System.out.println("TENDRÁ UN DESCUENTO DEL 35% : " + (monto * 0.35));
          }else{
               System.out.println("TENDRÁ UN DESCUENTO DEL 10% : " + (monto * 0.1));
          }
     }
}
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
<title>Ejercicio Condicional en JS - 07</title>
<script language="JavaScript" type="text/javascript">
     function descuento(){
     var xmonto = ejercicio7.monto.value;
          if(xmonto > 350) {
               document.getElementById('result').value="TENDRÁ UN DESCUENTO DEL 35% : " + (xmonto * 0.35);
          }else{
               document.getElementById('result').value="TENDRÁ UN DESCUENTO DEL 10% : " + (xmonto * 0.10);
          }
     }
</script>
</head>
<body>
<form method="get" name="ejercicio7">
     INGRESE MONTO : <input name="monto" id="monto" type="text" > <br>
     <input type="button" value="MOSTRAR" onClick="descuento()" > <br> <br>
     RESULTADO : <input name="result" id="result" type="text" size="35"> <br>
</form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module7
     Dim Monto As Decimal
     Sub Main()
          Write("Igrese Monto : ")
          Monto = ReadLine()
          If (Monto > 350) Then
               WriteLine("Tendrá un Descuento del 35% : " & Monto * 0.35)
          Else
               WriteLine("Tendrá un Descuento del 10% : " & Monto * 0.1)
          End If
          ReadLine()
     End Sub
End Module
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site