PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

16. Se requiere saber la edad de una persona cualquiera a partir de su fecha de nacimiento con todos sus datos; día, mes y año de nacimiento. Lo anterior, a partir de la fecha actual; día, mes y año actual. Todos los datos de ambas fechas, debe proporcionarlos el usuario ingresando los datos por teclado.


ANÁLISIS :

Para obtener la edad restamos la fecha el año actual con el año de nacimiento, lo cual nos da una edad probable, luego consultamos si el mes de nacimiento es menor que el mes actual, esto indicaría que aún no cumple años.
La siguiente consulta seria si el mes de nacimiento es igual que el mes actual, para dedicarnos a los días y saber si el día de nacimiento es menor que el día actual para indicar que aún no ha cumplido años, caso contrario ya cumplió años.
Pero si el mes de nacimiento es mayor que el mes actual indicar que ya cumplió años; todos estos datos se guardan y calculan en la variable edad.

ENTRADA : los datos de la fecha de nacimiento (d, m, a) y la fecha actual (df, mf, af).
SALIDA : Muestra la edad (edad).
PROCESO : Restar el año actual con el año de nacimiento y lo mismo en el mes y día de nacimiento.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_pseint_site
		
    Escribir Sin Saltar "DIA NACIMIENTO : "
    Leer d
    Escribir Sin Saltar "MES NACIMIENTO : "
    Leer m
    Escribir Sin Saltar "AÑO NACIMIENTO : "
    Leer a
	
    Escribir ""
    Escribir Sin Saltar "DIA ACTUAL : "
    Leer df
    Escribir Sin Saltar "MES ACTUAL : "
    Leer mf
    Escribir Sin Saltar "AÑO ACTUAL : "
    Leer af
	
    Si (m < mf) Entonces
        edad = af-a
    SiNo
        Si (m == mf) Entonces
            Si (d < df+1) Entonces
                edad = (af-a)
            SiNo
                edad = (af-a)-1
            FinSi
        SiNo
            edad = (af-a)-1
        FinSi
    FinSi
	
    Escribir ""
    Escribir "EDAD : ", edad
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_pseint_site

    Definir d, m, a como entero;
    Definir df, mf, af como entero;	
    Definir edad Como Entero;
	
    Escribir "DIA NACIMIENTO : ";
    Leer d;
    Escribir "MES NACIMIENTO : ";
    Leer m;
    Escribir "AÑO NACIMIENTO : ";
    Leer a;
	
    Escribir "";	
    Escribir "DIA ACTUAL : ";
    Leer df;
    Escribir "MES ACTUAL : ";
    Leer mf;
    Escribir "AÑO ACTUAL : ";
    Leer af;
	
    Si (m < mf) Entonces
        edad <- af-a;
    SiNo
        Si (m == mf) Entonces
            Si (d < df+1) Entonces
                edad <- (af-a);
            SiNo
                edad <- (af-a)-1;
            FinSi
        SiNo
            edad <- (af-a)-1;
        FinSi
    FinSi
	
    Escribir "";
    Escribir "EDAD : ", edad;
	
FinProceso
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site