Se requiere saber la edad de una persona cualquiera a partir de su fecha de nacimiento con todos sus datos; día, mes y año de nacimiento. Lo anterior, a partir de la fecha actual; día, mes y año actual. Todos los datos de ambas fechas, debe proporcionarlos el usuario ingresando los datos por teclado

¡Haz clic para puntuar este proyecto!
(Votos: 9 Promedio: 3.7)
¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Proceso www_pseint_site
        Escribir Sin Saltar "DIA NACIMIENTO : "
        Leer d
        Escribir Sin Saltar "MES NACIMIENTO : "
        Leer m
        Escribir Sin Saltar "AÑO NACIMIENTO : "
        Leer a
        Escribir ""
        Escribir Sin Saltar "DIA ACTUAL : "
        Leer df
        Escribir Sin Saltar "MES ACTUAL : "
        Leer mf
        Escribir Sin Saltar "AÑO ACTUAL : "
        Leer af
        Si (m < mf) Entonces
            edad = af-a
        SiNo
            Si (m == mf) Entonces
                Si (d < df+1) Entonces
                    edad = (af-a)
                SiNo
                    edad = (af-a)-1
                FinSi
            SiNo
                edad = (af-a)-1
            FinSi
        FinSi
        Escribir ""
        Escribir "EDAD : ", edad
    FinProceso
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir