Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

20. En el Supermercado, un cliente debe presionar un botón, dependiendo del color de lámpara que se encienda, obtiene un descuento, que es un porcentaje del valor de su compra, según se muestra en la tabla.

Color = Descuento (%)
------------------------
Blanco = 100
Verde = 50
Negro = 40
Celeste = 5
Rojo = 0

Calcular el descuento y el pago final (valor compra menos descuento) que realizará un cliente.

1. Ingreso de datos. (Pulsar Tecla para continuar y la función AZAR para saber el color)
2. Calcular el importe del descuento.
3. Calcular el pago final.
4. Mostrar: el importe del descuento y el pago final.



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_pseint_site
		
    Escribir "VALOR DE COMPRA : "
    Leer compra
	
    Escribir "Pulse una tecla para obtener el color"
    Esperar Tecla
    color = azar(5)
	
    Segun (color) Hacer
        1: Escribir "COLOR                 : BLANCO"
            dsct = 1
        2: Escribir "COLOR                 : VERDE"
            dsct = 0.5
        3: Escribir "COLOR                 : NEGRO"
            dsct = 0.4
        4: Escribir "COLOR                 : CELESTE"
            dsct = 0.05
        5: Escribir "COLOR                 : ROJO"
            dsct = 0
    FinSegun
	
    Escribir "DESCUENTO             : ", dsct
    Escribir "IMPORTE DEL DESCUENTO : ", compra * dsct
    Escribir "PAGO FINAL            : ", compra - (compra * dsct)
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_pseint_site

    Definir color como Entero;
    Definir dsct, compra como Real;
	
    dsct <- 0;
    compra <- 0;
	
    Escribir "VALOR DE COMPRA : ";
    Leer compra;
	
    Escribir "Pulse una tecla para obtener el color";
	
    Esperar Tecla;
		
    color <- azar(5);
	
    Segun (color) Hacer
        1: Escribir "COLOR                 : BLANCO";
            dsct <- 1;
        2: Escribir "COLOR                 : VERDE";
            dsct <- 0.5;
        3: Escribir "COLOR                 : NEGRO";
            dsct <- 0.4;
        4: Escribir "COLOR                 : CELESTE";
            dsct <- 0.05;
        5: Escribir "COLOR                 : ROJO";
            dsct <- 0;
    FinSegun
	
    Escribir "DESCUENTO             : ", dsct;
    Escribir "IMPORTE DEL DESCUENTO : ", compra * dsct;
    Escribir "PAGO FINAL            : ", compra - (compra * dsct);
	
FinProceso
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site