PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

17. En una Feria de Libros, los precios de las entradas tienen descuentos por la cantidad de personas que ingresa en grupos. Los menores de 4 personas tienen descuento del 20% el precio de entrada, los grupos de 4 personas y menores de 10 personas tiene descuento del 35% del precio de entrada y de 10 personas a más tienen descuento del 50%. Calcular cuánto pagará cada persona por el precio de entrada y el monto total a pagar por el grupo.

A. Ingreso de datos.
B. Precio a pagar por una entrada.
C. Monto total por el grupo.


ANÁLISIS :

Para este ejercicio se pide la cantidad de personas y el costo por entrada, para tener un precio total bruto; luego obtener el descuento en base a la cantidad de personas y las distintas condiciones. Una vez obtenido el descuento este se aplica al precio bruto para obtener el precio total.
Para obtener el precio por persona se divide el precio total entre la cantidad de personas.

ENTRADA : cantidad de personas (personas), precio de entrada(entradas)
SALIDA : precio de cada entrada (precio) y costo total (total)
PROCESO : Se realizan las validaciones para obtener el descuento por la cantidad de personas, y luego mostrar el costo por persona y el monto total.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_pseint_site
		
    Escribir Sin Saltar "Cantidad de personas : "
    Leer personas
	
    Escribir Sin Saltar "Precio de entrada : "
    Leer entradas
	
    Si (personas >= 10 ) Entonces
        desc = 0.50
    SiNo
        Si (personas >= 4 y personas < 10) Entonces
            desc = 0.35
        SiNo
            Si (personas < 4) Entonces
                desc = 0.20		
            FinSi
        FinSi	
    FinSi
	
    precio = personas * entradas
    total = precio - (precio * desc)
	
    Escribir ""
    Escribir "ENTRADA POR PERSONA : ", total/personas
    Escribir "MONTO TOTAL : ", total
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_pseint_site

    Definir personas Como Entero;
    Definir precio, entradas, desc, total como Real;
	
    desc <- 0;
    precio <- 0;
    total <- 0;
	
    Escribir "Cantidad de personas : ";
    Leer personas;
	
    Escribir "Precio de entrada : ";
    Leer entradas;
	
    Si (personas >= 10 ) Entonces
        desc <- 0.50;
    SiNo
        Si (personas >= 4 y personas < 10 ) Entonces
            desc <- 0.35;
        SiNo
            Si (personas < 4) Entonces
                desc <- 0.20;				
            FinSi
        FinSi	
    FinSi
	
    precio <- personas * entradas;
    total <- precio - (precio * desc);
	
    Escribir "ENTRADA POR PERSONA : ", total/personas;
    Escribir "MONTO TOTAL : ", total;
	
FinProceso
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site