Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

19. En un hospital se ha hecho un estudio con el objeto de hacer una aproximación de los costos diarios de internamiento por paciente. Se obtuvo un costo promedio diario según el tiempo que el enfermo esta sin atención por una enfermedad que aqueja al paciente, además se pudo determinar que en promedio todos los pacientes con edad entre 17 y 25 años implican un costo adicional del 20%. La siguiente tabla expresa los costos diarios según el tipo de enfermedad.

Tiempo sin atención = Costo diario por paciente en soles
Menos de 1 hora = 3
De 1 hora a menos de 4 = 20
De 4 horas a menos de 10 = 25
De 10 horas a más = 40

Construir un algoritmo que permita ingresar el tiempo de exposición del paciente en horas y su edad para luego mostrar el costo diario de su hospitalización.



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_pseint_site
		
    Escribir "Tiempo de exposición del paciente : "
    Leer tiempo
	
    Escribir "Edad : "
    Leer edad
	
    Si (tiempo < 1) Entonces
        costo = 3
    SiNo	
        Si (tiempo >= 1 y tiempo < 4) Entonces
            costo = 20
        SiNo	
            Si (tiempo >= 4 y tiempo < 10) Entonces
                costo = 25
            SiNo	
                costo = 40
            FinSi		
        FinSi		
    FinSi
	
    Si (edad >=17 y edad <= 25) Entonces
        Escribir "Costo Diario de hospitalización : ", costo - (costo * 0.2)
    SiNo
        Escribir "Costo Diario de hospitalización : ", costo
    FinSi
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_pseint_site

    Definir tiempo, edad como Entero;
    Definir costo como Real;
	
    Escribir "Tiempo de exposición del paciente : ";
    Leer tiempo;
	
    Escribir "Edad : ";
    Leer edad;
	
    Si (tiempo < 1) Entonces
        costo <- 3;
    SiNo	
        Si (tiempo >= 1 y tiempo < 4) Entonces
            costo <- 20;
        SiNo	
            Si (tiempo >= 4 y tiempo < 10) Entonces
                costo <- 25;
            SiNo	
                costo <- 40;
            FinSi		
        FinSi		
    FinSi
	
    Si (edad >=17 y edad <= 25) Entonces
        Escribir "Costo Diario de hospitalización : ", costo - (costo * 0.2);
    SiNo
        Escribir "Costo Diario de hospitalización : ", costo;
    FinSi
	
FinProceso
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site