Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

14. Se desea comprar los siguientes objetos y se tiene descuentos en función de la cantidad de productos comprado. Hallar el valor original de la compra, hallar el descuento y valor final de la compra. Recuerde que solo se compra un artículo.

Artículos : Cuaderno(S/.3) - Libro(S/.35)
- % DE DESCUENTO MAS DE 24 UNIDADES : Cuaderno (11%) - Libro (18%)
- % DE DESCUENTO ENTRE 12 Y 24 UNIDADES : Cuaderno(6%) - Libro(8%)
- MENOS DE 12 UNIDADES NO HAY DESCUENTO


ANÁLISIS :

Lo primero dividir los procesos tanto para cuadernos como para libros mediante una pregunta para saber que compro; luego consultar si la cantidad de compra es mayor de 24 unidades para aplicar el descuento, sino no fue así, volver a consultar por las cantidades de compra ahora si están dentro del rango de 12 a 24 para aplicar el descuento, caso contrario tampoco este en el rango el descuento sería igual a cero; este mismo proceso se replica tanto para libros como para cuadernos.

ENTRADA :
Guardar el artículo de compra en la variable ART y la cantidad de compra en la variable cant.

SALIDA :
- Muestra el valor de compra multiplicando (cat x precio del artículo seleccionado)
- Muestra el descuento multiplicando el valor de compra por la variable descuento.
- Muestra el valor final restando el descuento al valor de compra.

PROCESO :
Se guarda el descuento en la variable dsct, luego de haber validado las cantidades de compra del artículo seleccionado; al final se muestra el valor a pagar restando el descuento al valor de compra.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_pseint_site

    Escribir "ARTÍCULO A COMPRAR : (1)Cuaderno (2)Libro :"
    Leer art
	
    Escribir "CANTIDAD : "
    Leer cant
	
    Si (art == 1) Entonces
        valorcomp = cant * 3
        Si (cant > 24) Entonces
            des = 0.11
        SiNo
            Si (cant >= 12 Y cant <= 24) Entonces
                des = 0.06
            FinSi
        FinSi
    SiNo
        valorcomp = cant * 35
        Si (cant > 24) Entonces
            des = 0.18
        SiNo
            Si (cant >= 12 Y cant <= 24) Entonces
                des = 0.08
            FinSi
        FinSi
    FinSi
	
    valorfinal = valorcomp - (valorcomp * des)
	
    Escribir "Valor Original de Compra : ", valorcomp
    Escribir "Descuento obtenido es el : ", des,"%"
    Escribir "Valor Final de la Compra : ", valorfinal
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_pseint_site
	
    Definir cant, art como Entero;
    Definir des, valorcomp, valorfinal como Real;
		
    valorcomp <- 0;
    valorfinal <- 0;
    des <- 0;
	
    Escribir "ARTÍCULO A COMPRAR : (1)Cuaderno (2)Libro :";
    Leer art;
	
    Escribir "CANTIDAD : ";
    Leer cant;
	
    Si (art == 1) Entonces
        valorcomp <- cant * 3;
        Si (cant > 24) Entonces
            des <- 0.11;
        SiNo
            Si (cant >= 12 Y cant <= 24) Entonces
                des <- 0.06;						
            FinSi
        FinSi
    SiNo
        valorcomp <- cant * 35;
        Si (cant > 24) Entonces
            des <- 0.18;
        SiNo
            Si (cant >= 12 Y cant <= 24) Entonces
                des <- 0.08;						
            FinSi
        FinSi
    FinSi
		
    valorfinal <- valorcomp - (valorcomp * des);
	
    Escribir "Valor Original de Compra : ", valorcomp;
    Escribir "Descuento obtenido es el : ", des,"%";
    Escribir "Valor Final de la Compra : ", valorfinal;
	
FinProceso
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site