Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

13. Elaborar un pseudocódigo donde se ingrese por teclado un número natural de hasta 2 cifras, si tiene una cifra muestre lo mínimo que le falta para ser un número de 2 cifras; de lo contrario muestre lo mínimo que le falta para ser un número de 3 cifras. Considerar que el usuario ingresa números de hasta dos cifras.


ANÁLISIS :

Para resolver este ejercicio tenemos que hacer una condición anidada, se debe preguntar que el número ingresado no sea mayor de tres cifras y consultar si es de una cifra, si se da el caso completamos el valor restando diez menos el valor ingresado para que sea de dos cifras o lo requerido para completar que sea de tres cifras.




DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++




PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo num_cifras
    Escribir "NUMERO: "
    Leer num
    Si num > 99 Entonces
        Escribir "ERROR... EL NUMERO SUPERA LAS 2 CIFRAS"
    SiNo		
        Si num < 10 Entonces
            Escribir "LE FALTA ", 10-num ," PARA 2 CIFRAS"
        SiNo
            Escribir "LE FALTA ", 100-num ," PARA 3 CIFRAS"
        FinSi		
    FinSi
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo num_cifras
    Definir num, cifras como Entero;
	
    Escribir "NUMERO: ";
    Leer num;		
    Si num > 99 Entonces
        Escribir "ERROR... EL NUMERO SUPERA LAS 2 CIFRAS";
    SiNo		
        Si num < 10 Entonces
            Escribir "LE FALTA ", 10-num ," PARA 2 CIFRAS";
        SiNo
            Escribir "LE FALTA ", 100-num ," PARA 3 CIFRAS";
        FinSi		
    FinSi	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
    int num, cifras;
	
    printf("13. MUESTRE LO FALTANTE PARA 2 o 3 CIFRAS.\n\n");    	    
    printf("Ingrese Numero : ");
    scanf("%i",&num);
    if (num > 99) {
        printf("\nERROR... EL NUMERO SUPERA LAS 2 CIFRAS");        
    }else{
        if (num < 10) {
            printf("\nLE FALTA %d PARA 2 CIFRAS", 10-num);
        }else{
            printf("\nLE FALTA %d PARA 3 CIFRAS", 100-num);
        }
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
    int num, cifras;
	    
    cout << "13. MUESTRE LO FALTANTE PARA 2 o 3 CIFRAS.\n\n";
    cout << "Ingrese Numero : ";
    cin >> num;
    cout << endl;
    if (num > 99) {
        cout << "ERROR... EL NUMERO SUPERA LAS 2 CIFRAS" << endl;      
    }else{
        if (num < 10) {
            cout << "LE FALTA " << 10-num << " PARA 2 CIFRAS" << endl;
        }else{
            cout << "LE FALTA " << 100-num << " PARA 3 CIFRAS"<< endl;
        }
    }
    return 0;
}
    

Python DESCARGA CÓDIGO


print("13. INGRESA UN NÚMERO Y MUESTRA LO QUE FALTA PARA 2 o 3 CIFRAS.")
num = int(input("INGRESE NÚMERO : "))
if num > 99:
    print("Error el número supera las 2 cífras.")
elif num < 10:
    print("LE FALTA ", 10-num, " PARA 2 CIFRAS.")
else:
    print("LE FALTA ", 100-num, " PARA 3 CIFRAS.")


Java NetBeans DESCARGA CÓDIGO

    
package www_pseint_site;
import java.util.Scanner;

public class Www_pseint_site {
    public static void main(String[] args) {
        Scanner ingreso=new Scanner(System.in);  
        
        int num;
        
        System.out.print("13. MOSTRAR EL VALOR FALTANTE PARA 2 o 3 CIFRAS.\n\n");
        System.out.print("Ingrese Número : ");
        num = Integer.parseInt(ingreso.next());                
        if(num > 99){
            System.out.println("Error... EL NÚMERO SUPERA lAS 2 CIFRAS.");       
        }else{
            if (num < 10) {
                System.out.println("LE FALTA " + (10-num) + " PARA 2 CIFRAS");
            }else{
                System.out.println("LE FALTA " + (100-num) + " PARA 3 CIFRAS");
            }
        }
    }   
}
    

VISUAL BASIC .NET - CONSOLA DESCARGA CÓDIGO

    
Imports System.Console
Module Ejercicio13
    Dim num As Integer
    Sub Main()
        WriteLine("13. INGRESE UN MONTO Y MUESTRE LO FALTANTE PARA 2 o 3 CIFRAS.")
        WriteLine("")
        Write("Ingrese Monto : ")
        num = ReadLine()
        WriteLine("")
        If (num > 99) Then
            WriteLine("ERROR... EL NUMERO SUPERA LAS 2 CIFRAS")
        Else
            If (num < 10) Then
                WriteLine("LE FALTA " & (10 - num) & " PARA 2 CIFRAS")
            Else
                WriteLine("LE FALTA " & (100 - num) & " PARA 3 CIFRAS")
            End If
        End If
        ReadLine()
    End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site