PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

13. Elaborar un pseudocódigo donde se ingrese por teclado un número natural de hasta 2 cifras, si tiene una cifra muestre lo mínimo que le falta para ser un número de 2 cifras; de lo contrario muestre lo mínimo que le falta para ser un número de 3 cifras. Considerar que el usuario ingresa números de hasta dos cifras.


ANÁLISIS :

Para resolver este ejercicio tenemos que hacer una condición anidada, se debe preguntar que el número ingresado no sea mayor de tres cifras y consultar si es de una cifra, si se da el caso completamos el valor restando diez menos el valor ingresado para que sea de dos cifras o lo requerido para completar que sea de tres cifras.




DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python




PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo num_cifras
    Escribir "NUMERO: "
    Leer num
    Si num > 99 Entonces
        Escribir "ERROR... EL NUMERO SUPERA LAS 2 CIFRAS"
    SiNo		
        Si num < 10 Entonces
            Escribir "LE FALTA ", 10-num ," PARA 2 CIFRAS"
        SiNo
            Escribir "LE FALTA ", 100-num ," PARA 3 CIFRAS"
        FinSi		
    FinSi
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo num_cifras
    Definir num, cifras como Entero;
	
    Escribir "NUMERO: ";
    Leer num;		
    Si num > 99 Entonces
        Escribir "ERROR... EL NUMERO SUPERA LAS 2 CIFRAS";
    SiNo		
        Si num < 10 Entonces
            Escribir "LE FALTA ", 10-num ," PARA 2 CIFRAS";
        SiNo
            Escribir "LE FALTA ", 100-num ," PARA 3 CIFRAS";
        FinSi		
    FinSi	
FinAlgoritmo
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site