PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896



Mostrar el número intermedio

08. Elaborar un programa que ingrese 3 números y muestre el número intermedio.


ANÁLISIS :

Hay muchas formas de desarrollar este ejercicio, en este caso lo que haremos será comparar cada número hasta obtener el intermedio:

Aplicaremos la lógica del primer diagrama de flujo:
Tomamos como referencia: N1 = 5, N2 = 3, N3=9; a simple vista el número intermedio sería 5.

Paso 1: Si ¿N1(5) es mayor que N2(3)?; “entonces MEDIO = N1 (5) y XTEM = N2(3)”; No aplicamos el caso contrario porque no se cumple.
Paso 2: Si ¿MEDIO(5) es mayor que N3(9)?, “NO SE CUMPLE”.
Paso 3: Si ¿MEDIO(5) es mayor que XTEM(2)?, “NO SE CUMPLE”.
Paso 4: Por lo tanto mostramos por pantalla el Número intermedio: MEDIO(5).

La base está en la primera consulta, dónde se toma el valor intermedio como referencia, para final mente compararlo con el último valor.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python





DIAGRAMA DE FLUJO - OPCIÓN 01:


DIAGRAMA DE FLUJO - OPCIÓN 02:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional08
    Escribir "Ingrese Número 01 : "
    Leer N1
    Escribir "Ingrese Número 02 : "
    Leer N2
    Escribir "Ingrese Número 03 : "
    Leer N3
    Si N1 > N2 Entonces
        MEDIO = N1
        XTEM = N2
    SiNo
        MEDIO = N2
        XTEM = N1
    Fin Si
    Si MEDIO > N3 Entonces
        MEDIO = N3
    Fin Si
    Si MEDIO < XTEM Entonces
        MEDIO = XTEM
    Fin Si
    Escribir "El número Medio es : ", MEDIO
FinAlgoritmo 
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional08
    Definir N1, N2, N3, MEDIO, XTEM como Entero;
    Escribir "Ingrese Número 01 : ";
    Leer N1;
    Escribir "Ingrese Número 02 : ";
    Leer N2;
    Escribir "Ingrese Número 03 : ";
    Leer N3;
    Si N1 > N2 Entonces
        MEDIO <- N1;
        XTEM <- N2;
    SiNo
        MEDIO <- N2;
        XTEM <- N1;
    FinSi
    Si MEDIO > N3 Entonces
        MEDIO <- N3;
    FinSi
    Si MEDIO < XTEM Entonces
        MEDIO <- XTEM;
    FinSi
    Escribir "El número Medio es : ", MEDIO;
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
    int medio, n1, n2, n3, xtem;
    printf("Ingrese Numero 01 : ");
    scanf("%i",&n1);
    printf("Ingrese Numero 02 : ");
    scanf("%i",&n2);
    printf("Ingrese Numero 03 : ");
    scanf("%i",&n3);
    if (n1>n2) {
        medio = n1;
        xtem = n2;
    } else {
        medio = n2;
        xtem = n1;
    }
    if (medio > n3) {
        medio = n3;
    }
    if (medio < xtem) {
        medio = xtem;
    }
    printf("\nEl Numero Medio es : %i\n",medio);
    return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
    int medio, n1, n2, n3, xtem;
    cout << "Ingrese Numero 01 : ";
    cin >> n1;
    cout << "Ingrese Numero 02 : ";
    cin >> n2;
    cout << "Ingrese Numero 03 : ";
    cin >> n3;
    if (n1>n2) {
        medio = n1;
        xtem = n2;
    } else {
        medio = n2;
        xtem = n1;
    }
    if (medio > n3) {
        medio = n3;
    }
    if (medio < xtem) {
        medio = xtem;
    }
    cout << endl << "El Numero Medio es : " << medio << endl;
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    print("Ingrese Número 01 : ")
    n1 = int(input())
    print("Ingrese Número 02 : ")
    n2 = int(input())
    print("Ingrese Número 03 : ")
    n3 = int(input())
    if n1>n2:
        medio = n1
        xtem = n2
    else:
        medio = n2
        xtem = n1
    if medio > n3:
        medio = n3
    if medio < xtem :
        medio = xtem
    print("El número Medio es : ",medio)
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional8 {
    public static void main(String[] args) {
        int N1, N2, N3, MEDIO, XTEM;
        Scanner ingreso=new Scanner(System.in);
        System.out.print("Ingrese Nro 01 : ");
        N1 = Integer.parseInt(ingreso.next());
        System.out.print("Ingrese Nro 02 : ");
        N2 = Integer.parseInt(ingreso.next());
        System.out.print("Ingrese Nro 03 : ");
        N3 = Integer.parseInt(ingreso.next());
        if(N1 > N2){
            MEDIO = N1;
            XTEM = N2;
        }else{
            MEDIO = N2;
            XTEM = N1;
        }
        if(MEDIO > N3){
            MEDIO = N3;
        }
        if(MEDIO < XTEM){
            MEDIO = XTEM;
        }
        System.out.println("EL NÚMERO MEDIO ES : " + MEDIO);
    }
}
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
<title>Ejercicio Condicional en JS - 08 </title>
<script language="JavaScript" type="text/javascript">
    function intermedio(){
    var xn1 = ejercicio8.n1.value;
    var xn2 = ejercicio8.n2.value;
    var xn3 = ejercicio8.n3.value;
    if(xn1 > xn2){
        medio = xn1;
        xtem = xn2;
    }else{
        medio = xn2;
        xtem = xn1;
    }
    if(medio > xn3){
        medio = xn3;
    }
    if(medio < xtem){
        medio = xtem;
    }
    document.getElementById('result').value=medio;
}
</script>
</head>
<body>
<form method="get" name="ejercicio8">
    INGRESE NUMERO 01 : <input name="n1" type="text" > <br>
    INGRESE NUMERO 02 : <input name="n2" type="text" > <br>
    INGRESE NUMERO 03 : <input name="n3" type="text" > <br>
    <input type="button" value="MOSTRAR" onClick="intermedio()" > <br> <br>
    EL NUMERO MEDIO ES: <input name="result" Id="result" type="text" > <br>
</form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module8
    Dim N1, N2, N3, Medio, XTem As Integer
    Sub Main()
        Write("Igrese Número 1 : ")
        N1 = ReadLine()
        Write("Igrese Número 2 : ")
        N2 = ReadLine()
        Write("Igrese Número 3 : ")
        N3 = ReadLine()
        If (N1 > N2) Then
            Medio = N1
            XTem = N2
        Else
            Medio = N2
            XTem = N1
        End If
        If (Medio > N3) Then
            Medio = N3
        End If
        If (Medio < XTem) Then
            Medio = XTem
        End If
        WriteLine("El Número Medio es : " & Medio)
        ReadLine()
    End Sub
End Module
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site