PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896



02. Ingresar un número y mostrar si es número par o impar.


ANÁLISIS :

¿Cómo determinar si un número es par?

Todo número que pueda dividirse entre 2 y si su residuo es igual a 0 es un número par, de lo contrario es un número impar.


🔴 USA EL OPERADOR MOD, para saber su es par o impar.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python





Diagrama de flujo(DFD) que muestra si es par o impar:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional02
    Escribir "Ingrese Número : "
    Leer num
	
    cociente <- redon(num / 2)
    residuo <- cociente * 2
    resultado <- num - residuo
		
    Si (resultado == 0) Entonces
        Escribir "NÚMERO PAR"
    SiNo
        Escribir "NÚMERO IMPAR"
    FinSi
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional02
    Definir num, cociente, residuo, resultado como Entero;
	
    Escribir "Ingrese Número : ";
    Leer num;
	
    cociente <- redon(num / 2);
    residuo <- cociente * 2;
    resultado <- num - residuo;
		
    Si (resultado == 0) Entonces
        Escribir "NÚMERO PAR";
    SiNo
        Escribir "NÚMERO IMPAR";
    FinSi
FinAlgoritmo    
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
  int num, cociente, residuo, resultado;
  printf("Ingrese Numero : ");
  scanf("%i",&num);
  cociente = num / 2;
  residuo = cociente * 2;
  resultado = num - residuo;
  if (resultado == 0) {
    printf("NUMERO PAR\n");
  } else {
    printf("NUMERO IMPAR\n");
  }
  return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
  int num, cociente, residuo, resultado;
  cout << "Ingrese Numero : ";
  cin >> num;
  cociente = num / 2;
  residuo = cociente * 2;
  resultado = num - residuo;
  if (resultado == 0) {
    cout << "NUMERO PAR" << endl;
  } else {
    cout << "NUMERO IMPAR" << endl;
  }
  return 0;
}
    

Python DESCARGA CÓDIGO

    
print("Ingrese Número : ")
num = int(input())
cociente = round(num / 2);
residuo = cociente * 2;
resultado = num - residuo;
if resultado == 0:
if resultado == 0:
  print("NÚMERO PAR")
else:
  print("NÚMERO IMPAR")
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional2 {
  public static void main(String[] args) {
    int num, cociente, residuo, resultado;
    Scanner ingreso=new Scanner(System.in);
    System.out.print("Ingrese Número : ");
    num = Integer.parseInt(ingreso.next());
    cociente = num / 2;
    residuo = cociente * 2;
    resultado = num - residuo;
    if(resultado == 0){
      System.out.println("NÚMERO PAR");
    }else{
      System.out.println("NÚMERO IMPAR");
    }
  }
}  
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
<title>Ejercicio Condicional en JS - 02:</title>
<script language="JavaScript" type="text/javascript">
  function par_impar(){
  var xnum = ejercicio2.num.value;
  var cociente=parseInt(xnum)/2;
  var residuo=parseInt(cociente)*2;
  var resultado=parseInt(xnum)-parseInt(residuo);
    if(resultado == 0){
      document.getElementById('result').value="NUMERO PAR";
    }else{
      document.getElementById('result').value="NUMERO IMPAR";
    }
  }
</script>
</head>
<body>
<form method="get" name="ejercicio2">
  INGRESE NÚMERO : <input name="num" type="text" > <br>
  <input type="button" value="OPERAR" onClick="par_impar()" > <br>
  RESULTADO : <input name="result" id="result" type="text" > <br>
</form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module2
  Dim Num, Cociente, Residuo, Resultado As Decimal
  Sub Main()
    Write("Ingrese Número : ")
    Num = ReadLine()
    Cociente = Num \ 2
    Residuo = Cociente * 2
    Resultado = Num - Residuo
    If (Resultado = 0) Then
      WriteLine("NÚMERO PAR")
    Else
      WriteLine("NÚMERO IMPAR")
    End If
    ReadLine()
  End Sub
End Module
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site