Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896


Mostrar si un número es capicúa

05. Diseñe un algoritmo que lea un número de tres cifras y determine si es o no capicúa.


ANÁLISIS :

Un número capicúa o capicúa es aquel que al intercambiar sus valores nos da el mismo número; en este caso vamos a descomponer el número obteniendo la unidad, decena y centena para luego intercambiar sus valores y compararlos con el valor inicial.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++





Diagrama de flujo(DFD) para mostrar número capicúa:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional05
     Escribir "Ingrese Número : "
     Leer Num
     C1 = (Num - (Num MOD 100)) / 100
     R1 = Num MOD 100
     C2 = (R1 - (R1 MOD 10)) / 10
     R2 = R1 MOD 10
     Si Num = ((R2 * 100) + (C2 * 10) + C1) Entonces
          Escribir "NÚMERO CAPICÚO"
     SiNo
          Escribir "NÚMERO NO CAPICÚO"
     Fin Si
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional05
     Definir Num, C1, R1, C2, R2 como Entero;
     Escribir "Ingrese Número : ";
     Leer Num;
     C1 <- (Num - (Num MOD 100)) / 100;
     R1 <- Num MOD 100;
     C2 <- (R1 - (R1 MOD 10)) / 10;
     R2 <- R1 MOD 10;
     Si Num = ((R2 * 100) + (C2 * 10) + C1) Entonces
          Escribir "NÚMERO CAPICÚO";
     SiNo
          Escribir "NÚMERO NO CAPICÚO";
     FinSi
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
     int c1, c2, num, r1, r2;
     printf("Ingrese Numero : \n");
     scanf("%i",&num);
     c1 = (num-(num%100))/100;
     r1 = num%100;
     c2 = (r1-(r1%10))/10;
     r2 = r1%10;
     if (num==((r2*100)+(c2*10)+c1)) {
          printf("NUMERO CAPICUO\n");
     } else {
          printf("NUMERO NO CAPICUO\n");
     }
     return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
     int c1, c2, num, r1, r2;
     cout << "Ingrese Numero : ";
     cin >> num;
     c1 = (num-(num%100))/100;
     r1 = num%100;
     c2 = (r1-(r1%10))/10;
     r2 = r1%10;
     if (num==((r2*100)+(c2*10)+c1)) {
          cout << "NUMERO CAPICUO" << endl;
     } else {
          cout << "NUMERO NO CAPICUO" << endl;
     }
     return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
     print("Ingrese Número : ")
     num = int(input())
     c1 = (num-(num%100))/100
     r1 = num%100
     c2 = (r1-(r1%10))/10
     r2 = r1%10
     if num==((r2*100)+(c2*10)+c1):
          print("NÚMERO CAPICÚO")
     else:
          print("NÚMERO NO CAPICÚO")
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional5 {
     public static void main(String[] args) {
          int num, C1,R1,C2,R2;
          Scanner ingreso=new Scanner(System.in);
          System.out.print("Ingrese número de 3 cifras : ");
          num = Integer.parseInt(ingreso.next());
          C1 = num / 100;
          R1 = num - (C1 * 100);
          C2 = R1 / 10;
          R2 = R1 - (C2 * 10);
          if(num == ((((R2*10)+C2)*10)+C1)){
               System.out.println("NÚMERO CAPICÚO");
          }else{
               System.out.println("NÚMERO NO CAPICÚO");
          }
    
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
<title>Ejercicio Condicional en JS - 05 </title>
<script language="JavaScript" type="text/javascript">
     function capicuo(){
     var xnum = ejercicio5.num.value;
     var c1 = parseInt(parseInt(xnum)/100);
     var r1 = parseInt(parseInt(xnum)-(parseInt(c1)*100));
     var c2 = parseInt(parseInt(r1)/10);
     var r2 = parseInt(parseInt(r1)-(parseInt(c2)*10));
          if(xnum == (r2+''+c2+''+c1)){
               document.getElementById('result').value="CAPICÚA";
          }else{
               document.getElementById('result').value="NO CAPICÚA";
          }
     }
</script>
</head>
<body>
<form method="get" name="ejercicio5">
     INGRESE NÚMERO : <input name="num" type="text" > <br>
     <input type="button" value="MOSTRAR" onClick="capicuo()" > <br>
     NÚMERO: <input name="result" id="result" type="text" > <br>
</form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module5
     Dim Num, C1, C2, R1, R2 As Integer
     Sub Main()
          Write("Ingrese Número de 3 Cifras : ")
          Num = ReadLine()
          C1 = Num \ 100
          R1 = Num - (C1 * 100)
          C2 = R1 \ 10
          R2 = R1 - (C2 * 10)
          If (Num = ((R2 * 100) + (C2 * 10) + C1)) Then
               WriteLine("NÚMERO CAPICÚO")
          Else
               WriteLine("NÚMERO NO CAPICÚO")
          End If
          ReadLine()
     End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site