Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

Muestra números de mayor a menor y viceversa

09. Programa un algoritmo que lea tres números y los imprima de mayor a menor y de menor a mayor.


ANÁLISIS :

Lo primero seria ordenar por descarte:
Por ejemplo: Si N1 > N2 y N1 > N3, sabemos que N1 es el mayor, por lo tanto faltaría preguntar si N2 > N3, si se da el caso que N2 es mayor que N3 fácil mente se sabe que : N1 es mayor, N2 es intermedio y N3 es el menor y se imprimen en ese orden.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++





Diagrama de flujo(DFD) para mostrar de mayor a menor y de menor a mayor:

DFD 1.0 DESCARGA CÓDIGO

VER CÓDIGO



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional09
  Escribir "Ingrese Número 01 : "
  Leer N1
  Escribir "Ingrese Número 02 : "
  Leer N2
  Escribir "Ingrese Número 03 : "	
  Leer N3	
  Si (N1 > N2) Y (N1 > N3) Entonces
	P = N1
	Si N2 > N3 Entonces
	  S = N2
	  T = N3
	SiNo
	  S = N3
	  T = N2
	Fin Si
  SiNo
	Si N2 > N3 Entonces
	  P = N2
	  Si N1 > N3 Entonces
		S = N1
		T = N3
	  SiNo
		S = N3
		T = N1
	  Fin Si			
	SiNo
	  P = N3
	  Si N1 > N2 Entonces
		S = N1
		T = N2
	  SiNo
		S = N2
		T = N1
	  Fin Si
	Fin Si		
  Fin Si
  Escribir "Descendente : ", P " - " S " - " T
  Escribir "Ascendente  : ", T " - " S " - " P
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional09
  Definir N1, N2, N3, S, T, P como Entero;
  Escribir "Ingrese Número 01 : ";
  Leer N1;
  Escribir "Ingrese Número 02 : ";
  Leer N2;
  Escribir "Ingrese Número 03 : ";
  Leer N3;
  Si (N1 > N2) Y (N1 > N3) Entonces
	P <- N1;
	Si N2 > N3 Entonces
 	  S <- N2;
	  T <- N3;
	SiNo
	  S <- N3;
	  T <- N2;
	FinSi
  SiNo
	Si N2 > N3 Entonces
	  P <- N2;
	  Si N1 > N3 Entonces
		S <- N1;
		T <- N3;
	  SiNo
	 	S <- N3;
		T <- N1;
	  FinSi			
    SiNo
	  P <- N3;
	  Si N1 > N2 Entonces
 	    S <- N1;
	    T <- N2;
	  SiNo
	    S <- N2;
	    T <- N1;
	  FinSi
    FinSi		
  FinSi
  Escribir "Descendente : ", P, " - ", S, " - ", T;
  Escribir "Ascendente  : ", T, " - ", S, " - ", P;
FinAlgoritmo

    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
  int n1, n2, n3, p,s, t;
  printf("Ingrese Número 01 : ");
  scanf("%i",&n1);
  printf("Ingrese Número 02 : ");
  scanf("%i",&n2);
  printf("Ingrese Número 03 : ");
  scanf("%i",&n3);
  if ((n1>n2) && (n1>n3)) {
	p = n1;
	if (n2>n3) {
	  s = n2; t = n3;
	} else {
	  s = n3; t = n2;
	}
  } else {
	if (n2>n3) {
	  p = n2;
	  if (n1>n3) {
	    s = n1; t = n3;
	  } else {
	    s = n3; t = n1;
	  }
	} else {
	  p = n3;
	  if (n1>n2) {
	    s = n1; t = n2;
	  } else {
	    s = n2; t = n1;
	  }
	}
  }
  printf("Descendente : %i-%i-%i\n",p,s,t);
  printf("Ascendente  : %i-%i-%i\n",t,s,p);
  return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
  int n1, n2, n3, p,s, t;
  cout << "Ingrese Número 01 : ";
  cin >> n1;
  cout << "Ingrese Número 02 : ";
  cin >> n2;
  cout << "Ingrese Número 03 : ";
  cin >> n3;
  if ((n1>n2) && (n1>n3)) {
    p = n1;
	if (n2>n3) {
	  s = n2; t = n3;
	} else {
	  s = n3; t = n2;
	}
  } else {
	if (n2>n3) {
	  p = n2;
	  if (n1>n3) {
	    s = n1; t = n3;
	  } else {
		s = n3; t = n1;
	  }
	} else {
	  p = n3;
	  if (n1>n2) {
		s = n1;	t = n2;
	  } else {
		s = n2; t = n1;
	  }
	}
  }
  cout << "Descendente : " << p << " - " << s << " - " << t << endl;
  cout << "Ascendente  : " << t << " - " << s << " - " << p << endl;
  return 0;
}
    

Python DESCARGA CÓDIGO

    
print("Ingrese Número 01 : ")
n1 = int(input())
print("Ingrese Número 02 : ")
n2 = int(input())
print("Ingrese Número 03 : ")
n3 = int(input())
if (n1>n2) and (n1>n3):
  p = n1
  if n2>n3:
	s = n2 
	t = n3
  else:
	s = n3
	t = n2
  else:
	if n2>n3:
	  p = n2
	  if n1>n3:
		s = n1
		t = n3
	  else:
		s = n3
		t = n1
	else:
	  p = n3
	  if n1>n2:
		s = n1
		t = n2
	  else:
		s = n2
		t = n1
print("Descendente : ",p," - ",s," - ",t)
print("Ascendente  : ",t," - ",s," - ",p)       
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional9 {
  public static void main(String[] args) {
    int N1, N2, N3, P, S, T;
    Scanner ingreso=new Scanner(System.in);
    System.out.print("Ingrese Nro 01 : ");
    N1 = Integer.parseInt(ingreso.next()); 
    System.out.print("Ingrese Nro 02 : ");
    N2 = Integer.parseInt(ingreso.next()); 
    System.out.print("Ingrese Nro 03 : ");
    N3 = Integer.parseInt(ingreso.next());                         
    if((N1 > N2) && (N1 > N3)){
      P = N1;            
      if(N2 > N3){
        S = N2;
        T = N3;
      }else{
        S = N3;
        T = N2;
      }             
    }else{
      if(N2 > N3){
        P = N2;
        if(N1 > N3){
          S = N1;
          T = N3;                
        }else{
          S = N3;
          T = N1;
        }                 
      }else{
        P = N3;
        if(N1 > N2){
          S = N1;
          T = N2;                
        }else{
          S = N2;
          T = N1;
        } 
      } 
    }          
  System.out.println("DESCENDENTE : " + P + "," + S + "," + T);
  System.out.println("ASCENDENTE : " + T + "," + S + "," + P);        
  }     
}
    

Java Script DESCARGA CÓDIGO

    
<html>
  <title>Ejercicio Condicional en JS - 09</title>
<head>
<script language="JavaScript" type="text/javascript">
  function mayor_menor(){
  var xn1 = ejercicio9.n1.value;
  var xn2 = ejercicio9.n2.value;
  var xn3 = ejercicio9.n3.value;  
    if((xn1 > xn2)&&(xn1 > xn3)){
      p = xn1;
      if(xn2 > xn3){
      s = xn2; t = xn3;     
    }else{
      s = xn3; t = xn2;     
    }     
  }else{
    if(xn2 > xn3){
      p = xn2;
      if(xn1 > xn3){
        s = xn1; t = xn3;     
      }else{
        s = xn3; t = xn1;     
      }     
    }else{ p = xn3;
      if(xn1 > xn2){
        s = xn1; t = xn2;     
      }else{
        s = xn2; t = xn1;     
      }     
    }     
  }          
  document.getElementById('result1').value=p + " , " + s + " , " + t;
  document.getElementById('result2').value=t + " , " + s + " , " + p;   
}
</script>
</head>
<body>
  <form method="get" name="ejercicio9">
    INGRESE NUMERO 01 : <input name="n1" type="text" > <br>
    INGRESE NUMERO 02 : <input name="n2" type="text" > <br>
    INGRESE NUMERO 03 : <input name="n3" type="text" > <br>
 	<input type="button" value="MOSTRAR" onClick="mayor_menor()" > <br> <br>
	DESCENDENTE: <input name="result1" id="result1" type="text" > <br>
	ASCENDENTE: <input name="result2" id="result2" type="text" > <br>
  </form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module9
  Dim N1, N2, N3, P, S, T As Integer
  Sub Main()
    Write("Igrese Número 1 : ")
    N1 = ReadLine()
    Write("Igrese Número 2 : ")
    N2 = ReadLine()
    Write("Igrese Número 3 : ")
    N3 = ReadLine()
    If ((N1 > N2) And (N1 > N3)) Then
      P = N1
      If (N2 > N3) Then
        S = N2
        T = N3
      Else
        S = N3
        T = N2
      End If
    Else
      If (N2 > N3) Then
        P = N2
        If (N1 > N3) Then
          S = N1
          T = N3
        Else
          S = N3
          T = N1
        End If
      Else
        P = N3
        If (N1 > N2) Then
          S = N1
          T = N2
        Else
          S = N2
          T = N1
        End If
      End If
    End If
    WriteLine("Descendente : " & P & " " & S & " " & T)
    WriteLine("Ascendente : " & T & " " & S & " " & P)
    ReadLine()
  End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site