PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

15. Se lee el código del empleado, número de horas trabajadas, sueldo por hora. Calcular el pago neto considerando la siguiente tabla de descuento:

Sueldo Base = Descuento
Menor 500 = 0
Entre 501 y 1000 = 2%
Entre 1001 y 4000 = 8%
Entre 4001 y 8000 = 15%
Mayor a 8000 = 30%


ANÁLISIS :

Debemos multiplicar la cantidad de horas trabajadas por el costo por hora para obtener el - sueldo base -, según este resultado asignar el descuento, en base a las múltiples condiciones anidadas que están en la tabla; al final mostrara el Pago Neto en base al - sueldo base menos el descuento.

ENTRADA : Ingrese código (código), la cantidad de horas trabajadas (hrs) y el sueldo por hora (suehr)
SALIDA : Muestra el Pago Neto = (Sueldo Base - Descuento).
PROCESO : Lo importante es obtener el descuento, para ello se considera el sueldo base según las condiciones de la tabla.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_pseint_site
		
    Escribir Sin Saltar "Código : "
    Leer codigo
	
    Escribir Sin Saltar "Horas Trabajadas : "
    Leer hrs
	
    Escribir Sin Saltar "Sueldo x Hora : "
    Leer suehr
	
    sueldo = hrs * suehr
	
    Si (sueldo < 500) Entonces
        desc = 0
    SiNo	
        Si (sueldo >= 501 y sueldo <= 1000) Entonces
            desc = 0.02
        SiNo
            Si (sueldo >= 1001 y sueldo <= 4000) Entonces
                desc = 0.08
            SiNo
                Si (sueldo >= 4001 y sueldo <= 8000) Entonces
                    desc = 0.15
                SiNo
                    desc = 0.30
                FinSi
            FinSi
        FinSi
    FinSi	
	
    Escribir ""
    Escribir "Sueldo Base         : $", sueldo
    Escribir "Descuento del ",desc,"% : $",(sueldo * desc)
    Escribir "Pago Neto           : $", sueldo - (sueldo * desc)
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_pseint_site

    Definir hrs como Entero;
    Definir desc, suehr, sueldo como Real;
    Definir codigo como Caracter;
	
    desc <- 0;
    sueldo <- 0;
	
    Escribir "Código : ";
    Leer codigo;
	
    Escribir "Horas Trabajadas : ";
    Leer hrs;
	
    Escribir "Sueldo x Hora : ";
    Leer suehr;
	
    sueldo <- hrs * suehr;
	
    Si (sueldo < 500) Entonces
        desc <- 0;
    SiNo	
        Si (sueldo >= 501 y sueldo <= 1000) Entonces
            desc <- 0.02;
        SiNo
            Si (sueldo >= 1001 y sueldo <= 4000) Entonces
                desc <- 0.08;
            SiNo
                Si (sueldo >= 4001 y sueldo <= 8000) Entonces
                    desc <- 0.15;
                SiNo
                    desc <- 0.30;
                FinSi
            FinSi
        FinSi
    FinSi	
	
    Escribir "";
    Escribir "Sueldo Base         : $", sueldo;
    Escribir "Descuento del ",desc,"% : $",(sueldo * desc) ;
    Escribir "Pago Neto           : $", sueldo - (sueldo * desc);
	
FinProceso
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site