PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

10. Dado un monto calcular el descuento:

• 25% si el monto es mayor o igual que 300.
• 20% si el monto es mayor que 150 y menor que 300.
no hay descuento si el monto es menor a 150.

Obtén el descuento de un monto según la condición.


ANÁLISIS :

Para este ejercicio evaluamos la primera condición :
Si el monto es mayor que 300 aplicamos el 25%; caso contrario realizamos una nueva consulta o consulta anidada para conocer si el monto se encuentra en el rango de 150 a 300; para ello aplicaremos (monto > 150 y monto < 300), si se considera que se encuentra en ese rango se aplica el 20% de descuento, caso contrario no se aplica ningún descuento, ya que se entiende que el monto es menor que 150.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python





Algoritmo para calcular el decuento:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional10
     Escribir "Ingrese Monto : "
     Leer Monto
     Si Monto > 300 Entonces
          Descuento = Monto * 0.25
          Escribir "El Descuento es : ", Descuento
     SiNo
          Si (Monto > 150) Y (Monto < 300) Entonces
               Descuento = Monto * 0.02
               Escribir "El Descuento es : ", Descuento
          SiNo
               Escribir "No Hay Descuento"
          Fin Si
     Fin Si
FinAlgoritmo        
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional10
     Definir Monto, Descuento como Real;
     Escribir "Ingrese Monto : ";
     Leer Monto;
     Si Monto > 300 Entonces
          Descuento <- Monto * 0.25;
          Escribir "El Descuento es : ", Descuento;
     SiNo
          Si (Monto > 150) Y (Monto < 300) Entonces
               Descuento <- Monto * 0.02;
               Escribir "El Descuento es : ", Descuento;
          SiNo
               Escribir "No Hay Descuento";
          FinSi
     FinSi
FinAlgoritmo        
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
     float descuento, monto;
     printf("Ingrese Monto : ");
     scanf("%f",&monto);
     if (monto>300) {
          descuento = monto*0.25;
          printf("El Descuento es : %.2f\n",descuento);
     } else {
          if ((monto>150) && (monto<300)) {
               descuento = monto*0.02;
               printf("El Descuento es : %.2f\n",descuento);
          } else {
               printf("No Hay Descuento\n");
          }
     }
     return 0;
}        
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
     float descuento, monto;
     cout << "Ingrese Monto : ";
     cin >> monto;
     if (monto>300) {
          descuento = monto*0.25;
          cout << "El Descuento es : " << descuento << endl;
     } else {
          if ((monto > 150) && (monto < 300)) {
               descuento = monto*0.02;
               cout << "El Descuento es : " << descuento << endl;
          } else {
               cout << "No Hay Descuento" << endl;
          }
     }
     return 0;
}        
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
     print("Ingrese Monto : ")
     monto = float(input())
     if monto>300:
          descuento = monto*0.25
          print("El Descuento es : ",descuento)
     else:
          if (monto > 150) and (monto < 300):
               descuento = monto*0.02
               print("El Descuento es : ",descuento)
          else:
               print("No Hay Descuento")        
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional10 {
     public static void main(String[] args) {
          Double MONTO, DESCUENTO;
          Scanner ingreso=new Scanner(System.in);
          System.out.print("Ingrese Monto : ");
          MONTO = Double.parseDouble(ingreso.next());
          if(MONTO >= 300){
               DESCUENTO = MONTO * 0.25;
               System.out.println("EL DESCUENTO ES : " + DESCUENTO);
          }else{
               if((MONTO > 150) && (MONTO < 300)){
                    DESCUENTO = MONTO * 0.2;
                    System.out.println("EL DESCUENTO ES : " + DESCUENTO);
               }else{
                    System.out.println("NO HAY DESCUENTO");
               }
          }
     }
}        
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
     <title>Ejercicio Condicional en JS - 10 </title>
     <script language="JavaScript" type="text/javascript">
     function ver_descuento(){
     var xmonto = ejercicio10.monto.value;
          if(xmonto >= 300){
               descuento = xmonto * 0.25;
               document.getElementById('result').value=descuento;
          }else{
               if(xmonto > 150 && xmonto < 300){
                    descuento = xmonto * 0.20;
                    document.getElementById('result').value=descuento;
               }else{
                    document.getElementById('result').value="NO HAY DESCUENTO";
               }
          }
     }
    </script>
</head>
<body>
     <form method="get" name="ejercicio10">
          INGRESE MONTO : <input name="monto" type="text" > <br>
          <input type="button" value="MOSTRAR" onClick="ver_descuento()"> <br>
          EL DESCUENTO ES: <input name="result" id="result" type="text" > <br>
     </form>
</body>
</html>        
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module10
     Dim Monto, Descuento As Decimal
     Sub Main()
          Write("Ingrese Monto : ")
          Monto = ReadLine()
          If (Monto >= 300) Then
               Descuento = Monto * 0.25
               WriteLine("El Descuento es : " & Descuento)
          Else
               If ((Monto > 150) And (Monto < 300)) Then
                    Descuento = Monto * 0.2
                    WriteLine("El Descuento es : " & Descuento)
               Else
                    WriteLine("No Hay Descuento")
               End If
          End If
          ReadLine()
     End Sub
End Module        
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site