PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896



Algoritmo para crear un login o inicio de sesión

03. Elaborar un programa que simule una clave de acceso. Si el usuario es: "ADMIN" y la clave "123456" mostrar el mensaje "ACCESO PERMITIDO" caso contrario mostrar el mensaje "ACCESO DENEGADO".


ANÁLISIS :

Para este ejercicio usaremos una estructura condicional simple que permita realizar dos consultas, por el usuario y la clave; ambas consultas necesariamente debén de ser correctas y es necesario usar el operador lógico "Y".


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python





Diagrama de flujo(DFD) de un Login:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional03
     Escribir "Ingrese Usuario : "
     Leer Usuario
     Escribir "Ingrese Clave : "
     Leer Clave
     Si (Usuario = "ADMIN" Y Clave = 123456 ) Entonces
          Escribir "ACCESO PERMITIDO"
     SiNo
          Escribir "ACCESO DENEGADO"
     Fin Si
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional03
     Definir Usuario como Caracter;
     Definir Clave como Entero;
     Escribir "Ingrese Usuario : ";
     Leer Usuario;
     Escribir "Ingrese Clave : ";
     Leer Clave;
     Si (Usuario = "ADMIN" Y Clave = 123456 ) Entonces
          Escribir "ACCESO PERMITIDO";
     SiNo
          Escribir "ACCESO DENEGADO";
     FinSi
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
#include<string.h>
#define MAX_STRLEN 256
int main() {
     int clave;
     char usuario[MAX_STRLEN];
     printf("Ingrese Usuario : ");
     scanf("%s",usuario);
     printf("Ingrese Clave : ");
     scanf("%i",&clave);
     if ((strcmp(usuario,"ADMIN")==0 && clave==123456)) {
          printf("ACCESO PERMITIDO\n");
     } else {
          printf("ACCESO DENEGADO\n");
     }
     return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
     int clave;
     string usuario;
     cout << "Ingrese Usuario : ";
     cin >> usuario;
     cout << "Ingrese Clave : " ;
     cin >> clave;
     if ((usuario=="ADMIN" && clave==123456)) {
          cout << "ACCESO PERMITIDO" << endl;
     } else {
          cout << "ACCESO DENEGADO" << endl;
     }
     return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
     print("Ingrese Usuario : ")
     usuario = input()
     print("Ingrese Clave : ")
     clave = int(input())
     if (usuario=="ADMIN" and clave==123456):
          print("ACCESO PERMITIDO")
     else:
          print("ACCESO DENEGADO")
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional3 {
public static void main(String[] args) {
     String usuario;
     int clave;
     Scanner ingreso=new Scanner(System.in);
     System.out.print("Ingrese Usuario : ");
     usuario = ingreso.next();
     System.out.print("Ingrese Clave : ");
     clave = Integer.parseInt(ingreso.next());
     if(usuario.equals("ADMIN") && clave == 123456){
          System.out.println("ACCESO PERMITIDO");
     }else{
          System.out.println("ACCESO DENEGADO");
     }
}
}        
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
<title>Ejercicio Condicional en JS - 03:</title>
<script language="JavaScript" type="text/javascript">
     function acceso(){
     var xusuario = ejercicio3.usuario.value;
     var xclave = ejercicio3.clave.value;
          if(xusuario == "ADMIN" && xclave == 123456){
               document.getElementById('result').value="ACCESO PERMITIDO";
          }else{
               document.getElementById('result').value="ACCESO DENEGADO";
          }
     }
</script>
</head>
<body>
<form method="get" name="ejercicio3">
     INGRESE USUARIO : <input name="usuario" type="text" > <br>
     INGRESE CLAVE : <input name="clave" type="text" > <br>
     <input type="button" value="ACCESO" onClick="acceso()" > <br>
     MOSTRAR : <input name="result" id="result" type="text" > <br>
</form>
</body>
</html>     
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

    
Imports System.Console
Module Module3
Dim Usuario As String
Dim Clave As Integer
Sub Main()
     Write("Ingrese Usuario : ")
     Usuario = ReadLine()
     Write("Ingrese Clave : ")
     Clave = ReadLine()
     If (Usuario = "ADMIN" And Clave = 123456) Then
          WriteLine("ACCESO PERMITIDO")
     Else
          WriteLine("ACCESO DENEGADO")
     End If
     ReadLine()
End Sub
End Module        
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site