Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896


Calcular el promedio de tres notas.

01. Hacer un programa para calcular el promedio de 3 notas; si el promedio es mayor que 10.5 mostrar aprobado de lo contrario mostrar desaprobado.


ANÁLISIS :

Para obtener el promedio se suman las notas y se divide entre la cantidad de notas; en nuestro caso nuestra evaluación es de 0 a 20; dónde de 0 a 10 es desaprobado y 11 a 20 es aprobado; por lo tanto, si la nota es mayor que 10 mostrará el mensaje de aprobado caso contrario desaprobado.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++





Diagrama de flujo(DFD) para calcular el promedio de 3 notas:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Condicional01
     Escribir "Ingrese Nota 01 : "
     Leer N1
     Escribir "Ingrese Nota 02 : "
     Leer N2
     Escribir "Ingrese Nota 03 : "
     Leer N3
     Prom = (N1+N2+N3)/3
     Si Prom > 10.5 Entonces
          Escribir "APROBADO : ", Prom
     SiNo
          Escribir "DESAPROBADO : ", Prom
     Fin Si
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Condicional01
     Definir N1, N2, N3 como Entero;
     Definir Prom como Real;
     Escribir "Ingrese Nota 01 : ";
     Leer N1;
     Escribir "Ingrese Nota 02 : ";
     Leer N2;
     Escribir "Ingrese Nota 03 : ";
     Leer N3;
     Prom <- (N1+N2+N3)/3;
     Si Prom > 10.5 Entonces
          Escribir "APROBADO : ", Prom;
     SiNo
          Escribir "DESAPROBADO : ", Prom;
     FinSi
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
int main() {
     float n1, n2, n3, prom;
     printf("Ingrese Nota 01 : ");
     scanf("%f",&n1);
     printf("Ingrese Nota 02 : ");
     scanf("%f",&n2);
     printf("Ingrese Nota 03 : ");
     scanf("%f",&n3);
     prom = (n1+n2+n3)/3;
     if (prom>10.5) {
          printf("APROBADO : %.2f\n",prom);
     } else {
          printf("DESAPROBADO : %.2f\n",prom);
     }
     return 0;
}
    

C++ DESCARGA CÓDIGO

    
#include<iostream>
using namespace std;
int main() {
     float n1, n2, n3, prom;
     cout << "Ingrese Nota 01 : ";
     cin >> n1;
     cout << "Ingrese Nota 02 : ";
     cin >> n2;
     cout << "Ingrese Nota 03 : ";
     cin >> n3;
     prom = (n1+n2+n3)/3;
     if (prom>10.5) {
          cout << "APROBADO : " << prom << endl;
     } else {
          cout << "DESAPROBADO : " << prom << endl;
     }
     return 0;
}        
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
     print("Ingrese Nota 01 : ")
     n1 = int(input())
     print("Ingrese Nota 02 : ")
     n2 = int(input())
     print("Ingrese Nota 03 : ")
     n3 = int(input())
     prom = (n1+n2+n3)/3
     if prom>10.5:
          print("APROBADO : ",prom)
     else:
          print("DESAPROBADO : ",prom)
    

Java NetBeans DESCARGA CÓDIGO

    
package Condicional;
import java.util.Scanner;
public class condicional1 {
     public static void main(String[] args) {
        double prom, n1, n2, n3;
        Scanner ingreso=new Scanner(System.in);
        System.out.print("Ingrese Nota 1:");
        n1 = Integer.parseInt(ingreso.next());
        System.out.print("Ingrese Nota 2:");
        n2 = Integer.parseInt(ingreso.next());
        System.out.print("Ingrese Nota 3:");
        n3 = Integer.parseInt(ingreso.next());
        prom = (n1 + n2 + n3)/3;
        if(prom >= 10.5){
            System.out.println("APROBADO : " + prom);
        }else{
            System.out.println("DESAPROBADO : " + prom);
        }
     }
}
    

Java Script DESCARGA CÓDIGO

    
<html>
<head>
     <title>Ejercicio Condicional en JS - 01:</title>
     <script language="JavaScript" type="text/javascript">
     function resultado(){
     var xn1=ejercicio1.n1.value;
     var xn2=ejercicio1.n2.value;
     var xn3=ejercicio1.n3.value;
     var xresul = (parseFloat(xn1)+parseFloat(xn2)+parseFloat(xn3))/3;
     if(xresul > 10){
          document.getElementById('result').value="APROBADO";
     }else{
          document.getElementById('result').value="DESAPROBADO";
     }
     }
</script>
</head>
<body>
<form method="get" name="ejercicio1">
     INGRESE NOTA 01 : <input name="n1" type="text" > <br>
     INGRESE NOTA 02 : <input name="n2" type="text" > <br>
     INGRESE NOTA 03 : <input name="n3" type="text" > <br>
     <input type="button" value="OPERAR" onClick="resultado()" > <br>
     RESULTADO : <input name="result" id="result" type="text" > <br>
</form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

       
Imports System.Console
Module Module1
Dim Prom, N1, N2, N3 As Decimal
Sub Main()
     Write("Ingrese Nota 1 : ")
     N1 = ReadLine()
     Write("Ingrese Nota 2 : ")
     N2 = ReadLine()
     Write("Ingrese Nota 3 : ")
     N3 = ReadLine()
     Prom = (N1 + N2 + N3) / 3
     If (Prom > 10.5) Then
          WriteLine("APROBADO : " & Prom)
     Else
          WriteLine("DESAPROBADO : " & Prom)
     End If
     ReadLine()
End Sub
End Module        
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site