Construir un pseudocódigo que permita ingresar un número, si el número es mayor de 500, se debe calcular y mostrar en pantalla el 18% de este

¡Haz clic para puntuar este proyecto!
(Votos: 6 Promedio: 1.8)
¿En que programa quieres ver el Código? :

    Pseudocódigo

    INICIO
        VARIABLES : NUM  // De tipo Entero
        MOSTRAR -> "INGRESE NÚMERO : "
        LEER <- NUM
        Si (NUM > 500)
            MOSTRAR -> "EL 18% ES : ", (NUM * 0.18)
        Fin de Si
    FIN
    

    Diagrama de flujo(DFD)

    PSEINT FLEXIBLE

    Algoritmo www_PSeint_Site
        Escribir "12. MOSTRAR EL 18% SI EL MONTO INGRESADO ES MAYOR A $500."
        Escribir " "
        Escribir Sin Saltar "INGRESE MONTO : $"
        Leer num
        Si num > 500 Entonces
            Escribir "EL 18% ES : $", num * 0.18
        FinSi
    FinAlgoritmo
    

    Lenguaje C

    #include<stdio.h>
    int main() {
        float num;
        printf("12. MOSTRAR EL 18 PORCIENTO.\n\n");    	    
        printf("Ingrese Numero : ");
        scanf("%f",&num);
        if (num >= 500) {
            printf("\nRESULTADO : %.0f", (num * 0.18));    
        }
        return 0;
    }
    

    C++

    #include<iostream>
    using namespace std;
    int main() {
        int num;
        cout << "12. MOSTRAR EL 18 PORCIENTO.\n\n";
        cout << "Ingrese Numero : ";
        cin >> num;
        cout << endl;
        if (num >= 500) {
            cout << "RESULTADO : " << (num * 0.18) << endl;
        }
        return 0;
    }
    

    Python

    print("12. INGRESAR UN MONTO DE DINERO Y MOSTRAR EL 18%.")
    num = int(input("INGRESE MONTO : "))
    if num > 500:
        print("EL 18% ES : ", num * 0.18)
    

    Java NetBeans

    package www_pseint_site;
    import java.util.Scanner;
    
    public class Www_pseint_site {
        public static void main(String[] args) {
            Scanner ingreso=new Scanner(System.in);  
            int num;
            System.out.print("12. MOSTRAR EL 18% DE UN MONTO INGRESADO.\n\n");
            System.out.print("Ingrese Número : ");
            num = Integer.parseInt(ingreso.next());                
            if(num > 500){
              System.out.println("EL 18% ES : " + (num * 0.18));       
            }
        }   
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir