Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

18. El dueño de un spa necesita determinar cuánto debe cobrar por el uso de sus instalaciones a sus clientes, de acuerdo al tiempo de uso y al número de personas que ingresan. Las tarifas que se tienen son las siguientes: Hasta 3 horas a $5.00 por persona para 5 personas o menos. Hasta 3 horas a $3.00 por persona desde 6 personas en adelante, de 4 horas en adelante a $4.00 por persona para 5 personas o menos. De 4 horas en adelante a $2.00 por persona para 6 personas en adelante


ANÁLISIS :

Para este ejercicio se debe plantear una estructura condicional anidada, tomaremos el tiempo como condicón principal y luego consultaremos por las cantidades de personas para determinar el costo.

ENTRADA : Cantidad de personas (nroper), tiempo de uso de las instalaciones (tiempo).
SALIDA : Costo por persona por el uso de instalaciones (costo).
PROCESO : Realizar las condiciones empezando por el tiempo de uso y luego por el número de personas, para obtener el costo por persona.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_pseint_site
		
    Escribir "CANTIDAD DE PERSONAS : "
    Leer nroper
	
    Escribir "TIEMPO DE USO : "
    Leer tiempo
	
    Si (tiempo <= 3) Entonces		
        Si (nroper <= 5) Entonces
            costo = 5
        SiNo
            costo = 3
        FinSi		
    SiNo		
        Si (nroper <= 5) Entonces
            costo = 4
        SiNo
            costo = 2
        FinSi		
    FinSi
	
    Escribir "COSTO DE INSTALACIONES : $" , costo, " POR PERSONA"
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_pseint_site

    Definir tiempo, nroper como Entero;
    Definir costo como Real;
	
    costo <- 0;
	
    Escribir "CANTIDAD DE PERSONAS : ";
    Leer nroper;
	
    Escribir "TIEMPO DE USO : ";
    Leer tiempo;
	
    Si (tiempo <= 3) Entonces		
        Si (nroper <= 5) Entonces
            costo <- 5;
        SiNo
            costo <- 3;
        FinSi		
    SiNo		
        Si (nroper <= 5) Entonces
            costo <- 4;
        SiNo
            costo <- 2;
        FinSi		
    FinSi
	
    Escribir "COSTO DE INSTALACIONES : $" , costo, " POR PERSONA";
	
FinProceso
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site