FUNCIÓN LONGITUD()

DESARROLLO DE ALGORITMOS (+51) 954263896

La función Longitud retorna un número entero, con la cantidad de caracteres que contiene la variable.

INGRESO : NOM <- "PSEINT"
PROCESO : LONGITUD(NOM)
SALIDA : 6


DESCARGA CÓDIGOS

  Lenguaje C
  C++



PSEINT FLEXIBLE

    
Algoritmo Funcion_Longitud    
    //CASO 01
    nom = "PSEINT"; 
    Escribir LONGITUD(nom);	// RESULTADO 6
	
    //CASO 02
    Escribir "Ingrese Texto:";
    Leer nom2;	
    result = LONGITUD(nom2);
    Escribir result;
FinAlgoritmo    
    

PSEINT ESTRICTO

    
Algoritmo Funcion_Longitud
    //CASO 01
    Definir nom como Caracter;
    nom <- "PSEINT";	
    Escribir LONGITUD(nom); // RETORNA 6
	
    //CASO 02
    Definir resul como Entero;	
    Definir nom2 como caracter;	
    Escribir "Ingrese Texto:";
    Leer nom2;	
    resul <- LONGITUD(nom2);	
    Escribir resul;		
FinAlgoritmo
    

LENGUAJE C - strlen(nom)

    	   
#include<stdio.h>
int main() {
    //CASO 01
    char nom[]="PSEINT";		
    printf("%d", strlen(nom));	//RESULTADO -> 6
    
    //CASO 02
    char nom2[]="";
    int result;
    printf("\nIngrese Texto: ");	
    scanf("%s",nom2);
    result = strlen(nom2);
    printf("%d",result);
    
    return 0;
}
    

C++ - nom.size()

    	   
#include<iostream>
using namespace std;
int main() {
    //CASO 01
    string nom;
    nom = "PSEINT";	
    cout << nom.size();	//SALIDA --> 6
    
    //CASO 02
    string nom2;
    int resul;    
    cout << "\nIngrese Texto: ";
    cin >> nom2;
    resul = nom2.size();
    cout << resul;
       
    return 0;
}
    

PYTHON - len(nom)

    	   
'CASO 01'
nom = "PSEINT"
print(len(nom))

'CASO 02'
print("Ingrese Texto:")
nom2 = input()
result = len(nom2)
print(result)
    

JAVA NETBEANS - nom.length()

    
//CASO 01
package cadenas;
public class funciones {
    public static void main(String[] args) {
        String nom;
        nom = "PSEINT";
        System.out.println(nom.length());
    }  
}
	
    
//CASO 02
package cadenas;
import java.util.Scanner;
public class funciones {
    public static void main(String[] args) {
        Scanner leer=new Scanner(System.in);    
        String nom2;
        int result;
        System.out.print("Ingrese Texto: ");
        nom2 = leer.next();
        result = nom2.length();
        System.out.println(result);
  }  
}
	



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site