Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

B. Mantenimiento de Datos | Actualizacion.

Busca un registro determinado mediante el campo CÓDIGO, al encontrar el registro muestra todos sus campos y permite el ingreso de los nuevos datos por el que se van a remplazar.

PSeInt DESCARGA CÓDIGO

    
Algoritmo agregar_registros
	
    Definir continua, datos, xcod Como Caracter;
    Definir f, c, fila como numero;
    Dimension datos[10,5];
	
    continua <- "S";	
    f <- 0;
    c <- 0;
	
    //Cargar la matriz de datos de ejemplo	
    datos(1,0) <- "COD01";
    datos(1,1) <- "SOFIA     ";
    datos(1,2) <- "LOS OLIVOS";
    datos(1,3) <- "  F       ";
    datos(1,4) <- "2500      ";
	
    datos(2,0) <- "COD02";
    datos(2,1) <- "ANDRES    ";
    datos(2,2) <- "CALLAO    ";
    datos(2,3) <- "  M       ";
    datos(2,4) <- "2300      ";
	
    datos(3,0) <- "COD03";
    datos(3,1) <- "CESAR     ";
    datos(3,2) <- "LIMA      ";
    datos(3,3) <- "  M       ";
    datos(3,4) <- "2000      ";
	
    fila <- 3;
	
    //Actualización o Modificación de Datos
    Escribir Sin Saltar "Ingrese Codigo >> ";
    Leer xcod;	
    
    
        	
    Para f <- 1 hasta fila con paso 1 hacer

        Si xcod = datos(f,0) Entonces
            Escribir "DATO ENCONTRADO";
            Escribir "===============";
            Escribir datos[f,0]," ",datos[f,1]," ",datos[f,2]," ",datos[f,3]," ",datos[f,4];
            Escribir "";
			
            Escribir "ACTUALIZAR DATOS";
            Escribir "================";
            Escribir "CODIGO    :" , xcod; 
            Escribir Sin Saltar "NOMBRE    :";	Leer datos(f,1);			
            Escribir Sin Saltar "DIRECCIÓN :";	Leer datos(f,2);		
            Escribir Sin Saltar "SEXO      :";	Leer datos(f,3);		
            Escribir Sin Saltar "SUELDO    :";	Leer datos(f,4);	
			
            Escribir "";
            Escribir "REPORTE DE DATOS ACTUALIZADOS";
            Escribir "===============";
            //Listar Todos los Datos
            Para f <- 1 hasta fila-1 con paso 1 hacer
                Para c <- 1 hasta 4 con paso 1 hacer
                    Escribir Sin Saltar datos[f,c], " ";
                FinPara
                Escribir "";
            FinPara		
        SiNo
            Si f = 3 Entonces
                Escribir "CODIGO NO ENCONTRADO";
            FinSi			
        FinSi
	FinPara	
	
FinAlgoritmo
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site