PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

E. Mantenimiento de Datos | Filtros.

Muestra una sub lista del contenido del arreglo, filtrando una información específica de los datos, según los criterios de busqueda.

    
Algoritmo Consultar_registros
	
    Definir datos Como Caracter;
    Definir f, fila, opcion como numero;
    Dimension datos[10,5];
    opcion <- 0;	
    f <- 0;
		
    //Cargar la matriz de datos de ejemplo	
    datos(1,0) <- "COD01";
    datos(1,1) <- "SOFIA     ";
    datos(1,2) <- "LOS OLIVOS";
    datos(1,3) <- "F";
    datos(1,4) <- "2500";
	
    datos(2,0) <- "COD02";
    datos(2,1) <- "ANDRES    ";
    datos(2,2) <- "CALLAO";
    datos(2,3) <- "M";
    datos(2,4) <- "2300";
	
    datos(3,0) <- "COD03";
    datos(3,1) <- "CESAR     ";
    datos(3,2) <- "LIMA";
    datos(3,3) <- "M";
    datos(3,4) <- "2000";
	
    fila <- 3;
	
    //Menu de Reportes a Mostrar
    Escribir "SELECCIONA EL REPORTE A MOSTRAR";
    Escribir "===============================";
    Escribir "1. Muestra los registros que vivan en el Callao";
    Escribir "2. Muestra los registros que sean Masculinos (M)";
    Escribir "3. Muestra los registros que ganen mas de 2000";
    Escribir " ";
    Escribir "Seleccione su Opción >> ";
    Leer opcion;
    Escribir " ";
	
    Segun opcion Hacer
        1:
            Para f  <- 1 hasta fila con paso 1 hacer
                Si datos[f,2] = "CALLAO" Entonces
                    Escribir datos[f,0]," ",datos[f,1]," ",datos[f,2]," ",datos[f,3]," ",datos[f,4];
                FinSi
            FinPara	
        2:
            Para f  <- 1 hasta fila con paso 1 hacer
                Si datos[f,3] = "M" Entonces
                    Escribir datos[f,0]," ",datos[f,1]," ",datos[f,2]," ",datos[f,3]," ",datos[f,4];
                FinSi
            FinPara				
        3:
            Para f  <- 1 hasta fila con paso 1 hacer
                Si datos[f,4] > "2000" Entonces
                    Escribir datos[f,0]," ",datos[f,1]," ",datos[f,2]," ",datos[f,3]," ",datos[f,4];
                FinSi
            FinPara	
			
        De Otro Modo:
            Escribir "Error de Opcion";
    FinSegun
	
FinAlgoritmo
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site