PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

12. Un supermercado cuenta con 5 cajeros que laboran seis días a la semana (de lunes a sábado). De cada cajero se registra en una matriz el total de ventas que ha realizado en cada día.

Determinar:

a) Cajero con la mayor venta en la semana.
b) Día de la semana con menor venta para el cuarto cajero.

PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_PSeInt_Site
	
    Dimension cajero[6,5];	
    menor = 10000;
	
    para f = 1 Hasta 6 Con Paso 1 Hacer
        Escribir " "
        Segun (f) Hacer
            1: 	Escribir "LUNES"
            2: 	Escribir "MARTES"
            3: 	Escribir "MIÉRCOLES"
            4: 	Escribir "JUEVES"
            5: 	Escribir "VIERNES"
            6: 	Escribir "SÁBADO"
        FinSegun		
        para cajas = 1 Hasta 5 Con Paso 1 Hacer			
            Escribir Sin Saltar "VENTA CAJA 0",cajas, " : "
            Leer cajero[f,cajas]			
            Si (cajas == 4 y menor > cajero[f,cajas]) Entonces
                menor = cajero[f,cajas]
            FinSi			
        FinPara		
    FinPara
	
    Escribir " "
    Escribir "C01   C02   C03   C04   C05"
    Para f = 1 Hasta 6 con paso 1 Hacer
        Para cajas = 1 Hasta 5 con paso 1 Hacer
            Escribir Sin Saltar cajero[f,cajas],"    "
        FinPara
        Escribir " "
    FinPara
	
    Para cajas = 1 Hasta 5 con paso 1 Hacer
        Para f = 1 Hasta 6 con paso 1 Hacer
            Si (mayor < cajero[f,cajas]) Entonces
                nrocajero = cajas
                mayor = cajero[f,cajas]
            FinSi			
        FinPara				
    FinPara
	
    Escribir " "
    Escribir "CAJERO CON MAYOR VENTA [", nrocajero, "] CON [", mayor, "] VENTAS REALIZADAS"
    Escribir "DIA DE LA SEMANA CON MENOR VENTA 4to CAJERO : ", menor
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_PSeInt_Site
	
    Definir f, cajas, cajero, mayor, menor, nrocajero como Entero;
    Dimension cajero[6,5];
	
    nrocajero <- 0;
    mayor <- 0;	
    menor <- 10000;
	
    para f <- 0 Hasta 5 Con Paso 1 Hacer
        Escribir " ";
        Segun (f) Hacer
            0: 	Escribir "LUNES";
            1: 	Escribir "MARTES";	
            2: 	Escribir "MIÉRCOLES";
            3: 	Escribir "JUEVES";
            4: 	Escribir "VIERNES";
            5: 	Escribir "SÁBADO";
        FinSegun
				
        para cajas <- 0 Hasta 4 Con Paso 1 Hacer			
            Escribir Sin Saltar "VENTA CAJA 0",cajas+1, " : ";
            Leer cajero[f,cajas];
			
            //CAJERO 4 CON MENOR VENTA
            Si (cajas == 3 y menor > cajero[f,cajas]) Entonces
                menor <- cajero[f,cajas];				
            FinSi			
        FinPara
				
    FinPara
	
    Escribir " ";
    Escribir "C01   C02   C03   C04   C05";
    Para f <- 0 Hasta 5 con paso 1 Hacer
        Para cajas <- 0 Hasta 4 con paso 1 Hacer
            Escribir Sin Saltar cajero[f,cajas],"    ";
        FinPara
        Escribir " ";
    FinPara
	
    //CAJERO CON MAYOR VENTA
    Para cajas <- 0 Hasta 4 con paso 1 Hacer
        Para f <- 0 Hasta 5 con paso 1 Hacer
            Si (mayor < cajero[f,cajas]) Entonces
                nrocajero <- cajas;
                mayor <- cajero[f,cajas];
            FinSi			
        FinPara				
    FinPara
	
    Escribir " ";
    Escribir "CAJERO CON MAYOR VENTA [", nrocajero+1, "] CON [", mayor, "] VENTAS REALIZADAS";
    Escribir "DIA DE LA SEMANA CON MENOR VENTA 4to CAJERO : ", menor;
	
FinProceso
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site