PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

02. Matriz de números naturales, pares e impares.

02. Elaborar un programa que muestra la siguiente matriz:


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
//-------------------------
//| 1 | 2 | 3 | 4 | 5 | 6 |
//| 2 | 4 | 6 | 8 | 10| 12|
//| 1 | 3 | 5 | 7 | 9 | 11|
//-------------------------

Algoritmo Array_Bidimencional_02
	
    Dimension matrix[3,6]
	
    //Cargar Array Bidimencional
    Para f = 1 hasta 3 con paso 1 hacer
        Segun f Hacer
            1: 
                Para c = 1 hasta 6 con paso 1 hacer
                    matrix[f,c]=c
                FinPara
            2:
                Para c = 1 hasta 6 con paso 1 hacer
                    matrix[f,c]=c*2
                FinPara
            3:
                Para c = 1 hasta 6 con paso 1 hacer
                    matrix[f,c]=(c*2)-1
                FinPara
        Fin Segun			
    FinPara
	
    //Mostrar Array Bidimencional
    Para f = 1 hasta 3 con paso 1 hacer
        Para c = 1 hasta 6 con paso 1 hacer
            Escribir Sin Saltar matrix[f,c], " ";
        FinPara	
        Escribir "";
    FinPara		
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
//-------------------------
//| 1 | 2 | 3 | 4 | 5 | 6 |
//| 2 | 4 | 6 | 8 | 10| 12|
//| 1 | 3 | 5 | 7 | 9 | 11|
//-------------------------
Algoritmo Array_Bidimencional_02
	
    Definir m, f, c como Entero;
    Dimension m[3,6];
	
    //Cargar Array Bidimencional
    Para f <- 0 hasta 2 con paso 1 hacer
        Segun f Hacer
            0: 
                Para c <- 0 hasta 5 con paso 1 hacer
                    m[f,c] <- c + 1;
                FinPara
            1:
                Para c <- 0 hasta 5 con paso 1 hacer
                    m[f,c] <- (c + 1) * 2;
                FinPara
            2:
                Para c <- 0 hasta 5 con paso 1 hacer
                    m[f,c] <- ((c + 1) * 2) - 1;
                FinPara
        FinSegun
    FinPara
	
    //Mostrar Array Bidimencional
    Para f <- 0 hasta 2 con paso 1 hacer
        Para c <- 0 hasta 5 con paso 1 hacer
            Escribir Sin Saltar m[f,c], " ";
        FinPara
        Escribir "";
    FinPara		
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
/* ------------------------- */
/* | 1 | 2 | 3 | 4 | 5 | 6 | */
/* | 2 | 4 | 6 | 8 | 10| 12| */
/* | 1 | 3 | 5 | 7 | 9 | 11| */
/* ------------------------- */
int main() {
    int c, f, m[3][6];
	
    /* Cargar Array Bidimencional */
    for (f=0;f<=2;f+=1) {
        switch (f) {
        case 0:
            for (c=0;c<=5;c+=1) {
                m[f][c] = c+1;
            }
            break;
        case 1:
            for (c=0;c<=5;c+=1) {
                m[f][c] = (c+1)*2;
            }
            break;
        case 2:
            for (c=0;c<=5;c+=1) {
                m[f][c] = ((c+1)*2)-1;
            }
            break;
        }
    }
    /* Mostrar Array Bidimencional */
    for (f=0;f<=2;f+=1) {
        for (c=0;c<=5;c+=1) {
            printf("%d  ",m[f][c]);
        }
        printf("\n");
    }
    
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
// -------------------------
// | 1 | 2 | 3 | 4 | 5 | 6 |
// | 2 | 4 | 6 | 8 | 10| 12|
// | 1 | 3 | 5 | 7 | 9 | 11|
// -------------------------
int main() {
    int c, f, m[3][6];
	
    // Cargar Array Bidimencional
    for (f=0;f<=2;f++) {
        switch (f) {
        case 0:
            for (c=0;c<=5;c++) {
                m[f][c] = c+1;
            }
            break;
        case 1:
            for (c=0;c<=5;c++) {
                m[f][c] = (c+1)*2;
            }
            break;
        case 2:
            for (c=0;c<=5;c++) {
                m[f][c] = ((c+1)*2)-1;
            }
            break;
        }
    }
    // Mostrar Array Bidimencional
    for (f=0;f<=2;f++) {
        for (c=0;c<=5;c++) {
            cout << m[f][c] << " ";
        }
        cout << endl;
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
# -------------------------
# | 1 | 2 | 3 | 4 | 5 | 6 |
# | 2 | 4 | 6 | 8 | 10| 12|
# | 1 | 3 | 5 | 7 | 9 | 11|
# -------------------------
if __name__ == '__main__':
    m = [[int() for ind0 in range(6)] for ind1 in range(3)]
    # Cargar Array Bidimencional
    for f in range(3):
        if f==0:
            for c in range(6):
                m[f][c] = c+1
        elif f==1:
            for c in range(6):
                m[f][c] = (c+1)*2
        elif f==2:
            for c in range(6):
                m[f][c] = ((c+1)*2)-1
    # Mostrar Array Bidimencional
    for f in range(3):
        print(m[f][0]," ",m[f][1]," ",m[f][2]," ",m[f][3]," ",m[f][4]," ",m[f][5])
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site