PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

03. Ordena una Matriz de 3 x 3.

Elaborar un programa que ingresa números aleatorios en una matriz de 3 x 3 y los muestre ordenados en otra.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
//-------------		-------------
//| 5 | 9 | 1 |		| 1 | 2 | 4 |
//| 4 | 20| 11|		| 5 | 9 | 11|
//| 13| 12| 2 |		| 12| 13| 20|
//-------------		-------------

Algoritmo Array_Bidimencional_03
	
    Dimension matrix_1[3,6]
    cont = 1
    n = 1
    //Lee Datos al Array Bidimencional
    Para f = 1 hasta 3 con paso 1 hacer
        Para c = 1 hasta 3 con paso 1 hacer
            Escribir "Ingrese valor ", cont ,"/12 :" 
            Leer matrix_1[f,c]
            cont = cont + 1
        FinPara			
    FinPara
	
    //Ordenar Datos del Array Bidimencional
    Para m = 1 hasta 3 con paso 1 hacer			
        Para n = 1 hasta 3 con paso 1 hacer			
            Para f = 1 hasta 3 con paso 1 hacer		
                Para c = 1 hasta 3 con paso 1 hacer					
                    Si matrix_1[m,n] < matrix_1[f,c] Entonces
                        temp = matrix_1[m,n]
                        matrix_1[m,n] = matrix_1[f,c]
                        matrix_1[f,c] = temp
                    Fin Si						
                FinPara					
            FinPara		
        FinPara				
    FinPara

    //Mostrar Datos al Array Bidimencional 2
    Para f = 1 hasta 3 con paso 1 hacer		
        Escribir matrix_1[f,1] , " " , matrix_1[f,2] , " " , matrix_1[f,3]			
    FinPara	
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
//-------------		-------------
//| 5 | 9 | 1 |		| 1 | 2 | 4 |
//| 4 | 20| 11|		| 5 | 9 | 11|
//| 13| 12| 2 |		| 12| 13| 20|
//-------------		-------------
Algoritmo Array_Bidimencional_03
	
    Definir matrix, matrix_1, f, c, m, n, cont, temp como Entero;
    Dimension matrix_1[3,6];
    cont <- 1;
    n <- 1;
    //Lee Datos al Array Bidimencional
    Para f <- 0 hasta 2 con paso 1 hacer
        Para c <- 0 hasta 2 con paso 1 hacer
            Escribir "Ingrese valor ", cont ," de 9 :";
            Leer matrix_1[f,c];
            cont <- cont + 1;
        FinPara			
    FinPara
	
    //Ordenar Datos del Array Bidimencional
    Para m <- 0 hasta 2 con paso 1 hacer			
        Para n <- 0 hasta 2 con paso 1 hacer			
            Para f <- 0 hasta 2 con paso 1 hacer		
                Para c <- 0 hasta 2 con paso 1 hacer					
                    Si matrix_1[m,n] < matrix_1[f,c] Entonces
                        temp <- matrix_1[m,n];
                        matrix_1[m,n] <- matrix_1[f,c];
                        matrix_1[f,c] <- temp;
                    FinSi
                FinPara
            FinPara
        FinPara
    FinPara

    //Mostrar Datos al Array Bidimencional 2
    Para f <- 0 hasta 2 con paso 1 hacer		
        Escribir matrix_1[f,0] , " " , matrix_1[f,1] , " " , matrix_1[f,2];
    FinPara	
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
/* -------------  ------------- */
/* | 5 | 9 | 1 |  | 1 | 2 | 4 | */
/* | 4 | 20| 11|  | 5 | 9 | 11| */
/* | 13| 12| 2 |  | 12| 13| 20| */
/* -------------  ------------- */
int main() {
    int c, cont, f, m, n, temp, matrix, matrix_1[3][6];
	
    cont = 1;
    n = 1;
    /* Lee Datos al Array Bidimencional */
    for (f=0;f<=2;f+=1) {
        for (c=0;c<=2;c+=1) {
            printf("Ingrese valor %d de 9 : ",cont);
            scanf("%d",&matrix_1[f][c]);
            cont = cont+1;
        }
    }
    /* Ordenar Datos del Array Bidimencional */
    printf("\n");
    for (m=0;m<=2;m+=1) {
        for (n=0;n<=2;n+=1) {
            for (f=0;f<=2;f+=1) {
                for (c=0;c<=2;c+=1) {
                    if (matrix_1[m][n] < matrix_1[f][c]) {
                        temp = matrix_1[m][n];
                        matrix_1[m][n] = matrix_1[f][c];
                        matrix_1[f][c] = temp;
                    }
                }
            }
        }
    }
    /* Mostrar Datos al Array Bidimencional 2 */
    for (f=0;f<=2;f+=1) {
        printf("%d %d %d\n",matrix_1[f][0],matrix_1[f][1],matrix_1[f][2]);
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>>
using namespace std;
// -------------  -------------
// | 5 | 9 | 1 |  | 1 | 2 | 4 |
// | 4 | 20| 11|  | 5 | 9 | 11|
// | 13| 12| 2 |  | 12| 13| 20|
// -------------  -------------
int main() {
    int c, cont, f, m, n, temp, matrix, matrix_1[3][6];
	
    cont = 1;
    n = 1;
    // Lee Datos al Array Bidimencional
    for (f=0;f<=2;f++) {
        for (c=0;c<=2;c++) {
            cout << "Ingrese valor " << cont << " de 9 : ";
            cin >> matrix_1[f][c];
            cont = cont+1;
        }
    }
    // Ordenar Datos del Array Bidimencional
    cout << " " << endl;
    for (m=0;m<=2;m++) {
        for (n=0;n<=2;n++) {
            for (f=0;f<=2;f++) {
                for (c=0;c<=2;c++) {
                    if (matrix_1[m][n] < matrix_1[f][c]) {
                        temp = matrix_1[m][n];
                        matrix_1[m][n] = matrix_1[f][c];
                        matrix_1[f][c] = temp;
                    }
                }
            }
        }
    }
    // Mostrar Datos al Array Bidimencional 2
    for (f=0;f<=2;f++) {
        cout << matrix_1[f][0] << " " << matrix_1[f][1] << 	" " << matrix_1[f][2] << endl;
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
# -------------  -------------
# | 5 | 9 | 1 |  | 1 | 2 | 4 |
# | 4 | 20| 11|  | 5 | 9 | 11|
# | 13| 12| 2 |  | 12| 13| 20|
# -------------  -------------
if __name__ == '__main__':
    matrix_1 = [[int() for ind0 in range(6)] for ind1 in range(3)]
    cont = 1
    n = 1
    # Lee Datos al Array Bidimencional
    for f in range(3):
        for c in range(3):
            print("Ingrese valor ",cont," de 9 :")
            matrix_1[f][c] = int(input())
            cont = cont+1
    # Ordenar Datos del Array Bidimencional
    for m in range(3):
        for n in range(3):
            for f in range(3):
                for c in range(3):
                    if matrix_1[m][n] < matrix_1[f][c]:
                        temp = matrix_1[m][n]
                        matrix_1[m][n] = matrix_1[f][c]
                        matrix_1[f][c] = temp
    # Mostrar Datos al Array Bidimencional 2
    for f in range(3):
        print(matrix_1[f][0]," ",matrix_1[f][1]," ",matrix_1[f][2])
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site