PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

05. Sumatoria de una matriz de 3x3.

Elaborar un programa que muestre la siguiente sumatoria.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
//-------------------		
//| n+1 | n+2 | n+3 |
//| n+4 | n+5 | n+6 |
//| n+7 | n+8 | n+9 |
//-------------------
Algoritmo Array_Bidimencional_05
	
    Dimension matrix[3,3]
		
    Escribir "Ingrese Número : "
    Leer num
    n = 1
		
    //Lee Datos al Array Bidimencional
    Para f = 1 hasta 3 con paso 1 hacer
        Para c = 1 hasta 3 con paso 1 hacer
            matrix[f,c] = num + n
            n = n + 1
        FinPara			
    FinPara
	
    //Mostrar Datos al Array Bidimencional 2
    Escribir ""
    Para f = 1 hasta 3 con paso 1 hacer		
        Escribir matrix[f,1] , " " , matrix[f,2] , " " , matrix[f,3]			
    FinPara	
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
//-------------------		
//| n+1 | n+2 | n+3 |
//| n+4 | n+5 | n+6 |
//| n+7 | n+8 | n+9 |
//-------------------
Algoritmo Array_Bidimencional_05
	
    Definir matrix, f, c, n, num como Entero;
    Dimension matrix[3,3];
		
    Escribir "Ingrese Número : ";
    Leer num;
    n <- 1;
		
    //Lee Datos al Array Bidimencional
    Para f <- 0 hasta 2 con paso 1 hacer
        Para c <- 0 hasta 2 con paso 1 hacer
            matrix[f,c] <- num + n;
            n <- n + 1;
        FinPara			
    FinPara

    //Mostrar Datos al Array Bidimencional 2
    Escribir "";
    Para f <- 0 hasta 2 con paso 1 hacer		
        Escribir matrix[f,0]," ",matrix[f,1]," ",matrix[f,2];
    FinPara	
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
/* ------------------- */
/* | n+1 | n+2 | n+3 | */
/* | n+4 | n+5 | n+6 | */
/* | n+7 | n+8 | n+9 | */
/* ------------------- */
int main() {
    int c, f, n, num, matrix[3][3]; 
    printf("Ingrese Numero : ");
    scanf("%d",&num);
    n = 1;
    /* Lee Datos al Array Bidimencional */
    for (f=0;f<=2;f+=1) {
        for (c=0;c<=2;c+=1) {
            matrix[f][c] = num+n;
            n = n+1;
        }
    }
    /* Mostrar Datos al Array Bidimencional 2 */
    printf("\n");
    for (f=0;f<=2;f+=1) {
        printf("%d %d %d\n",matrix[f][0],matrix[f][1],matrix[f][2]);
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
// -------------------  
// | n+1 | n+2 | n+3 |
// | n+4 | n+5 | n+6 |
// | n+7 | n+8 | n+9 |
// -------------------
int main() {
    int c, f, n, num, matrix[3][3]; 
		
    cout << "Ingrese Numero : ";
    cin >> num;
    n = 1;
    // Lee Datos al Array Bidimencional
    for (f=0;f<=2;f++) {
        for (c=0;c<=2;c++) {
            matrix[f][c] = num+n;
            n = n+1;
        }
    }
    // Mostrar Datos al Array Bidimencional 2
    cout << "" << endl;
    for (f=0;f<=2;f++) {
        cout << matrix[f][0] << " " << matrix[f][1] << " " << matrix[f][2] << endl;
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
# -------------------  
# | n+1 | n+2 | n+3 |
# | n+4 | n+5 | n+6 |
# | n+7 | n+8 | n+9 |
# -------------------
if __name__ == '__main__':
    matrix = [[int() for ind0 in range(3)] for ind1 in range(3)]
    print("Ingrese Número : ")
    num = int(input())
    n = 1
    # Lee Datos al Array Bidimencional
    for f in range(3):
        for c in range(3):
            matrix[f][c] = num+n
            n = n+1
    # Mostrar Datos al Array Bidimencional 2
    print("")
    for f in range(3):
        print(matrix[f][0]," ",matrix[f][1]," ",matrix[f][2])
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site