Sumatoria de una matriz de 3x3

¡Haz clic para puntuar este proyecto!
(Votos: 4 Promedio: 3)

Elaborar un programa que muestre la siguiente sumatoria.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension matrix[3,3]
        Escribir "Ingrese Número : "
        Leer num
        n = 1
        //Lee Datos al Array Bidimencional
        Para f = 1 hasta 3 con paso 1 hacer
            Para c = 1 hasta 3 con paso 1 hacer
                matrix[f,c] = num + n
                n = n + 1
            FinPara			
        FinPara
        //Mostrar Datos al Array Bidimencional 2
        Escribir ""
        Para f = 1 hasta 3 con paso 1 hacer		
            Escribir matrix[f,1] , " " , matrix[f,2] , " " , matrix[f,3]			
        FinPara	
    FinAlgoritmo
    

    Lenguaje C

        
    #include<stdio.h>
    int main() {
        int c, f, n, num, matrix[3][3]; 
        printf("Ingrese Numero : ");
        scanf("%d",&num);
        n = 1;
        for (f=0;f<=2;f+=1) {
            for (c=0;c<=2;c+=1) {
                matrix[f][c] = num+n;
                n = n+1;
            }
        }
        printf("\n");
        for (f=0;f<=2;f+=1) {
            printf("%d %d %d\n",matrix[f][0],matrix[f][1],matrix[f][2]);
        }
        return 0;
    }
    

    C++

       
    #include<iostream>
    using namespace std;
    int main() {
        int c, f, n, num, matrix[3][3]; 
        cout << "Ingrese Numero : ";
        cin >> num;
        n = 1;
        // Lee Datos al Array Bidimencional
        for (f=0;f<=2;f++) {
            for (c=0;c<=2;c++) {
                matrix[f][c] = num+n;
                n = n+1;
            }
        }
        // Mostrar Datos al Array Bidimencional 2
        cout << "" << endl;
        for (f=0;f<=2;f++) {
            cout << matrix[f][0] << " " << matrix[f][1] << " " << matrix[f][2] << endl;
        }
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir