PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

06. Sumatoria de matrices.

Elaborar un programa que muestre la siguiente sumatoria.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
//-------------		-------------		----------------
//| 1 | 2 | 3 |		| 3 | 2 | 1 |		| S1 | S2 | S3 |
//| 4 | 5 | 6 |		| 6 | 5 | 4 |		| S4 | S5 | S6 |
//| 7 | 8 | 9 |		| 9 | 8 | 7 |		| S7 | S8 | S9 |
//-------------		-------------		----------------
Algoritmo Array_Bidimencional_06
	
    Dimension matrix_1[3,3]
    Dimension matrix_2[3,3]
    Dimension matrix_3[3,3]
	
    //Lee Datos al Array Bidimencional
    Para f = 1 hasta 3 con paso 1 hacer
        Para c = 1 hasta 3 con paso 1 hacer
            matrix_1[f,c] = azar(9) + 1
            matrix_2[f,c] = azar(9) + 1
            matrix_3[f,c] = matrix_1[f,c] + matrix_2[f,c]
        FinPara			
    FinPara
	
    //Mostrar Datos al Array Bidimencional 2
    Escribir ""
    Para f = 1 hasta 3 con paso 1 hacer		
        Escribir matrix_1[f,1] , " " , matrix_1[f,2] , " " , matrix_1[f,3]					
    FinPara	
	
    Escribir ""
    Para f = 1 hasta 3 con paso 1 hacer		
        Escribir matrix_2[f,1] , " " , matrix_2[f,2] , " " , matrix_2[f,3]					
    FinPara	
	
    Escribir ""
    Para f = 1 hasta 3 con paso 1 hacer		
        Escribir matrix_3[f,1] , " " , matrix_3[f,2] , " " , matrix_3[f,3]				
    FinPara	
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
//-------------		-------------		----------------
//| 1 | 2 | 3 |		| 3 | 2 | 1 |		| S1 | S2 | S3 |
//| 4 | 5 | 6 |		| 6 | 5 | 4 |		| S4 | S5 | S6 |
//| 7 | 8 | 9 |		| 9 | 8 | 7 |		| S7 | S8 | S9 |
//-------------		-------------		----------------
Algoritmo Array_Bidimencional_06
	
    Definir matrix, matrix_1, matrix_2, matrix_3, f, c como Entero;
    Dimension matrix_1[3,3];
    Dimension matrix_2[3,3];
    Dimension matrix_3[3,3];
	
    //Lee Datos al Array Bidimencional
    Para f <- 0 hasta 2 con paso 1 hacer
        Para c <- 0 hasta 2 con paso 1 hacer
            matrix_1[f,c] <- azar(9) + 1;
            matrix_2[f,c] <- azar(9) + 1;
            matrix_3[f,c] <- matrix_1[f,c] + matrix_2[f,c];
        FinPara			
    FinPara
	
    //Mostrar Datos al Array Bidimencional 2
    Escribir "";
    Para f <- 0 hasta 2 con paso 1 hacer		
        Escribir matrix_1[f,0]," ",matrix_1[f,1]," ",matrix_1[f,2];
    FinPara	
	
    Escribir "";
    Para f <- 0 hasta 2 con paso 1 hacer		
        Escribir matrix_2[f,0]," ",matrix_2[f,1]," ",matrix_2[f,2];
    FinPara	
	
    Escribir "";
    Para f <- 0 hasta 2 con paso 1 hacer		
        Escribir matrix_3[f,0]," ",matrix_3[f,1]," ",matrix_3[f,2];
    FinPara	
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
#include<stdlib.h>
/* -------------  -------------  ---------------- */
/* | 1 | 2 | 3 |  | 3 | 2 | 1 |  | S1 | S2 | S3 | */
/* | 4 | 5 | 6 |  | 6 | 5 | 4 |  | S4 | S5 | S6 | */
/* | 7 | 8 | 9 |  | 9 | 8 | 7 |  | S7 | S8 | S9 | */
/* -------------  -------------  ---------------- */
int main() {
    int c, f, matrix;
    int matrix_1[3][3];
    int matrix_2[3][3];
    int matrix_3[3][3];
    /* Lee Datos al Array Bidimencional */
    for (f=0;f<=2;f+=1) {
        for (c=0;c<=2;c+=1) {
            matrix_1[f][c] = (rand()%9)+1;
            matrix_2[f][c] = (rand()%9)+1;
            matrix_3[f][c] = matrix_1[f][c]+matrix_2[f][c];
        }
    }
    /* Mostrar Datos al Array Bidimencional 2 */
    printf("\n");
    for (f=0;f<=2;f+=1) {
        printf("%d %d %d\n",matrix_1[f][0],matrix_1[f][1],matrix_1[f][2]);
    }
    printf("\n");
    for (f=0;f<=2;f+=1) {
        printf("%d %d %d\n",matrix_2[f][0],matrix_2[f][1],matrix_2[f][2]);
    }
    printf("\n");
    for (f=0;f<=2;f+=1) {
        printf("%d %d %d\n",matrix_3[f][0],matrix_3[f][1],matrix_3[f][2]);
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
#include<cstdlib>
using namespace std;
// -------------  -------------  ----------------
// | 1 | 2 | 3 |  | 3 | 2 | 1 |  | S1 | S2 | S3 |
// | 4 | 5 | 6 |  | 6 | 5 | 4 |  | S4 | S5 | S6 |
// | 7 | 8 | 9 |  | 9 | 8 | 7 |  | S7 | S8 | S9 |
// -------------  -------------  ----------------
int main() {
    int c, f, matrix;
    int matrix_1[3][3];
    int matrix_2[3][3];
    int matrix_3[3][3];
	
    // Lee Datos al Array Bidimencional
    for (f=0;f<=2;f++) {
        for (c=0;c<=2;c++) {
            matrix_1[f][c] = (rand()%9)+1;
            matrix_2[f][c] = (rand()%9)+1;
            matrix_3[f][c] = matrix_1[f][c]+matrix_2[f][c];
        }
    }
    // Mostrar Datos al Array Bidimencional 2
    cout << "" << endl;
    for (f=0;f<=2;f++) {
        cout << matrix_1[f][0] << " " << matrix_1[f][1] << " " << matrix_1[f][2] << endl;
    }
	cout << "" << endl;
    for (f=0;f<=2;f++) {
        cout << matrix_2[f][0] << " " << matrix_2[f][1] << " " << matrix_2[f][2] << endl;
    }
    cout << "" << endl;
    for (f=0;f<=2;f++) {
        cout << matrix_3[f][0] << " " << matrix_3[f][1] << " " << matrix_3[f][2] << endl;
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
from random import randint
# -------------  -------------  ----------------
# | 1 | 2 | 3 |  | 3 | 2 | 1 |  | S1 | S2 | S3 |
# | 4 | 5 | 6 |  | 6 | 5 | 4 |  | S4 | S5 | S6 |
# | 7 | 8 | 9 |  | 9 | 8 | 7 |  | S7 | S8 | S9 |
# -------------  -------------  ----------------
if __name__ == '__main__':
    matrix_1 = [[int() for ind0 in range(3)] for ind1 in range(3)]
    matrix_2 = [[int() for ind0 in range(3)] for ind1 in range(3)]
    matrix_3 = [[int() for ind0 in range(3)] for ind1 in range(3)]
    # Lee Datos al Array Bidimencional
    for f in range(3):
        for c in range(3):
            matrix_1[f][c] = randint(0,8)+1
            matrix_2[f][c] = randint(0,8)+1
            matrix_3[f][c] = matrix_1[f][c]+matrix_2[f][c]
    # Mostrar Datos al Array Bidimencional 2
    print("")
    for f in range(3):
        print(matrix_1[f][0]," ",matrix_1[f][1]," ",matrix_1[f][2])
    print("")
    for f in range(3):
        print(matrix_2[f][0]," ",matrix_2[f][1]," ",matrix_2[f][2])
    print("")
    for f in range(3):
        print(matrix_3[f][0]," ",matrix_3[f][1]," ",matrix_3[f][2])
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site