Sumatoria de matrices

¡Haz clic para puntuar este proyecto!
(Votos: 1 Promedio: 4)

Elaborar un programa que muestre la siguiente sumatoria.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension matrix_1[3,3]
        Dimension matrix_2[3,3]
        Dimension matrix_3[3,3]
        //Lee Datos al Array Bidimencional
        Para f = 1 hasta 3 con paso 1 hacer
            Para c = 1 hasta 3 con paso 1 hacer
                matrix_1[f,c] = azar(9) + 1
                matrix_2[f,c] = azar(9) + 1
                matrix_3[f,c] = matrix_1[f,c] + matrix_2[f,c]
            FinPara			
        FinPara
        //Mostrar Datos al Array Bidimencional 2
        Escribir ""
        Para f = 1 hasta 3 con paso 1 hacer		
            Escribir matrix_1[f,1] , " " , matrix_1[f,2] , " " , matrix_1[f,3]					
        FinPara	
        Escribir ""
        Para f = 1 hasta 3 con paso 1 hacer		
            Escribir matrix_2[f,1] , " " , matrix_2[f,2] , " " , matrix_2[f,3]					
        FinPara	
        Escribir ""
        Para f = 1 hasta 3 con paso 1 hacer		
            Escribir matrix_3[f,1] , " " , matrix_3[f,2] , " " , matrix_3[f,3]				
        FinPara	
    FinAlgoritmo
    

    Lenguaje C

       
    #include<stdio.h>
    #include<stdlib.h>
    int main() {
        int c, f, matrix;
        int matrix_1[3][3];
        int matrix_2[3][3];
        int matrix_3[3][3];
        /* Lee Datos al Array Bidimencional */
        for (f=0;f<=2;f+=1) {
            for (c=0;c<=2;c+=1) {
                matrix_1[f][c] = (rand()%9)+1;
                matrix_2[f][c] = (rand()%9)+1;
                matrix_3[f][c] = matrix_1[f][c]+matrix_2[f][c];
            }
        }
        /* Mostrar Datos al Array Bidimencional 2 */
        printf("\n");
        for (f=0;f<=2;f+=1) {
            printf("%d %d %d\n",matrix_1[f][0],matrix_1[f][1],matrix_1[f][2]);
        }
        printf("\n");
        for (f=0;f<=2;f+=1) {
            printf("%d %d %d\n",matrix_2[f][0],matrix_2[f][1],matrix_2[f][2]);
        }
        printf("\n");
        for (f=0;f<=2;f+=1) {
            printf("%d %d %d\n",matrix_3[f][0],matrix_3[f][1],matrix_3[f][2]);
        }
        return 0;
    }
    

    C++

      
    #include<iostream>
    #include<cstdlib>
    using namespace std;
    int main() {
        int c, f, matrix;
        int matrix_1[3][3];
        int matrix_2[3][3];
        int matrix_3[3][3];
        // Lee Datos al Array Bidimencional
        for (f=0;f<=2;f++) {
            for (c=0;c<=2;c++) {
                matrix_1[f][c] = (rand()%9)+1;
                matrix_2[f][c] = (rand()%9)+1;
                matrix_3[f][c] = matrix_1[f][c]+matrix_2[f][c];
            }
        }
        // Mostrar Datos al Array Bidimencional 2
        cout << "" << endl;
        for (f=0;f<=2;f++) {
            cout << matrix_1[f][0] << " " << matrix_1[f][1] << " " << matrix_1[f][2] << endl;
        }
    	cout << "" << endl;
        for (f=0;f<=2;f++) {
            cout << matrix_2[f][0] << " " << matrix_2[f][1] << " " << matrix_2[f][2] << endl;
        }
        cout << "" << endl;
        for (f=0;f<=2;f++) {
            cout << matrix_3[f][0] << " " << matrix_3[f][1] << " " << matrix_3[f][2] << endl;
        }
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir