Ubica un valor dentro de la matriz

¡Haz clic para puntuar este proyecto!
(Votos: 1 Promedio: 5)

Crear una matriz de 4 x 5 y cargarlos con los primeros números naturales; al ingresar un número cualquiera deberá buscar dicho número en la matriz e indicar en que fila y columna se encuentra el número dado.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension matrix[4,5]
        num = 1
        //Carga Números Naturales
        Para f = 1 hasta 4 con paso 1 hacer
            Para c = 1 hasta 5 con paso 1 hacer			
                matrix[f,c] = num
                num = num + 1
            FinPara			
        FinPara
        //Ingrese número 1 al 20 :
        Escribir "Ingrese Número del 1 al 20 :"
        Leer Num
        Escribir ""
        Si Num >=1 Y Num <=20  Entonces
            //Mostrar Datos al Array Bidimencional 2
            Para f = 1 hasta 4 con paso 1 hacer		
                Escribir matrix[f,1] , " " , matrix[f,2] , " " , matrix[f,3] , " " , matrix[f,4], " " , matrix[f,5]
            FinPara	
            Escribir ""
            //Buscando Número
            Para f = 1 hasta 4 con paso 1 hacer
                Para c = 1 hasta 5 con paso 1 hacer							
                    Si 	matrix[f,c] = num Entonces
                        Escribir "Posición MATRIX[",f,",",c,"]"
                    Fin Si
                FinPara			
            FinPara		
        SiNo
            Escribir "Número mal Ingresado"
        Fin Si
    FinAlgoritmo
    

    Lenguaje C

        
    #include<stdio.h>
    int main() {
        int c, f, num, matrix[4][5];
        num = 1;
        /* Carga Números Naturales */
        for (f=0;f<=3;f+=1) {
            for (c=0;c<=4;c+=1) {
                matrix[f][c] = num;
                num = num+1;
            }
        }
        /* Ingrese número 1 al 20 : */
        printf("Ingrese Numero del 1 al 20 : ");
        scanf("%d",&num);
        printf("\n");
        if (num>=1 && num<=20) {
            /* Mostrar Datos al Array Bidimencional 2 */
            for (f=0;f<=3;f+=1) {
                printf("%d %d %d %d %d\n",matrix[f][0],matrix[f][1],matrix[f][2],matrix[f][3],matrix[f][4]);
            }
            printf("\n");
            /* Buscando Número */
            for (f=0;f<=3;f+=1) {
                for (c=0;c<=4;c+=1) {
                    if (matrix[f][c]==num) {
                        printf("Posicion en la MATRIZ[%d,%d]\n",f+1,c+1);
                    }
                }
            }
        }else {
            printf("Numero mal Ingresado");
        }
        return 0;
    }
    

    C++ 

       
    #include<iostream>
    using namespace std;
    int main() {
        int c, f, num, matrix[4][5];		
        num = 1;
        // Carga Numeros Naturales
        for (f=0;f<=3;f++) {
            for (c=0;c<=4;c++) {
                matrix[f][c] = num;
                num = num+1;
            }
        }
        // Ingrese numero 1 al 20 :
        cout << "Ingrese Numero del 1 al 20 : ";
        cin >> num;
        cout << "" << endl;
        if (num>=1 && num<=20) {
            // Mostrar Datos al Array Bidimencional 2
            for (f=0;f<=3;f++) {
                cout << matrix[f][0] << " " << matrix[f][1] << " " << matrix[f][2] << " " << matrix[f][3] << " " << matrix[f][4] << endl;
            }
            cout << "" << endl;
            // Buscando Numero
            for (f=0;f<=3;f++) {
                for (c=0;c<=4;c++) {
                    if (matrix[f][c]==num) {
                        cout << "Posicion en la MATRIZ[" << f+1 << "," << c+1 << "]" << endl;
                    }
                }
            }
        } else {
            cout << "Numero mal Ingresado";
        }
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir