PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

04. Ubica un valor dentro de la matriz.

Crear una matriz de 4 x 5 y cargarlos con los primeros números naturales; al ingresar un número cualquiera deberá buscar dicho número en la matriz e indicar en que fila y columna se encuentra el número dado.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Array_Bidimencional_04
	
    Dimension matrix[4,5]
    num = 1
    //Carga Números Naturales
    Para f = 1 hasta 4 con paso 1 hacer
        Para c = 1 hasta 5 con paso 1 hacer			
            matrix[f,c] = num
            num = num + 1
        FinPara			
    FinPara
	
    //Ingrese número 1 al 20 :
    Escribir "Ingrese Número del 1 al 20 :"
    Leer Num
    Escribir ""
	
    Si Num >=1 Y Num <=20  Entonces
        //Mostrar Datos al Array Bidimencional 2
        Para f = 1 hasta 4 con paso 1 hacer		
            Escribir matrix[f,1] , " " , matrix[f,2] , " " , matrix[f,3] , " " , matrix[f,4], " " , matrix[f,5]
        FinPara	
		
        Escribir ""
		
        //Buscando Número
        Para f = 1 hasta 4 con paso 1 hacer
            Para c = 1 hasta 5 con paso 1 hacer							
                Si 	matrix[f,c] = num Entonces
                    Escribir "Posición MATRIX[",f,",",c,"]"
                Fin Si
            FinPara			
        FinPara		
    SiNo
        Escribir "Número mal Ingresado"
    Fin Si
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Array_Bidimencional_04
	
    Definir matrix, num, f, c como Entero;
    Dimension matrix[4,5];
	
    num <- 1;
    //Carga Números Naturales
    Para f <- 0 hasta 3 con paso 1 hacer
        Para c <- 0 hasta 4 con paso 1 hacer			
            matrix[f,c] <- num;
            num <- num + 1;
        FinPara			
    FinPara
	
    //Ingrese número 1 al 20 :
    Escribir "Ingrese Número del 1 al 20 :";
    Leer Num;
    Escribir "";
	
    Si Num >= 1 Y Num <= 20  Entonces
        //Mostrar Datos al Array Bidimencional 2
        Para f <- 0 hasta 3 con paso 1 hacer		
            Escribir matrix[f,0]," ",matrix[f,1]," ",matrix[f,2]," ",matrix[f,3]," ",matrix[f,4];
        FinPara	
		
        Escribir "";
			
        //Buscando Número
        Para f <- 0 hasta 3 con paso 1 hacer
            Para c <- 0 hasta 4 con paso 1 hacer							
                Si 	matrix[f,c] = num Entonces
                    Escribir "Posición en la MATRIZ[",f + 1,",",c + 1,"]";
                FinSi
            FinPara
        FinPara
    SiNo
        Escribir "Número mal Ingresado";
    FinSi
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int c, f, num, matrix[4][5];
    num = 1;
    /* Carga Números Naturales */
    for (f=0;f<=3;f+=1) {
        for (c=0;c<=4;c+=1) {
            matrix[f][c] = num;
            num = num+1;
        }
    }
    /* Ingrese número 1 al 20 : */
    printf("Ingrese Numero del 1 al 20 : ");
    scanf("%d",&num);
    printf("\n");
    if (num>=1 && num<=20) {
        /* Mostrar Datos al Array Bidimencional 2 */
        for (f=0;f<=3;f+=1) {
            printf("%d %d %d %d %d\n",matrix[f][0],matrix[f][1],matrix[f][2],matrix[f][3],matrix[f][4]);
        }
        printf("\n");
        /* Buscando Número */
        for (f=0;f<=3;f+=1) {
            for (c=0;c<=4;c+=1) {
                if (matrix[f][c]==num) {
                    printf("Posicion en la MATRIZ[%d,%d]\n",f+1,c+1);
                }
            }
        }
    }else {
        printf("Numero mal Ingresado");
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
    int c, f, num, matrix[4][5];		
    num = 1;
    // Carga Numeros Naturales
    for (f=0;f<=3;f++) {
        for (c=0;c<=4;c++) {
            matrix[f][c] = num;
            num = num+1;
        }
    }
    // Ingrese numero 1 al 20 :
    cout << "Ingrese Numero del 1 al 20 : ";
    cin >> num;
    cout << "" << endl;
    if (num>=1 && num<=20) {
        // Mostrar Datos al Array Bidimencional 2
        for (f=0;f<=3;f++) {
            cout << matrix[f][0] << " " << matrix[f][1] << " " << matrix[f][2] << " " << matrix[f][3] << " " << matrix[f][4] << endl;
        }
        cout << "" << endl;
        // Buscando Numero
        for (f=0;f<=3;f++) {
            for (c=0;c<=4;c++) {
                if (matrix[f][c]==num) {
                    cout << "Posicion en la MATRIZ[" << f+1 << "," << c+1 << "]" << endl;
                }
            }
        }
    } else {
        cout << "Numero mal Ingresado";
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    matrix = [[int() for ind0 in range(5)] for ind1 in range(4)]
    num = 1
    # Carga Números Naturales
    for f in range(4):
        for c in range(5):
            matrix[f][c] = num
            num = num+1
    # Ingrese numero 1 al 20 :
    print("Ingrese Número del 1 al 20 :")
    num = int(input())
    print("")
    if num>=1 and num<=20:
        # Mostrar Datos al Array Bidimencional 2
        for f in range(4):
            print(matrix[f][0]," ",matrix[f][1]," ",matrix[f][2]," ",matrix[f][3]," ",matrix[f][4])
        print("")
        # Buscando Número
        for f in range(4):
            for c in range(5):
                if matrix[f][c]==num:
                    print("Posición en la MATRIZ[",f+1,",",c+1,"]")
    else:
        print("Número mal Ingresado")
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site