Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

01. Cronometro en PSeInt.

Codificar un cronometro de forma descendente que permita ingresar, la hora, minuto y segundo hasta llegar a la hora 00:00:00.

Ingrese la hora : 0 ↲
Ingrese el minuto : 1 ↲
Ingrese el segundo : 4 ↲


0:1:4
0:1:3
0:1:2
0:1:1
0:1:0
0:0:60
0:0:59
.
.
0:0:0



PSeInt.Site DESCARGA CÓDIGO

    
Algoritmo Cronometro
    
    Definir H, M, S, CH, CM, Cs como numero;
    Definir continuar como caracter;
    
    H <- 0;
    M <- 0;
    S <- 0;
    continuar <- "s";
    
    Mientras continuar ="s" Hacer
        Repetir
            Escribir "Ingrese la hora : ";
            Leer H;
        Hasta Que H <= 24;
        
        Repetir
            Escribir "Ingrese el minuto : ";
            Leer M;
        Hasta Que M <= 60;
        
        Repetir
            Escribir "Ingrese el segundo : ";
            Leer S;
        Hasta Que S <= 60;
    
            
        Escribir "TIEMPO INGRESADO : ", H, ":", M, ":", S;
        para CH <- 0 hasta H con paso 1 hacer
            para CM <- 0 hasta M con paso 1 hacer
                para CS <- 0 hasta S con paso 1 hacer
                    Escribir (H-CH), ":", M, ":", (S-CS);
                    Esperar 1 Segundo;
                FinPara
                S <- 60;
                M <- M -1;
            FinPara
            M <- 60;
            S <- 60;
        FinPara

        Escribir "FIN DE CRONÓMETRO";
        Escribir "Volvera a Reiniciar la cuenta? (s/n)";
        Leer continuar;
    FinMientras
FinAlgoritmo
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site