PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

05. Conteo y suma de números ingresados.

Ingrese varios números enteros y muestre la cantidad de números ingresados y la suma de los mismos. Realice esta acción hasta que el usuario ingrese la palabra FIN.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos05
	
    Mientras Palabra != "FIN" Hacer			
        Escribir "Ingrese Número : "
        Leer Num
		
        Cantidad = Cantidad + 1
        Suma = Suma + Num
		
        Escribir "Escriba FIN para terminar : "
        Leer Palabra
	FinMientras
	
    Escribir "Cantidad de Números Ingresados : ", Cantidad
    Escribir "Suma de los Número Ingresados : ", Suma
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos05
	
    Definir Suma, Cantidad Como Entero;
    Definir Num, Palabra como Caracter;
	
    Suma <- 0;
    Cantidad <- 0;
    Num <- "";
	
    Mientras Num != "FIN" Hacer			
        Escribir "Ingrese Número o FIN para terminar: ";
        Leer Num;
		
        Si Num != "FIN" Entonces
            Cantidad <- Cantidad + 1;
            Suma <- Suma + ConvertirANumero(Num);		
        FinSi
    FinMientras
	
    Escribir "Cantidad de Números Ingresados : ", Cantidad;
    Escribir "Suma de los Número Ingresados : ", Suma;
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define MAX_STRLEN 256
int main() {
    int cantidad, suma;
    char num[MAX_STRLEN], palabra[MAX_STRLEN];
		
    suma = 0;
    cantidad = 0;
		
    while (strcmp(num,"FIN") !=0 ) {
        printf("Ingrese Numero o FIN para terminar: ");
        scanf("%s",num);
		
        if (strcmp(num,"FIN") != 0) {
            cantidad = cantidad+1;
            suma = suma+atof(num);
        }
    }
	
    printf ("\nCantidad de Numeros Ingresados : %i\n",cantidad);
    printf ("Suma de los Numeros Ingresados : %i\n",suma);
	
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
#include<cstdlib>
using namespace std;

int main() {
    int cantidad, suma;
    string num, palabra;
		
    suma = 0;
    cantidad = 0;
    num = "";
	
    while (num!="FIN") {
        cout << "Ingrese Numero o FIN para terminar: ";
        cin >> num;
        if (num!="FIN") {
            cantidad = cantidad+1;
            suma = suma+atof((num).c_str());
        }
    }
	
    cout << endl << "Cantidad de Numeros Ingresados : " << cantidad << endl;
    cout << "Suma de los Numero Ingresados : " << suma << endl;
	
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    suma = 0
    cantidad = 0
    num = ""
    while num!="FIN":
        print("Ingrese Número o FIN para terminar: ")
        num = input()
        if num!="FIN":
            cantidad = cantidad+1
            suma = suma+float(num)
    print("Cantidad de Números Ingresados : ",cantidad)
    print("Suma de los Número Ingresados : ",int(suma))
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site