Suma de cifras

¡Haz clic para puntuar este proyecto!
(Votos: 6 Promedio: 4.2)

Ingresar un número de cualquier cifra y mostrar, la suma de sus cifras.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Escribir "Ingrese Número : "
        Leer Num
        sw = 0
        Cont = 1
        Si Num < 10 Entonces
            Escribir Num
        SiNo
        //Captura número divisor
        Mientras sw = 0 Hacer			
            Si Num > (Cont * 10) Entonces
                Cont = Cont * 10
            SiNo
                sw = 1
            Fin Si				
        Fin Mientras	
        //Descompone número
        Mientras Num > 10			
            R = Num MOD Cont
            D = (Num - R)/ Cont			
            Suma = Suma + D
            Num = R
            Cont = Cont / 10
        FinMientras		
            Escribir Suma + R		
        Fin Si		
    FinAlgoritmo
    

    Lenguaje C

        
    #include<stdio.h>
    int main() {
        int cont, num, sw, d, r, suma;
        printf("Ingrese Numero : ");
        scanf("%d",&num);	
        sw = 0;
        cont = 1;
        suma = 0;
        if (num < 10) {
            printf("%i \n",num);
        } else {
            // Captura numero divisor
            while (sw == 0) {
                if (num > (cont * 10)) {
                    cont = cont * 10;
                } else {
                    sw = 1;
                }
            }
            // Descompone numero
            while (num > 10) {
                r = num % cont;
                d = (num-r)/cont;
                suma = suma+d;
                num = r;
                cont = cont/10;
            }
            printf("%d \n", suma + r);
        }
        return 0;
    }	
    

    C++

      
    #include<iostream>
    using namespace std;
    int main() {
        int cont, num, sw, d, r, suma;
        cout << "Ingrese Numero : ";
        cin >> num;
        sw = 0;
        cont = 1;
        suma = 0;
        if (num < 10) {
            cout << num << endl;
        } else {
            //Captura numero divisor
            while (sw==0) {
                if (num>(cont*10)) {
                    cont = cont*10;
                } else{
                    sw = 1;
                }
            }
            // Descompone numero
            while ((num > 10)) {
                r = num % cont;
                d = (num-r)/cont;
                suma = suma + d;
                num = r;
                cont = cont/10;
            }
            cout << suma+r << endl;
        }
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir