PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

04. Número de cifras invertidas. - Ejm. (342 - 243)

Ingresar un número cualquiera de varias cifras y devolver el mismo número con sus cifras invertidas.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos04

    Escribir "Ingrese Número : "
    Leer Num
    sw = 0
    Cont = 1

    Si Num < 10 Entonces
        Escribir Num
    SiNo
    
        //Captura número divisor
        Mientras sw = 0 Hacer			
            Si Num > (Cont * 10) Entonces
                Cont = Cont * 10
            SiNo
                sw = 1
            Fin Si				
        Fin Mientras	
        
        //Descompone número
        X = 1
        Mientras Num > 10			
            R = Num MOD Cont
            D = (Num - R)/ Cont			
            Suma = (D * X) + Suma
            X = X * 10
            Num = R
            Cont = Cont / 10
        FinMientras		
        Escribir (X * R)+ Suma		
    Fin Si		
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos04
	
    Definir Num, sw, Cont, X, R, D, Suma  como Entero;
		
    Escribir "Ingrese Número : ";
    Leer Num;
    sw <- 0;
    Cont <- 1;
    Suma <- 0;

    Si Num < 10 Entonces
        Escribir Num;
    SiNo
		
        //Captura número divisor
        Mientras sw = 0 Hacer			
            Si Num > (Cont * 10) Entonces
                Cont <- Cont * 10;
            SiNo
                sw <- 1;
            FinSi				
        FinMientras	
        
        //Descompone número
        X <- 1;
        R <- 0;
        D <- 0;
        Mientras Num > 10 Hacer
            R <- Num MOD Cont;
            D <- (Num - R)/ Cont;
            Suma <- (D * X) + Suma;
            X <- X * 10;
            Num <- R;
            Cont <- Cont / 10;
        FinMientras		
        Escribir (X * R)+ Suma;
    FinSi
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int cont, d, r, x, num, sw, suma;
	
    printf("Ingrese Numero : ");
    scanf("%i",&num);	
	
    sw = 0;
    cont = 1;
    suma = 0;
	
    if (num < 10) {
        printf("%i \n", num);		
    } else {
		
        // Captura numero divisor
        while (sw == 0) {
            if (num>(cont*10)) {
                cont = cont*10;
            } else {
                sw = 1;
            }
        }
		
        // Descompone numero
        x = 1;
        r = 0;
        d = 0;
        while (num > 10) {
            r = num%cont;
            d = (num-r)/cont;
            suma = (d*x)+suma;
            x = x*10;
            num = r;
            cont = cont/10;
        }
        printf("\n");
        printf("%d\n",(x*r)+suma);
    }
	
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
    int cont, d, r, x, num, sw, suma;
	
    cout << "Ingrese Numero : ";
    cin >> num;
	
    sw = 0;
    cont = 1;
    suma = 0;
	
    if (num < 10) {
        cout << num << endl;
    } else {
		
        // Captura numero divisor
        while (sw == 0) {
            if (num>(cont*10)) {
                cont = cont*10;
            } else {
                sw = 1;
            }
        }
		
        // Descompone numero
        x = 1;
        r = 0;
        d = 0;
        while (num>10) {
            r = num%cont;
            d = (num-r)/cont;
            suma = (d*x)+suma;
            x = x*10;
            num = r;
            cont = cont/10;
        }
        cout << " " << endl;
        cout << (x*r)+suma << endl;
    }
	
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    print("Ingrese Número : ")
    num = int(input())
    sw = 0
    cont = 1
    suma = 0
    if num < 10:
        print(num)
    else:

        # Captura número divisor
        while sw==0:
            if num>(cont*10):
                cont = cont*10
            else:
                sw = 1
		
        # Descompone número
        x = 1
        r = 0
        d = 0
        while num>10:
            r = num%cont
            d = (num-r)/cont
            suma = (d*x)+suma
            x = x*10
            num = r
            cont = cont/10
        print(int((x*r)+suma))
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site