Número de cifras invertidas. - Ejm. (342 - 243)

¡Haz clic para puntuar este proyecto!
(Votos: 2 Promedio: 5)

Ingresar un número cualquiera de varias cifras y devolver el mismo número con sus cifras invertidas.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Escribir "Ingrese Número : "
        Leer Num
        sw = 0
        Cont = 1
        Si Num < 10 Entonces
            Escribir Num
        SiNo
            Mientras sw = 0 Hacer			
                Si Num > (Cont * 10) Entonces
                    Cont = Cont * 10
                SiNo
                    sw = 1
                Fin Si				
            Fin Mientras	
            X = 1
            Mientras Num > 10			
                R = Num MOD Cont
                D = (Num - R)/ Cont			
                Suma = (D * X) + Suma
                X = X * 10
                Num = R
                Cont = Cont / 10
            FinMientras		
            Escribir (X * R)+ Suma		
        Fin Si		
    FinAlgoritmo
    

    Lenguaje C

        
    #include<stdio.h>
    int main() {
        int cont, d, r, x, num, sw, suma;
        printf("Ingrese Numero : ");
        scanf("%i",&num);	
        sw = 0;
        cont = 1;
        suma = 0;
        if (num < 10) {
            printf("%i \n", num);		
        } else {
            // Captura numero divisor
            while (sw == 0) {
                if (num>(cont*10)) {
                    cont = cont*10;
                } else {
                    sw = 1;
                }
            }
            // Descompone numero
            x = 1;
            r = 0;
            d = 0;
            while (num > 10) {
                r = num%cont;
                d = (num-r)/cont;
                suma = (d*x)+suma;
                x = x*10;
                num = r;
                cont = cont/10;
            }
            printf("\n");
            printf("%d\n",(x*r)+suma);
        }
        return 0;
    }
    

    Python

    print("Ingrese Número : ")
    num = int(input())
    sw = 0
    cont = 1
    suma = 0
    if num < 10:
        print(num)
    else:
        # Captura número divisor
        while sw==0:
            if num>(cont*10):
                cont = cont*10
            else:
                sw = 1
        # Descompone número
        x = 1
        r = 0
        d = 0
        while num>10:
            r = num%cont
            d = (num-r)/cont
            suma = (d*x)+suma
            x = x*10
            num = r
            cont = cont/10
        print(int((x*r)+suma))
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir