Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

02. Promedio de notas aprobadas y desaprobadas.

Dado N notas, calcular el promedio de las notas aprobadas y el promedio de las notas desaprobadas.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos02
	
    Escribir "Ingrese la cantidad de Notas : "
    Leer Num_Notas
	
    Mientras cont < Num_Notas Hacer
        cont = cont + 1
        Escribir "Ingrese Nota ", cont , " de ", Num_Notas, " : "
        Leer Nota
					
            Si Nota > 10 Entonces
                Nota_Apro = Nota_Apro + Nota
                Pro_Apro = Pro_Apro + 1
            SiNo
                Nota_Des = Nota_Des + Nota
                Pro_Des = Pro_Des + 1
            Fin Si	
    Fin Mientras
	
    Escribir "Promedio de Notas Aprobadas : ", (Nota_Apro / Pro_Apro)
    Escribir "Promedio de Notas Desaprobadas : ", (Nota_Des / Pro_Des)
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos02
	
    Definir cont, Nota, Num_Notas, Nota_Apro, Nota_Des como Entero;
    Definir Pro_Apro, Pro_Des como Real;
	
    cont <- 0;
    Nota <- 0;
    Num_Notas <- 0;
    Nota_Apro <- 0;
    Nota_Des <- 0;
    Pro_Apro <- 0;
    Pro_Des <- 0;
	
    Escribir "Ingrese la cantidad de Notas : ";
    Leer Num_Notas;
		
    Mientras cont < Num_Notas Hacer
        cont <- cont + 1;
        Escribir "Ingrese Nota ", cont , " de ", Num_Notas, " : ";
        Leer Nota;
					
            Si Nota > 10 Entonces
                Nota_Apro <- Nota_Apro + Nota;
                Pro_Apro <- Pro_Apro + 1;
            SiNo
                Nota_Des <- Nota_Des + Nota;
                Pro_Des <- Pro_Des + 1;
            FinSi
    FinMientras		
		
    Si Pro_Des = 0 Entonces
        Pro_Des <- 1;
    FinSi
    Si Pro_Apro = 0 Entonces
        Pro_Apro <- 1;
    FinSi		
	
    Escribir "Promedio de Notas Aprobadas : ", (Nota_Apro / Pro_Apro);
    Escribir "Promedio de Notas Desaprobadas : ", (Nota_Des / Pro_Des);
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int cont, nota, nota_apro, nota_des, num_notas;
    float pro_apro, pro_des;
    	
    cont = 0;
    nota = 0;
    num_notas = 0;
    nota_apro = 0;
    nota_des = 0;
    pro_apro = 0;
    pro_des = 0;
    
    printf("Ingrese la cantidad de Notas : ");
    scanf("%i",&num_notas);	
    printf("\n");
	
    while(cont < num_notas){
        cont = cont + 1;
        printf("Ingrese Nota %i de %i : ", cont, num_notas);
        scanf("%i",¬a);
        if(nota > 10) {
            nota_apro = nota_apro + nota;
            pro_apro = pro_apro + 1;
        } else{
            nota_des = nota_des + nota;
            pro_des = pro_des + 1;
        }
    }
	    
    if(pro_des == 0) {
        pro_des = 1;
    }
    if(pro_apro == 0) {
        pro_apro = 1;
    }
	
    printf("\nPromedio de Notas Aprobadas : %.2f \n", (nota_apro/pro_apro));
    printf("Promedio de Notas Desaprobadas : %.2f \n", (nota_des/pro_des));
	
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;

int main() {
    int cont, nota, nota_apro, nota_des, num_notas;
    float pro_apro, pro_des;
	
    cont = 0;
    nota = 0;
    num_notas = 0;
    nota_apro = 0;
    nota_des = 0;
    pro_apro = 0;
    pro_des = 0;
	
    cout << "Ingrese la cantidad de Notas : ";
    cin >> num_notas; 
    cout << " " << endl;
	
    while (cont < num_notas) {
        cont = cont+1;
        cout << "Ingrese Nota " << cont << " de " << num_notas << " : ";
        cin >> nota;
        if (nota>10) {
            nota_apro = nota_apro+nota;
            pro_apro = pro_apro+1;
        } else {
            nota_des = nota_des+nota;
            pro_des = pro_des+1;
        }
    }
	
    if (pro_des==0) {
        pro_des = 1;
    }
    if (pro_apro==0) {
        pro_apro = 1;
    }
    cout << " " << endl;
    cout << "Promedio de Notas Aprobadas : " << (nota_apro/pro_apro) << endl;
    cout << "Promedio de Notas Desaprobadas : " << (nota_des/pro_des) << endl;
	
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    cont = 0
    nota = 0
    num_notas = 0
    nota_apro = 0
    nota_des = 0
    pro_apro = 0
    pro_des = 0
    print("Ingrese la cantidad de Notas : ")
    num_notas = int(input())
    while cont < num_notas:
        cont = cont+1
        print("Ingrese Nota ",cont," de ",num_notas," : ")
        nota = int(input())
        if nota > 10:
            nota_apro = nota_apro+nota
            pro_apro = pro_apro+1
        else:
            nota_des = nota_des+nota
            pro_des = pro_des+1
	
    if pro_des==0:
        pro_des = 1
    if pro_apro==0:
        pro_apro = 1
        
    print("Promedio de Notas Aprobadas : ",(nota_apro/pro_apro))
    print("Promedio de Notas Desaprobadas : ",(nota_des/pro_des))
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site