Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

08. Registrar n PRODUCTOS.

Realizar un programa que registre n productos dónde se solicite la descripción y el precio de venta. Si el total de la compra es mayor que 500 soles dar un descuento de 20% de lo contrario de 5%, mostrar una lista de todos los registros y su respectivo descuento. El programa termina cuando se formule la pregunta SI desea continuar o NO registrando productos.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos08
	
    Mientras Palabra != "N" Hacer					
        Escribir "INGRESE NOMBRE PRODUCTO :"	
        Leer PRODUCTO
        Escribir "INGRES PRECIO VENTA :"
        Leer Monto
        TOTAL = TOTAL + Monto	
        Escribir "Desea Continuar (S/N )"
        Leer Palabra							
    FinMientras
	
    Escribir "Monto Total de Compra : ", TOTAL
    
    SI TOTAL > 500 Entonces
        Descuento = TOTAL * 0.20
        Escribir "Descuento Generado 20% : ", Descuento
    SiNo	
        Descuento = TOTAL * 0.05
        Escribir "Descuento Generado 5% : ", Descuento
    FinSi	
    Escribir "Total a Pagar : ", TOTAL - Descuento
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos08
	
    Definir Palabra, PRODUCTO como Caracter;
    Definir Monto, TOTAL, Descuento como Real;
	
    Palabra <- "";
    PRODUCTO <- "";
    Monto <- 0;
    TOTAL <- 0;
    Descuento <- 0;
		
    Mientras Palabra != "N" Hacer					
        Escribir "INGRESE NOMBRE PRODUCTO :";
        Leer PRODUCTO;
        Escribir "INGRES PRECIO VENTA :";
        Leer Monto;
        TOTAL <- TOTAL + Monto;
        Escribir "Desea Continuar (S/N )";
        Leer Palabra;	
    FinMientras
	
    Escribir "Monto Total de Compra : ", TOTAL;
	
    SI TOTAL > 500 Entonces
        Descuento <- TOTAL * 0.20;
        Escribir "Descuento Generado 20% : ", Descuento;
    SiNo	
        Descuento <- TOTAL * 0.05;
        Escribir "Descuento Generado 5% : ", Descuento;
    FinSi	
    Escribir "Total a Pagar : ", TOTAL - Descuento;
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

       
#include<stdio.h>
#include<string.h>
#define MAX_STRLEN 256
	
int main() {
    float descuento, monto, total;
    char palabra[MAX_STRLEN] = {" "};
    char producto[MAX_STRLEN] = {" "};
		    
    monto = 0;
    total = 0;
    descuento = 0;

    while (strcmp(palabra,"N") != 0) {
        printf("INGRESE NOMBRE PRODUCTO : ");
        scanf("%s", producto);
        printf("INGRES PRECIO VENTA : ");
        scanf("%f", &monto);
        total = total + monto;
        printf("Desea Continuar (S/N ) : ");
        scanf("%s",palabra);
        printf("\n");
    }
    
    printf("Monto Total de Compra : %.2f \n", total);

    if (total > 500) {
        descuento = total * 0.20;
        printf("Descuento Generado 20 PORCIENTO : %.2f \n", descuento);
    } else {
        descuento = total * 0.05;
        printf("Descuento Generado 5 PORCIENTO : %.2f \n", descuento);
    }
    printf("Total a Pagar : %.2f \n", total-descuento);
    
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;

int main() {
    float descuento, monto, total;
    string palabra, producto;
		
    palabra = "";
    producto = "";
    monto = 0;
    total = 0;
    descuento = 0;
	
    while (palabra!="N") {
        cout << "INGRESE NOMBRE PRODUCTO : ";
        cin >> producto;
        cout << "INGRES PRECIO VENTA : ";
        cin >> monto;
        total = total+monto;
        cout << "Desea Continuar (S/N ) : ";
        cin >> palabra;
        cout << " " << endl;
    }
    
    cout << "Monto Total de Compra : " << total << endl;

    if (total>500) {
        descuento = total*0.20;
        cout << "Descuento Generado 20% : " << descuento << endl;
    } else {
        descuento = total*0.05;
        cout << "Descuento Generado 5% : " << descuento << endl;
    }
    cout << "Total a Pagar : " << total-descuento << endl;
    
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    palabra = ""
    producto = ""
    monto = 0
    total = 0
    descuento = 0
    while palabra!="N":
        print("INGRESE NOMBRE PRODUCTO :")
        producto = input()
        print("INGRES PRECIO VENTA :")
        monto = float(input())
        total = total+monto
        print("Desea Continuar (S/N )")
        palabra = input()
    print("Monto Total de Compra : ",total)
    if total>500:
        descuento = total*0.20
        print("Descuento Generado 20% : ",descuento)
    else:
        descuento = total*0.05
        print("Descuento Generado 5% : ",descuento)
    print("Total a Pagar : ",total-descuento)
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site