Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

09. Seriación Gráfica.

Cada vez que se pulse la tecla C, deberá mostrar la siguiente secuencia gráfica:

*
**
***
****
*****

Si se pulsa cualquier otra tecla el programa termina.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos09
	
    Palabra = "C"
    Limite = 0
    Mientras Palabra == "C" Hacer
        cadena = ""
        Para Cont <- 0 Hasta Limite Con Paso 1 Hacer
            cadena = cadena + "*"
        Fin Para		
        Escribir cadena
        Limite = Limite + 1
		
        Escribir "Pulse C Para Monstrar Secuencia Gráfica"
        Leer Palabra							
    FinMientras

FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos09
	
    Definir Palabra, cadena como Caracter;
    Definir Cont, Limite como Entero;
	
    Palabra <- "C";
    Limite <- 0;
	
    Mientras Palabra == "C" Hacer
        cadena <- "";
        Para Cont <- 0 Hasta Limite Con Paso 1 Hacer
            cadena <- Concatenar(cadena, "*");
        FinPara		
        Escribir cadena;
        Limite <- Limite + 1;
        Escribir "Pulse C Para Monstrar Secuencia Gráfica";
        Leer Palabra;
    FinMientras

FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include<stdio.h>
#include<string.h>
#define MAX_STRLEN 256
int main() {
    int cont, limite;
    char cadena[MAX_STRLEN] = {""};
    char palabra[MAX_STRLEN] = {"C"};
		        	
    limite = 0;
	
    while (strcmp(palabra,"C")==0) {		
        for (cont=0;cont<=limite;cont+=1) {
            printf("*");
        }
        printf("%s\n",cadena);
        limite = limite + 1;
        printf("Pulse C Para Monstrar Secuencia Grafica\n");
        scanf("%s",palabra);
    }
	
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
    int cont, limite;
    string cadena, palabra;
	
    palabra = "C";
    limite = 0;
	
    while (palabra=="C") {
        cadena = "";
        for (cont=0;cont<=limite;cont++) {
            cadena = (cadena+"*");
        }
        cout << cadena << endl;
        limite = limite+1;
        cout << "Pulse C Para Monstrar Secuencia Grafica" << endl;
        cin >> palabra;
    }
	
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    palabra = "C"
    limite = 0
    while palabra=="C":
        cadena = ""
        for cont in range(limite+1):
            cadena = cadena+"*"
        print(cadena)
        limite = limite+1
        print("Pulse C Para Monstrar Secuencia Gráfica")
        palabra = input()
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site