Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

01. Suma de "n" números naturales.

Hacer un programa que calcule la suma de los N primeros números naturales, dónde N es el número límite ingresado por teclado.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos01
	
	Escribir "Ingrese un Número : "
	Leer Num
	
	Mientras cont <= Num Hacer
		Suma = Suma + Cont
		Cont = Cont + 1
	Fin Mientras
	
	Escribir "La Suma es : ", Suma		
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos01
	
	Definir Cont, Num, Suma como Entero;
	Cont <- 0;
	Suma <- 0;
	
	Escribir "Ingrese un Número : ";
	Leer Num;
	
	Mientras Cont <= Num Hacer
		Suma <- Suma + Cont;
		Cont <- Cont + 1;
	FinMientras
	
	Escribir "La Suma es : ", Suma;		
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>

int main() {
    int cont, num, suma;
    cont = 0;
    suma = 0;
    
    printf("Ingrese un Numero : ");
    scanf("%i",&num);
    while (cont <= num) {    	
        suma = suma + cont;
        cont = cont + 1;
    }
    printf("La Suma es : %i", suma) ;
			
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;

int main() {
    int cont, num, suma;
    cont = 0;
    suma = 0;
    
    cout << "Ingrese un Numero : ";
    cin >> num;
    while (cont <= num) {
        suma = suma+cont;
        cont = cont+1;
    }
    cout << "La Suma es : " << suma << endl;
	
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    print("Ingrese un Número : ")
    num = int(input())
    cont = 0
    suma = 0
    while cont <= num:
        suma = suma+cont
        cont = cont+1
    print("La Suma es : ",suma)
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site