PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

Calcular el total de ventas realizadas por género.

21. Una Corporación comercial registra el nombre, género y la cantidad de ventas realizado durante el mes de cada uno de sus N empleados, se pide calcular el total de ventas realizadas por género durante el mes así con el porcentaje de mujeres que trabajan en la corporación.

A. Estructura del pseudocódigo y entrada de datos.
B. Cantidad de ventas por género.
C. El porcentaje de mujeres que trabajan en la corporación.
D. Mostrar el resultado de los cálculos.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo www_pseint_site
    
    Escribir Sin Saltar "CANTIDAD DE EMPLEADOS : "
    Leer empleados
    Escribir ""
	
    Para cont = 1 Hasta empleados Con paso 1 Hacer		
        Escribir "EMPLEADO Nro ",cont,"/",empleados
        Escribir Sin Saltar "NOMBRE : "
        Leer nom
        Escribir Sin Saltar "GÉNERO (H/M) : "
        Leer genero
        Escribir Sin Saltar "VENTAS : "
        Leer ventas
        Escribir ""		
        Si (genero == "H") Entonces
            tv_h = tv_h + ventas
        SiNo
            tv_m = tv_m + ventas
            muj = muj + 1
        FinSi					
    FinPara
	
    Escribir "TOTAL DE VENTAS HOMBRES : ",tv_h
    Escribir "TOTAL DE VENTAS MUJERES : ",tv_m
    Escribir ""
    Escribir "PORCENTAJE DE MUJERES   : ",(muj * 100)/empleados

FinAlgoritmo    
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

Perfiles : UTP-Peru │ ESPE

    
Algoritmo www_pseint_site

    Definir cont, ventas, empleados, tv_h, tv_m, muj como entero;
    Definir nom, genero como Caracter;
	
    tv_h <- 0;
    tv_m <- 0;	
    muj <- 0;
	
    Escribir Sin Saltar "CANTIDAD DE EMPLEADOS : ";
    Leer empleados;
    Escribir "";
	
    Para cont <- 1 Hasta empleados Con paso 1 Hacer
        Escribir "EMPLEADO Nro ",cont,"/",empleados;
        Escribir Sin Saltar "NOMBRE : ";
        Leer nom;
        Escribir Sin Saltar "GÉNERO (H/M) : ";
        Leer genero;
        Escribir Sin Saltar "VENTAS : ";
        Leer ventas;
        Escribir "";
        Si (genero == "H") Entonces
            tv_h <- tv_h + ventas;
        SiNo
            tv_m <- tv_m + ventas;
            muj <- muj + 1;
        FinSi			
    FinPara
	
    Escribir "TOTAL DE VENTAS HOMBRES : ",tv_h;
    Escribir "TOTAL DE VENTAS MUJERES : ",tv_m;
    Escribir "";
    Escribir "PORCENTAJE DE MUJERES   : ",(muj * 100)/empleados;
	
FinAlgoritmo
    


Python DESCARGA CÓDIGO


tv_h=0; tv_m=0; muj=0; empleados=0;

empleados = int(input("CANTIDAD DE EMPLEADOS : "))

for cont in range(0,empleados):
    nom = input("\nNOMBRE : ")
    genero = input("GÉNERO H/M :")
    ventas = int(input("VENTAS : "))

    if genero.upper() == "H":
        tv_h = tv_h + ventas
    else:
        tv_m = tv_m + ventas
        muj+=1

print("\nTOTAL DE VENTAS HOMBRES : ", tv_h)
print("TOTAL DE VENTAS MUJERES : ", tv_m)
print("PORCENTAJE DE MUJERES   : ", (muj*100)/empleados)







Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site