PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

Calcular la ganancia de una garíta de control.

22. Una garita cobra por el paso de vehículos. El cobro se realiza de acuerdo al vehículo; hay tres tipos de vehículos Ómnibus, Minivan y micro que su tarifa es de 13, 10, 8 soles respectivamente, ingrese el tipo de vehículo y el turno (Mañana, Noche).

Desarrollar un algoritmo que permita: Ingresar datos: La cantidad de vehículos, de cada vehículo se debe ingresar el tipo y el turno (Mañana, Noche).

A. Ingreso de datos.
B. Calculo del importe total recaudado en cada turno.
C. Calculo del importe total recaudado por cada tipo de vehículo.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo www_pseint_site
    
    Escribir Sin Saltar "CANTIDAD DE VEHICULOS "
    Leer cantidad
    Escribir " "
	
    Para cont = 1 Hasta  cantidad con paso 1 Hacer
        Escribir ">> TIPO DE VEHÍCULO Nro ", cont, "/",cantidad, " : "
        Escribir "1. Ómnibus"
        Escribir "2. Minivan"
        Escribir "3. Micro"
        Escribir Sin Saltar "OPC : "
        Leer tipo;		
        Segun (tipo) Hacer
            1: tarifa = 13
                bus = bus + tarifa		
            2: tarifa = 10
                van = van + tarifa		
            3: tarifa = 8
                micro = micro + tarifa
        FinSegun		
        Escribir Sin Saltar "TURNO (M/N): "
        Leer turno
        Si (turno == "M") Entonces
            man = man + tarifa
        SiNo
            noc = noc + tarifa
        FinSi	
        Escribir " "	
    FinPara
	
    Escribir " "
    Escribir "IMPORTE DE TURNO MAÑANA :", man
    Escribir "IMPORTE DE TURNO NOCHE :", noc
    Escribir " "
    Escribir "IMPORTE DE ÓMNIBUS :", bus
    Escribir "IMPORTE DE MINIVAN :", van
    Escribir "IMPORTE DE MICRO :", micro

FinAlgoritmo    
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

Perfiles : UTP-Peru │ ESPE

    
Algoritmo www_pseint_site

    Definir man, noc, cont, tipo, cantidad, bus, van, micro como Entero;
    Definir tarifa como Real;
    Definir turno como Caracter;
	
    tarifa <- 0;
    bus <- 0;
    van <- 0;
    micro <- 0;
    man <- 0;
    noc <- 0;
	
    Escribir Sin Saltar "CANTIDAD DE VEHICULOS ";
    Leer cantidad;	
    Escribir " ";
	
    Para cont <- 1 Hasta  cantidad con paso 1 Hacer
        Escribir ">> TIPO DE VEHÍCULO Nro ", cont, "/",cantidad, " : ";
        Escribir "1. Ómnibus";
        Escribir "2. Minivan";
        Escribir "3. Micro";
        Escribir Sin Saltar "OPC : ";	
        Leer tipo;		
        Segun (tipo) Hacer
            1: tarifa <- 13;
                bus <- bus + tarifa;				
            2: tarifa <- 10;
                van <- van + tarifa;				
            3: tarifa <- 8;
                micro <- micro + tarifa;
        FinSegun		
        Escribir Sin Saltar "TURNO (M/N): ";
        Leer turno;		
        Si (turno == "M") Entonces
            man <- man + tarifa;
        SiNo
            noc <- noc + tarifa;
        FinSi	
        Escribir " ";		
    FinPara
	
    Escribir " ";
    Escribir "IMPORTE DE TURNO MAÑANA :", man;
    Escribir "IMPORTE DE TURNO NOCHE :", noc;
    Escribir " ";
    Escribir "IMPORTE DE ÓMNIBUS :", bus;
    Escribir "IMPORTE DE MINIVAN :", van;
    Escribir "IMPORTE DE MICRO :", micro;
	
FinAlgoritmo
    


Python DESCARGA CÓDIGO


bus=0; van=0; micro=0; man=0; noc=0;

cantidad = int(input("CANTIDAD DE VEHICULOS : "))

for cont in range(0,cantidad):
    print("\n1. Ómnibus")
    print("2. Minivan")
    print("3. Micro")
    tipo = int(input("OPCIÓN : "))

    if tipo == 1:
        tarifa = 13
        bus = bus + tarifa
    elif tipo == 2:
        tarifa = 10
        van = van + tarifa
    elif tipo == 3:
        tarifa = 8
        micro = micro + tarifa

    turno = input("TURNO M/N : ")

    if turno.upper() == "M":
        man = man + tarifa
    else :
        noc = noc + tarifa

print("\nIMPORTE DE TURNO MAÑANA : ", man)
print("IMPORTE DE TURNO NOCHE  : ", noc)
print("IMPORTE DE ÓMNIBUS      : ", bus)
print("IMPORTE DE MINIVAN      : ", van)
print("IMPORTE DE MICRO        : ", micro)







Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site