PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

Número de letras C, S, D, L, R y M que hay

20. Desarrolle un algoritmo que ingrese un refrán o una frase y que indique el número de letras C, S, D, L, R y M que hay, además, que indique el número total de consonantes que tiene esa cadena de caracteres.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo www_pseint_site
    
    Escribir "Ingrese Refran : "
    Leer ref
	
    Para F = 0 Hasta Longitud(ref) Con paso 1 hacer
        Si (SubCadena(ref,F,F) != " ") Entonces
            refran = concatenar(refran,SubCadena(ref,F,F))
        FinSi		
    FinPara
		
    Para F = 1 Hasta Longitud(refran) Con paso 1 hacer
		
        letra = Mayusculas(SubCadena(refran,F,F))
		
        SI (letra == "C") Entonces
            C = C + 1
        FinSi
        SI (letra == "S") Entonces
            S = S + 1
        FinSi
        SI (letra == "D") Entonces
            D = D + 1
        FinSi
        SI (letra == "L") Entonces
            L = L + 1
        FinSi
        SI (letra == "R") Entonces
            R = R + 1
        FinSi
        SI (letra == "M") Entonces
            M = M + 1
        FinSi
		
        Si(letra != "A" Y letra != "E" Y letra != "I" Y letra != "O" Y letra != "U") Entonces
            consonante = consonante + 1
        FinSi
		
    FinPara
	
    Escribir "CANTIDA DE C : ", C
    Escribir "CANTIDA DE S : ", S
    Escribir "CANTIDA DE D : ", D
    Escribir "CANTIDA DE L : ", L
    Escribir "CANTIDA DE R : ", R
    Escribir "CANTIDA DE M : ", M
    Escribir ""
    Escribir "CANTIDA DE CONSONANTES : ", consonante

FinAlgoritmo    
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

Perfiles : UTP-Peru │ ESPE

    
Algoritmo www_pseint_site

    Definir refran, ref, letra como Caracter;
    Definir F, C, S, D, L, R, M, consonante como Entero;
	
    C <- 0;
    S <- 0;
    D <- 0;
    L <- 0;
    R <- 0;
    M <- 0;
    consonante <- 0;	
    refran <- "";
	
    Escribir "Ingrese Refran : ";
    Leer ref;
	
    Para F <- 0 Hasta Longitud(ref) Con paso 1 hacer
        Si (SubCadena(ref,F,F) != " ") Entonces
            refran <- concatenar(refran,SubCadena(ref,F,F));
        FinSi		
    FinPara
		
    Para F <- 1 Hasta Longitud(refran) Con paso 1 hacer
		
        letra <- Mayusculas(SubCadena(refran,F,F));
		
        SI (letra == "C") Entonces
            C <- C + 1;
        FinSi
        SI (letra == "S") Entonces
            S <- S + 1;
        FinSi
        SI (letra == "D") Entonces
            D <- D + 1;
        FinSi
        SI (letra == "L") Entonces
            L <- L + 1;
        FinSi
        SI (letra == "R") Entonces
            R <- R + 1;
        FinSi
        SI (letra == "M") Entonces
            M <- M + 1;
        FinSi
		
        Si(letra != "A" Y letra != "E" Y letra != "I" Y letra != "O" Y letra != "U") Entonces
            consonante <- consonante + 1;
        FinSi
		
    FinPara
	
    Escribir "CANTIDA DE C : ", C;
    Escribir "CANTIDA DE S : ", S;
    Escribir "CANTIDA DE D : ", D;
    Escribir "CANTIDA DE L : ", L;
    Escribir "CANTIDA DE R : ", R;
    Escribir "CANTIDA DE M : ", M;
    Escribir "";
    Escribir "CANTIDA DE CONSONANTES : ", consonante;
	
FinAlgoritmo
    


Python DESCARGA CÓDIGO


c=0; s=0; d=0; l=0; r=0; m=0; consonante = 0

ref = input("INGRESE REFRAN : ")
ref = ref.upper()
for f in range(0,len(ref)):
    if ref[f] == "C":
        c+=1
    if ref[f] == "S":
        s+=1
    if ref[f] == "D":
        d+=1
    if ref[f] == "L":
        l+=1
    if ref[f] == "R":
        r+=1
    if ref[f] == "M":
        m+=1
    if (ref[f]!="A" and ref[f]!="E" and ref[f]!="I" and ref[f]!="O" and ref[f]!="U" and ref[f]!=" "):
        consonante+=1

print("CANTIDAD DE C : ", c)
print("CANTIDAD DE S : ", s)
print("CANTiDAD de D : ", d)
print("CANTIDAD DE L : ", l)
print("CANTIDAD DE R : ", r)
print("CANTIDAD DE M : ", m)
print("CANTIDAD DE CONSOANTES : ", consonante)







Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site