Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

Obtener un porcentaje del consumo total.

04. Hacer un programa que lea 10 consumos de una cafetería, si el consumo total excede los $50, el descuento será 7% mostrar el pago total acumulado y su respectivo descuento si lo hubiera.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos04
	
    Para Cont <- 1 Hasta 10 Con Paso 1 Hacer		
        Escribir "Ingrese Consumo ", Cont , " : "
        Leer CONSUMO		
        TOTAL = TOTAL + CONSUMO				
    Fin Para
	
    Si TOTAL > 50 Entonces
        DESC = TOTAL * 0.07
    SiNo
        DESC = 0
    Fin Si		
	
    Escribir "CONSUMO TOTAL : ", TOTAL
    Escribir "DESCUENTO     : ", DESC
    Escribir "PAGO TOTAL    : ", (TOTAL - DESC)
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos04
	
    Definir Cont como Entero;
    Definir TOTAL, CONSUMO, DESC como Real;
	
    TOTAL <- 0;
    CONSUMO <- 0;
    DESC <- 0;
	
    Para Cont <-1 Hasta 10 Con Paso 1  Hacer		
        Escribir "Ingrese Consumo ", Cont , " : ";
        Leer CONSUMO;		
        TOTAL <- TOTAL + CONSUMO;		
    FinPara
	
    Si TOTAL > 50 Entonces
        DESC <- TOTAL * 0.07;
    SiNo
        DESC <- 0;
    FinSi		
	
    Escribir "CONSUMO TOTAL : ", TOTAL;
    Escribir "DESCUENTO     : ", DESC;
    Escribir "PAGO TOTAL    : ", (TOTAL - DESC);
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

            
#include<stdio.h>
int main(){	
    float consumo, desc, total;
    int cont;
	
    total = 0.0;
    consumo = 0.0;
    desc = 0.0;
	
    for (cont=1; cont<=10;cont++){
        printf("Ingrese Consumo %d : ", cont);
        scanf("%f",&consumo);
        total = total +consumo;
    }
    if(total >50){
        desc=total*0.07;
    }else{
        desc=0;
    }
    printf("\nCONSUMO TOTAL : %.2f \n", total);
    printf("DESCUENTO : %.2f \n", desc);
    printf("PAGO TOTAL : %.2f \n", (total-desc));
	
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;

int main(){	
    float consumo, desc, total;
    int cont;
	
    total = 0.0;
    consumo = 0.0;
    desc = 0.0;
	
    for (cont=1; cont<=10;cont++){
        cout << "Ingrese Consumo " << cont << " : ";
        cin >> consumo;
        total = total + consumo;
    }	

    if(total > 50){
        desc = total*0.07;
    }else{
        desc = 0;
    }
    
    cout << "\nCONSUMO TOTAL : " << total << endl;
    cout << "DESCUENTO  : " << desc << endl;
    cout << "PAGO TOTAL : " << total-desc << endl;
	
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    total = 0
    consumo = 0
    desc = 0
    for cont in range(1,11):
        print("Ingrese Consumo ",cont," : ")
        consumo = float(input())
        total = total+consumo
	
    if total>50:
        desc = total*0.07
    else:
        desc = 0
    print("CONSUMO TOTAL : ",total)
    print("DESCUENTO     : ",desc)
    print("PAGO TOTAL    : ",(total-desc))
     

Java NetBeans DESCARGA CÓDIGO

            
package Repetitivos;
import java.util.Scanner;

public class repetitivo4 {
    public static void main(String[] args) {

        int cont;
        Double consumo, total, desc;
        total = 0.0;
        Scanner ingreso=new Scanner(System.in);                                        
        for(cont = 1; cont < 11; cont++){
            System.out.print("Ingrese Consumo Nro " + cont + " : ");
            consumo = Double.parseDouble(ingreso.next());
            total = total + consumo;
        }                  
        if(total > 50){
            desc = total * 0.07;
        }else{
            desc = 0.0;
        }        
        System.out.println("CONSUMO TOTAL : " + total);
        System.out.println("DESCUENTO : " + desc);
        System.out.println("PAGO TOTAL : " + (total - desc));
    }     
}
     

Java Script DESCARGA CÓDIGO

               
<html>
<title>Ejercicio Repetitivos Para - For en JS - 04:</title>
<head>
<script language="JavaScript" type="text/javascript">
    function mayor(){	
        var consumo = "0";
        var total = "0";
        var desc = "0";
        for(var cont = 1; cont < 11; cont++) {        
            var consumo = prompt("INGRESE CONSUMO Nro " + cont + " :");  
            total = parseFloat(total) + parseFloat(consumo);
        }
        if(parseFloat(total) > 50) {
            desc = parseFloat(total) * 0.07;
        }else{
            desc = 0;
        }        
        document.getElementById('imput_total').value=total;
        document.getElementById('imput_desc').value=desc;
        document.getElementById('imput_pagot').value=parseFloat(total) - parseFloat(desc);      
    }
</script>
</head>
<body>
    <form method="get" name="ejercicio4">
        <input type="button" value="INICAR..." onClick="mayor()" > <br> <br> 
        CONSUMO TOTAL : <input name="imput_total" id="imput_total" type="text" > <br>
        DESCUENTO  : <input name="imput_desc" id="imput_desc" type="text" > <br>
        PAGO TOTAL : <input name="imput_pagot" id="imput_pagot" type="text" > <br>       
    </form>
</body>
</html>
     

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module4
    Dim Cont As Integer
    Dim Consumo, Total, Desc As Decimal
    Sub Main()

        For Cont = 1 To 10
            Write("Ingrese Consumo Nro " & Cont & " :")
            Consumo = ReadLine()
            Total = Total + Consumo
        Next

        If (Total > 50) Then
            Desc = Total * 0.07
        Else
            Desc = 0
        End If

        WriteLine("Consumo Total : " & Total)
        WriteLine("Descuento : " & Desc)
        WriteLine("Pago Total : " & Total - Desc)

        ReadLine()
    End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site