Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

Mostrar alumno con mayor nota.

05. Hacer un programa que permita almacenar los nombres y promedios de 5 alumnos, las notas deben estar entre 0 y 20. Mostrar el alumno con la mayor nota.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos05
	
    XPROM_MAY = 0
    	
    Para Cont <-1 Hasta 5 Con Paso 1  Hacer
    		
        Escribir "Ingrese Nombre ", Cont , " : "
        Leer NOMBRE
        Escribir "Ingrese Promedio ", Cont , " : "
        Leer PROMEDIO
    		
        Si PROMEDIO >= 0 Y PROMEDIO <= 20 Entonces
            Si XPROM_MAY < PROMEDIO Entonces
                XPROM_MAY = PROMEDIO				
                XNOM = NOMBRE
            Fin Si		
        SiNo
            CONT = CONT - 1
        Fin Si		
    		
    Fin Para
    		
    Escribir "ALUMNO   : ", XNOM	
    Escribir "PROMEDIO : ", XPROM_MAY
	
FinAlgoritmo    
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos05
	
    Definir XNOM, NOMBRE como Caracter;
    Definir XPROM_MAY, PROMEDIO, Cont como Entero;
    		
    XPROM_MAY <- 0;
    	
    Para Cont <-1 Hasta 5 Con Paso 1  Hacer
    		
        Escribir "Ingrese Nombre ", Cont , " : ";
        Leer NOMBRE;
        Escribir "Ingrese Promedio ", Cont , " : ";
        Leer PROMEDIO;
    		
        Si PROMEDIO >= 0 Y PROMEDIO <= 20 Entonces
            Si XPROM_MAY < PROMEDIO Entonces
                XPROM_MAY <- PROMEDIO;
                XNOM <- NOMBRE;
            FinSi		
        SiNo
            CONT <- CONT - 1;
        FinSi		
    	
    FinPara
    		
    Escribir "ALUMNO   : ", XNOM;
    Escribir "PROMEDIO : ", XPROM_MAY;
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

            
#include<stdio.h>
#include<string.h>
#define MAX_STRLEN 256
int main(){	
    int cont, promedio, xprom_may;
    char nombre[MAX_STRLEN], xnom[MAX_STRLEN];
		
    xprom_may = 0;
	
    for (cont=1; cont<=5; cont+=1){
        printf("\nIngrese Nombre %d   : ", cont);
        scanf("%s",nombre);
        printf("Ingrese Promedio %d : ", cont);
        scanf("%d",&promedio);
		
        if(promedio >= 0 && promedio <= 20){
            if(xprom_may < promedio){
                xprom_may = promedio;
                strcpy(xnom, nombre);
            }		
        }else{
            cont = cont - 1;
        }
    }
	
    printf("\nALUMNO  : %s\n", xnom);
    printf("PROMEDIO : %d \n", xprom_may);	
	
    return 0;
}
    

C++ DESCARGA CÓDIGO

      
#include<iostream>
using namespace std;
int main(){	
    int cont, promedio, xprom_may;
    string nombre, xnom;
		
    xprom_may = 0;
	
    for (cont=1; cont<=5; cont++){
        cout << "Ingrese Nombre " << cont << " : ";
        cin >> nombre;
        cout << "Ingrese Promedio " << cont << " : ";		
        cin >> promedio;
        cout << endl;
		
        if(promedio >= 0 && promedio <= 20){
            if(xprom_may < promedio){
                xprom_may = promedio;
                xnom = nombre;
            }		
        }else{
            cont = cont - 1;
        }
    }
	
    cout << "ALUMNO   : " << xnom << endl;
    cout << "PROMEDIO : " << xprom_may << endl;	
    
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    xprom_may = 0
    for cont in range(1,6):
        print("Ingrese Nombre ",cont," : ")
        nombre = input()
        print("Ingrese Promedio ",cont," : ")
        promedio = int(input())
        if promedio>=0 and promedio<=20:
            if xprom_may < promedio:
                xprom_may = promedio
                xnom = nombre
        else:
            cont = cont-1
    print("ALUMNO   : ",xnom)
    print("PROMEDIO : ",xprom_may)
    

Java NetBeans DESCARGA CÓDIGO

            
package Repetitivos;
import java.util.Scanner;
public class repetitivo5 {
    public static void main(String[] args) {        
        int cont;
        Double xprom_may, promedio;
        String nombre, xnom;
        xprom_may = 0.0;
        xnom = "";
        Scanner ingreso=new Scanner(System.in);                                        
        for(cont = 1; cont < 6; cont++){
            System.out.print("Ingrese Nombre Nro " + cont + " : ");
            nombre = ingreso.next();
            System.out.print("Ingrese Promedio Nro " + cont + " : ");
            promedio = Double.parseDouble(ingreso.next());
            if(promedio >= 0 && promedio <= 20){
                if(xprom_may < promedio){
                    xprom_may = promedio;
                    xnom = nombre;
                }
            }else{
                cont = cont - 1;
            }
        }                  
        System.out.println("ALUMNO   : " + xnom);
        System.out.println("PROMEDIO : " + xprom_may);
    }
}
    

Java Script DESCARGA CÓDIGO

      
<html>
    <title>Ejercicio Repetitivos Para - For en JS - 05:</title>
<head>
<script language="JavaScript" type="text/javascript">
    function almacena(){	
    var promedio = "0";
    var xprom_may = "0";
    var nombre = "";
    var xnom = "";
    for(var cont = 1; cont < 6; cont++) {        
        var nombre = prompt("INGRESE NOMBRE NRO " + cont + " :");  
        var promedio = prompt("INGRESE PROMEDIO NRO " + cont + " :");  
            if(parseInt(promedio) >= 0 && parseInt(promedio) <= 20) {
                if(parseInt(xprom_may) < parseInt(promedio)) {
                    xprom_may = parseInt(promedio);
                    xnom = nombre;
                }       
            }else{
                cont = parseInt(cont) - 1;
            }                 
    }
    document.getElementById('alumno').value=xnom;
    document.getElementById('imput_promedio').value=xprom_may;
    }
</script>
</head>
<body>
    <form method="get" name="ejercicio5">
        <input type="button" value="INICAR..." onClick="almacena()" > <br> <br>
        ALUMNO   : <input name="alumno" id="alumno" type="text" > <br>    
        PROMEDIO : <input name="imput_promedio" id="imput_promedio" type="text" > <br>
    </form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module5
    Dim Cont, Promedio, xprom_May As Integer
    Dim Nombre, Xnom As String
    Sub Main()
    
        xprom_May = 0
        
        For Cont = 1 To 5
            Write("Ingrese Nombre " & Cont & " :")
            Nombre = ReadLine()
            Write("Ingrese Promedio " & Cont & " :")
            Promedio = ReadLine()

            If ((Promedio >= 0) And (Promedio <= 20)) Then
                If (xprom_May < Promedio) Then
                    xprom_May = Promedio
                    Xnom = Nombre
                End If
            Else
                Cont = Cont - 1
            End If         
        Next
        WriteLine("Alumno : " & Xnom)
        WriteLine("Promedio : " & xprom_May)

        ReadLine()
        
    End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site