PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

Números pares e impares.

03. Elaborar un programa que permita ingresar 10 número enteros y muestre la cantidad de números pares e impares ingresados.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python



Diagrama de Flujo que permite el ingreso de diez números por teclado y muestra cuantos pares e impares hay.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos03
	
    Para Cont <-1 Hasta 10 Con Paso 1  Hacer
        Escribir "Ingrese Número ", Cont , " : "
        Leer NUM
        Si (NUM MOD 2) = 0 Entonces
            PARES = PARES + 1
        SiNo
            IMPARES = IMPARES + 1
        Fin Si		
    Fin Para
	
    Escribir "PARES INGRESADOS   : ", PARES
    Escribir "IMPARES INGRESADOS : ", IMPARES
	
FinAlgoritmo

    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos03
	
    Definir Cont, NUM, PARES, IMPARES como Entero;
	
    PARES <- 0;
    IMPARES <- 0;
	
    Para Cont <- 1 Hasta 10 Con Paso 1  Hacer
        Escribir "Ingrese Número ", Cont , " : ";
        Leer NUM;
        Si (NUM MOD 2) = 0 Entonces
            PARES <- PARES + 1;
        SiNo
            IMPARES <- IMPARES + 1;
        FinSi		
    FinPara
	
    Escribir "PARES INGRESADOS   : ", PARES;
    Escribir "IMPARES INGRESADOS : ", IMPARES;
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

            
#include<stdio.h>
int main() {
    int cont, impares, num, pares;
	
    pares = 0;
    impares = 0;
	
    for (cont=1;cont<=10;cont+=1) {
        printf("Ingrese Numero %d : ",cont);
        scanf("%i",&num);
        if ((num%2)==0) {
            pares = pares+1;
        } else {
            impares = impares+1;
        }
    }
	
    printf("\nPARES INGRESADOS : %d\n",pares);
    printf("IMPARES INGRESADOS : %d\n",impares);
	
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
	int cont, impares, num, pares;
	
	pares = 0;
	impares = 0;
	
	for (cont=1;cont<=10;cont++) {
		cout << "Ingrese Numero " << cont << " : ";
		cin >> num;
		if ((num%2)==0) {
			pares = pares+1;
		} else {
			impares = impares+1;
		}
	}
	
	cout << endl << "PARES INGRESADOS   : " << pares << endl;
	cout << "IMPARES INGRESADOS : " << impares << endl;
	
	return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    pares = 0
    impares = 0
    for cont in range(1,11):
        print("Ingrese Número ",cont," : ")
        num = int(input())
        if (num%2)==0:
            pares = pares+1
        else:
            impares = impares+1
    print("PARES INGRESADOS   : ",pares)
    print("IMPARES INGRESADOS : ",impares)
     

Java NetBeans DESCARGA CÓDIGO

            
package Repetitivos;
import java.util.Scanner;

public class repetitivo3 {
    public static void main(String[] args) {
        int num, cont, pares, impares;
        pares = 0;
        impares = 0;
        Scanner ingreso=new Scanner(System.in);                                        
        for(cont = 1; cont < 11; cont++){
            System.out.print("Ingrese número " + cont + " : ");
            num = Integer.parseInt(ingreso.next());            
            if((num - ((num / 2)*2)) == 0){
                pares++;
            }else{
                impares++;
            }
        }                  
        System.out.println("PARES INGRESADOS : " + pares);
        System.out.println("IMPARES INGRESADOS : " + impares);
    }
}
     

Java Script DESCARGA CÓDIGO

               
<html>
    <title>Ejercicio Repetitivos Para - For en JS - 04:</title>
<head>
    <script language="JavaScript" type="text/javascript">
    function mayor(){	
        var num = "0";
        var cont = "0";
        var pares = "0";
        var impares = "0";
                
        for(var cont = 1; cont < 11; cont++) {        
            var num = prompt("INGRESE NÚMERO " + cont + " :");  
            if((parseInt(num) - (parseInt(parseInt(num)/2)*2)) == 0) {
                pares = parseInt(pares) + 1;
            } else{
                impares = parseInt(impares) + 1;
            }          
        }
    document.getElementById('par').value=pares;
    document.getElementById('impar').value=impares;
    }
    </script>
</head>
<body>
    <form method="get" name="ejercicio4">
        <input type="button" value="INICAR..." onClick="mayor()" > <br> <br>
        PARES INGRESADOS   : <input name="par" id="par" type="text" > <br>    
        IMPARES INGRESADOS : <input name="impar" id="impar" type="text" > <br>        
    </form>
</body>
</html>
     

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module3
    Dim Num, Cont, Pares, Impares As Integer
    Sub Main()

        For Cont = 1 To 10
            Write("Ingrese Número " & Cont & " :")
            Num = ReadLine()
            If (Num - ((Num \ 2) * 2)) = 0 Then
                Pares = Pares + 1
            Else
                Impares = Impares + 1
            End If
        Next
        
        WriteLine("PARES INGRESADOS : " & Pares)
        WriteLine("IMPARES INGRESADOS : " & Impares)

        ReadLine()
    End Sub
End Module
     



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site