PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

10. Serie Gráfica:

Realizar un algoritmo que muestre la siguiente gráfica:

* * * * * *
* * * * *
* * * *
* * *
* * * *
* * * * *
* * * * * *


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Repetitivos10
	
    XN = 7
	
    Para F <- 1 Hasta 7 Con Paso 1  Hacer
        Serie = ""
        Si F >= 5 Entonces
            XN = XN + 2
        Fin Si
		
        Para C <- 1 Hasta XN - F Con Paso 1  Hacer
            Serie = Serie + " "	+ " * "
        Fin Para
        Escribir Serie
	Fin Para	
	
FinAlgoritmo    
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Repetitivos10
	
    Definir C, F, XN como Real;
    Definir Serie como Caracter;
	
    XN <- 7;
	
    Para F <-1 Hasta 7 Con Paso 1  Hacer
        Serie <- "";
        Si F >= 5 Entonces
            XN <- XN + 2;
        FinSi
        Para C <-1 Hasta XN - F Con Paso 1  Hacer
            Serie <- Concatenar(Serie, " * ");
        FinPara
        Escribir Serie;
	FinPara	
		
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

          
#include<stdio.h>
int main(){	
    int c, f, xn;
	
    xn = 7;
	
    for (f=1; f<=7; f+=1){				
        if (f >= 5){			
            xn = xn + 2;
        }
        for (c=1; c<=xn-f; c+=1){		
            printf(" * ");
        }
            printf("\n");
    }
		
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main(){	
    int c, f, xn;
	
    xn = 7;
	
    for (f=1; f<=7; f+=1){				
        if (f >= 5){			
            xn = xn + 2;
        }
        for (c=1; c<=xn-f; c+=1){
            cout << " * ";
        }
            cout << endl;
    }
		
	return 0;
}	
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    xn = 7
    for f in range(1,8):
        serie = ""
        if f >= 5:
            xn = xn+2
        for c in range(1,xn-f+1):
            serie = serie+" * "
        print(serie)
    

Java NetBeans DESCARGA CÓDIGO

            
package Repetitivos;
import java.util.Scanner;

public class repetitivo10 {
    public static void main(String[] args) {

        int XN=7, F, C;
        for(F = 1; F < 8; F++){
            if(F >= 5){
                XN = XN + 2;
            }            
            for(C = 1; C <= (XN - F); C++){
                System.out.print("*");                
            }
            System.out.println("");
        }
    }      
}
    

Java Script DESCARGA CÓDIGO

    
<html>
    <title>Ejercicio Repetitivos Para - For en JS - 10:</title>
<head>
<script language="JavaScript" type="text/javascript">
    function grafica(){	
        var XN = "7";
        var F = "0";
        var C = "0";
        grafica = "";
        
        for(F = 1; F < 8; F++) {    
            if(parseInt(F) >= 5) {        
                XN = parseInt(XN) + 2;
            }    
            for(C = 1; C < (parseInt(XN) - parseInt(F)); C++) {        
                grafica = grafica + "*";
            }
            grafica = grafica + "       ";
        }
        document.getElementById('serie').value=grafica;
    }
</script>
</head>
<body>
    <form method="get" name="ejercicio10">
        <input type="button" value="MOSTRAR GRÁFICA" onClick="grafica()" > <br> <br> 
        GRÁFICA: <textarea name="serie" id="serie" cols="10" rows="7"> </textarea>
    </form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module10
    Dim XN As Integer = 7
    Dim F, C As Integer

    Sub Main()

        For F = 1 To 7
            If (F >= 5) Then
                XN = XN + 2
            End If
            For C = 1 To XN - F
                Write("*")
            Next
            WriteLine()
        Next

        ReadLine()
    End Sub
End Module
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site