Tabla de Multiplicar

¡Haz clic para puntuar este proyecto!
(Votos: 10 Promedio: 3.9)

01. Elaborar un programa que permita ingresar un número entero del 1 al 12 y muestre la tabla de multiplicar de dicho número.

¿En que programa quieres ver el Código? :

    Pseudocódigo que muestre la tabla de multiplicar

    INICIO
        VARIABLES : NUM, CONT     // De tipo Entero.
        MOSTRAR -> "INGRESE UN NÚMERO DEL 1 - 12 : "
        LEER <- NUM
        PARA CONT=1 HASTA 12
            MOSTRAR -> CONT "X" NUM "=" (CONT * NUM)
        FIN PARA
    FIN
    

    Diagrama de flujo: Para codificar una tabla de multiplicar

    PSeInt - FLEXIBLE

    Algoritmo www_cisco_cursos_com
        Escribir "Ingrese un Número del 1 - 12 : "
        Leer Num
        Para Cont <-1 Hasta 12 Con Paso 1  Hacer
            Escribir Num " X " Cont " = " (Num * Cont)
        Fin Para
    FinAlgoritmo      
    

    PSeInt - ESTRICTO

    Algoritmo www_cisco_cursos_com
        Definir cont, num como Entero;
        Escribir "Ingrese un Número del 1 - 12 : ";
        Leer num;
        Para cont <-1 Hasta 12 Con Paso 1  Hacer
            Escribir num, " X ", cont, " = ", (num * cont);
        FinPara
    FinAlgoritmo
    

    Lenguaje C

            
    #include<stdio.h>
    int main() {
        int cont, num;	
        printf("Ingrese un Número del 1 - 12 : ");
        scanf("%i",&num);
        for (cont=1;cont<=12;cont+=1) {
            printf("%i X %i = %d\n",cont,num,(cont*num));
        }
        return 0;
    }
    

    C++

       
    #include<iostream>
    using namespace std;
    int main() {
        int cont;
        int num;
        cout << "Ingrese un Número del 1 - 12 : ";
        cin >> num;
        for (cont=1;cont<=12;cont++) {
            cout << cont << " X " << num << " = " << (cont*num) << endl;
        }
        return 0;
    }
    

    Python

    print("01. TABLA DE MULTIPLICAR")
    num = int(input("Ingrese un Número del 1 - 12 : "))
    for cont in range(1,13):
        print(cont," X ",num," = ",(cont*num))
    

    Java NetBeans - CONSOLA

            
    package Repetitivos;
    import java.util.Scanner;
    
    public class repetitivo1 {
        public static void main(String[] args) {
            int num,cont;
            Scanner ingreso=new Scanner(System.in);
            System.out.print("Ingrese un número del 1 - 12 : ");
            num = Integer.parseInt(ingreso.next());       
            for(cont = 1; cont < 13; cont++){
                System.out.println(cont +" X "+ num +" = "+(cont * num));
            }                  
        }         
    }
    

    Java Script

              
    <html>
        <title>Ejercicio Repetitivos Para - For en JS - 01:</title>
    <head>
    <script language="JavaScript" type="text/javascript">
        function tabla(){	
            var xnum = ejercicio1.num.value;            
            var contenido = "";
            for(var cont = 1; cont < 13; cont++) {        
                contenido = contenido + cont + " x " + xnum + " = " + (parseInt(cont) * parseInt(xnum)) + "      ";         
            }
            document.getElementById('result').value=contenido;
        }
    </script>
    </head>
    <body>
        <form method="get" name="ejercicio1">
            INGRESE NÚMERO DEL 1 - 12: <input name="num" type="text" > <br>    
            <input type="button" value="OPERAR" onClick="tabla()" > <br>
            RESULTADO : <textarea name="result" id="result" cols="13" rows="12"></textarea>
        </form>
    </body>
    </html>
    

    Visual Basic .Net - Consola

      
    Imports System.Console
    Module Module1
        Dim Num, Cont As Integer
        Sub Main()
            Write("Ingrese un Número del 1 - 12 : ")
            Num = ReadLine()
            For Cont = 1 To 12
                WriteLine(Cont & " x " & Num & " = " & (Cont * Num))
            Next
            ReadLine()
        End Sub
    End Module
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir