PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

DAR REGALO A LOS NIÑOS SEGÚN SU EDAD Y SEXO.

17. Se tienen 2 niños a quienes se les pide sus datos personales como DNI, Fecha de nacimiento (considerar día, mes y año) y género. Si los niños tienen 8 años o más se les dará Tablet. Si los niños tienen 6 años se les dará carrito o muñeca dependiendo del género.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo rango
    
    // ACTUALIZA LOS DATOS DE FECHA ACTUAL - 21/10/2021
    diax = 21
    mesx = 10
    aniox = 2021
	
    Para x = 1 Hasta 2 Con Paso 1 Hacer
        Escribir Sin Saltar "DNI : "
        Leer dni
        Escribir Sin Saltar "DÍA DE NACIMIENTO: "
        Leer dia
        Escribir Sin Saltar "MES DE NACIMIENTO: "
        Leer mes
        Escribir Sin Saltar "AÑO DE NACIMIENTO: "
        Leer anio
        Escribir Sin Saltar "GÉNERO (H/M): "
        Leer genero
		
        Escribir "FECHA ACTUAL : ",diax,"/",mesx,"/",aniox
		
        edad = aniox - anio
				
        Si (mes > mesx) Entonces
            edad = edad - 1
        SiNo
            Si (mes == mesx Y dia > diax) Entonces
                edad = edad - 1
            FinSi
        FinSi
        Escribir Sin Saltar "EDAD : ", edad
        Escribir " "
		
        Si (edad >= 8) Entonces
            Escribir "RECIBE TABLET"
        SiNo
            Si (edad == 6) Entonces
                Si (genero == "H") Entonces
                    Escribir "RECIBE CARRITO"
                SiNo
                    Escribir "RECIBE MUÑECA"
                FinSi				
            FinSi
        FinSi
        Escribir " "
		
    FinPara
FinAlgoritmo    
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

Perfiles : UTP-Peru │ ESPE

    
Algoritmo rango
	
    Definir x, edad, dia, mes, anio, diax, mesx, aniox como entero;
    Definir dni, genero como Caracter;
	
    // ACTUALIZA LOS DATOS DE FECHA ACTUAL - 21/10/2021
    diax <- 21;	
    mesx <- 10;	
    aniox <- 2021;
    edad <- 0;
	
    Para x <- 1 Hasta 2 Con Paso 1 Hacer
        Escribir Sin Saltar "DNI : ";
        Leer dni; 				
        Escribir Sin Saltar "DÍA DE NACIMIENTO: ";
        Leer dia;
        Escribir Sin Saltar "MES DE NACIMIENTO: ";
        Leer mes;
        Escribir Sin Saltar "AÑO DE NACIMIENTO: ";
        Leer anio;		
        Escribir Sin Saltar "GÉNERO (H/M): ";
        Leer genero;
		
        Escribir "FECHA ACTUAL : ",diax,"/",mesx,"/",aniox;
		
        edad <- aniox - anio;
				
        Si (mes > mesx) Entonces
            edad <- edad - 1;
        SiNo
            Si (mes == mesx Y dia > diax) Entonces
                edad <- edad - 1;						
            FinSi
        FinSi
        Escribir Sin Saltar "EDAD : ", edad;
        Escribir " ";		
		
        Si (edad >= 8) Entonces
            Escribir "RECIBE TABLET";
        SiNo
            Si (edad == 6) Entonces
                Si (genero == "H") Entonces
                    Escribir "RECIBE CARRITO";
                SiNo
                    Escribir "RECIBE MUÑECA";
                FinSi
            FinSi
        FinSi
        Escribir " ";
		
    FinPara
	
FinAlgoritmo
    


Python DESCARGA CÓDIGO


diax = 21
mesx = 10
aniox = 2021

for x in range(1,3):
    dni = input("DNI : ")
    dia = int(input("DIA DE NACIMIENTO : "))
    mes = int(input("MES DE NACIMIENTO : "))
    anio = int(input("AÑO DE NACIMIENTO : "))
    genero = input("GÉNERO H/M : ")

    print("FECHA ACTUAL : ",diax,"/",mesx,"/",aniox)

    edad = aniox - anio

    if mes > mesx:
        edad = edad - 1
    else:
        if mes == mesx and dia > diax:
            edad = edad - 1

    print("\nEDAD : ",edad)

    if edad >= 8:
        print("RECIBE TABLET\n")
    elif edad == 6:
        if genero == "H" or genero == "h":
            print("REGALO CARRITO\n")
        else:
            print("REGALO MUÑECA\n")







Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site