Monto a pagar del cliente, según las condiciones

¡Haz clic para puntuar este proyecto!
(Votos: 7 Promedio: 4.3)

En una tienda dónde se venden teclados, si se compran más de 8 el costo por cada una es de 10 soles; entre 4 y 8 es de 11 soles cada una, si la compra es menor de 4 el costo es de 15 soles cada una.

Escriba el algoritmo para saber cuánto pagará un cliente según el número de teclados que compra. Mostrar el número de teclados a comprar y el total a pagar.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

     
    Algoritmo Seleccion06
        Escribir "Ingrese la Cantidad a Comprar : "
        Leer Cantidad
        Segun Cantidad Hacer
            1, 2, 3: Costo = 15
            4, 5, 6, 7, 8: Costo = 11
            De Otro Modo: Costo = 10
        Fin Segun
        Escribir "Costo por cada Teclado : ", Costo
        Escribir "Total a Pagar : ", Costo * Cantidad
    FinAlgoritmo
    

    Lenguaje C

      
    #include<stdio.h>
    int main(){	
    	int cantidad, costo;
    	printf("Ingrese la cantidad a Comprar : ");	
    	scanf("%i",&cantidad);
    	switch(cantidad){
    		case 1: case 2: case 3:			
    			costo = 15;			
    			break;
    		case 4: case 5: case 6: case 7: case 8:						
    			costo = 11;
    			break;
    		default:
    			costo = 10;
    	}
    	printf("Costo por cada Teclado : %i\n", costo);	
    	printf("Total a Pagar : %2.f\n", (float)(costo*cantidad));	
    	return 0;
    }
    

    C++

     
    #include<iostream>
    using namespace std;
    int main(){	
    	int cantidad, costo;
    	cout << "Ingrese la cantidad a Comprar : ";
    	cin >> cantidad;
    	switch(cantidad){
    		case 1: case 2: case 3:			
    			costo = 15;			
    			break;
    		case 4: case 5: case 6: case 7: case 8:						
    			costo = 11;
    			break;
    		default:
    			costo = 10;
    	}
    	cout << endl;	
    	cout << "Costo por cada Teclado : " << costo << endl;	
    	cout << "Total a Pagar : " << (costo*cantidad) << endl;	
    	return 0;
    }
    

    Python

     
    print("06. COSTOS DEPENDEN DE LA CANTIDAD DE COMPRA.")
    cantidad = int(input("Ingrese la Cantidad a Comprar : "))
    if cantidad <= 3:
        costo = 15
    elif cantidad >= 4 and cantidad<=8:
        costo = 11
    else:
        costo = 10
    print("Costo por cada Teclado : ",costo)
    print("Total a Pagar : ",costo*cantidad)
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir