Hacer un programa que muestre un menú de opciones

¡Haz clic para puntuar este proyecto!
(Votos: 8 Promedio: 4.4)

03. Programar el siguiente menú de opciones:

A. El valor del área de un triángulo, dada la base y la altura.
B. El valor de la base de un triángulo, dada la altura y el área.
C. El valor de la altura de un triángulo, dada la base y el área.
Dependiendo de la opción A, B ó C, se ejecutara el opción correspondiente.

¿En que programa quieres ver el Código? :

    Diagrama de flujo

    PSeInt - FLEXIBLE

    Algoritmo Seleccion03
        Escribir "MENU DE OPCIONES"
        Escribir "================"
        Escribir "A. El valor del área de un Triángulo, dada la base y la altura."
        Escribir "B. El valor de la Base de un Triángulo, dada la altura y el área."
        Escribir "C. El valor de la altura de un Triángulo, dada la base y la altura."
        Escribir "Selecciona una Opión : "
        Leer OPC
        Segun OPC Hacer
            "A":
                Escribir "Ingrese Base : "
                Leer Base
                Escribir "Ingrese Altura :"
                Leer Altura
                Area = (Base * Altura)/2
                Escribir "El área es : ", Area
            "B":
                Escribir "Ingrese Altura : "
                Leer Altura
                Escribir "Ingrese Área :"
                Leer Area
                Base = (Area * 2)/Altura
                Escribir "La Base es: ", Base
            "C":
                Escribir "Ingrese Base : "
                Leer Base
                Escribir "Ingrese Área :"
                Leer Area
                Altura = (Area * 2) / Base
                Escribir "La altura es : ", Altura
            De Otro Modo:
                Escribir "OPCIÓN INCORRECTA"
        Fin Segun
    FinAlgoritmo
    

    PSeInt - ESTRICTO

     
    Algoritmo Seleccion03
        Definir OPC como Numero;
        Definir Area, Base, Altura como Real;
        Escribir "MENU DE OPCIONES";
        Escribir "================";
        Escribir "1. El valor del área de un Triángulo, dada la base y la altura.";
        Escribir "2. El valor de la Base de un Triángulo, dada la altura y el área.";
        Escribir "3. El valor de la altura de un Triángulo, dada la base y la altura.";
        Escribir "Selecciona una Opión : ";
        Leer OPC;
        Segun OPC Hacer
            1:
                Escribir "Ingrese Base : ";
                Leer Base;
                Escribir "Ingrese Altura :";
                Leer Altura;
                Area <- ((Base * Altura)/2) * (-1);
                Escribir "El área es : ", Area;
            2:
                Escribir "Ingrese Altura : ";
                Leer Altura;
                Escribir "Ingrese Área :";
                Leer Area;
                Base <- ((Area * 2)/Altura) * (-1);
                Escribir "La Base es: ", Base;
            3:
                Escribir "Ingrese Base : ";
                Leer Base;
                Escribir "Ingrese Área :";
                Leer Area;
                Altura <- ((Area * 2) / Base) * (-1);
                Escribir "La altura es : ", Altura;
            De Otro Modo:
                Escribir "OPCIÓN INCORRECTA";
        FinSegun;
    FinAlgoritmo
    

    Lenguaje C

      
    #include<stdio.h>
    int main(){
    	float altura, area, base;
    	int opc;
    	printf("MENU DE OPCIONES\n");
    	printf("================\n");
    	printf("1. Area de un triangulo.\n");
    	printf("2. Base de un triangulo.\n");
    	printf("3. Altura de un triangulo.\n");
    	printf("Opcion : ");
    	scanf("%i",&opc);
    	switch(opc){
    	case 1:
    		printf("Ingrese Base : ");
    		scanf("%f",&base);
    		printf("Ingrese Altura : ");
    		scanf("%f",&altura);
    		area = ((base * altura)/2);
    		printf("\nAREA : %.2f\n", area);
    		break;
    	case 2:
    		printf("Ingrese Altura : ");
    		scanf("%f",&altura);
    		printf("Ingrese Area : ");
    		scanf("%f",&area);
    		base = ((area * 2)/altura);
    		printf("\nBASE : %.2f\n", base);
    		break;
    	case 3:
    		printf("Ingrese Base : ");
    		scanf("%f",&base);
    		printf("Ingrese Area : ");
    		scanf("%f",&area);
    		altura = ((area * 2)/base);
    		printf("\nALTURA : %.2f\n", altura);
    		break;
    	default:		
    		printf("\nOPCIÓN INCORRECTA\n");			
    	}		
    	return 0;
    }	
    

    C++

     
    #include<iostream>
    using namespace std;
    int main(){
    	float altura, area, base;
    	int opc;
    	cout << "MENU DE OPCIONES\n";
    	cout << "================\n";
    	cout << "1. Area de un triangulo.\n";
    	cout << "2. Base de un triangulo.\n";
    	cout << "3. Altura de un triangulo.\n";
    	cout << "Opcion : ";
    	cin  >> opc;
    		
    	switch(opc){
    	case 1:
    		cout << "Ingrese Base : ";
    		cin  >> base;
    		cout << "Ingrese Altura : ";
    		cin  >> altura;
    		area = ((base * altura)/2);
    		cout << "\nAREA : " << area;
    		break;
    	case 2:
    		cout << "Ingrese Altura : ";
    		cin  >> altura;
    		cout << "Ingrese Area : ";
    		cin  >> area;
    		base = ((area * 2)/altura);
    		cout << "\nBASE : " << base;
    		break;
    	case 3:
    		cout << "Ingrese Base : ";
    		cin  >> base;
    		cout << "Ingrese Area : ";
    		cin  >> area;
    		altura = ((area * 2)/base);
    		cout << "\nALTURA : " << altura;
    		break;
    	default:		
    		cout << "\nOPCIÓN INCORRECTA\n";
    	}	
    	return 0;
    }	
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir