Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

Mostrar número en letras.

08. Ingresar un número entero de dos cifras y mostrar su valor en letras.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++





Diagrama de flujo(DFD) - Ingresa un número y muestralo en letras:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

      
Algoritmo Seleccion08
     Escribir "Ingrese Número de Hasta 2 Cifras : "
     Leer Num
     Si Num > 0 Y Num < 100 Entonces
          Si Num > 10 Y Num < 16 Entonces
               Segun Num Hacer
                    11: Escribir "ONCE"
                    12: Escribir "DOCE"
                    13: Escribir "TRECE"
                    14: Escribir "CATORCE"
                    15: Escribir "QUINCE"
               Fin Segun
          SiNo
               DEC = (Num - (Num MOD 10))/10
               UNI = Num MOD 10
               Segun DEC Hacer
                    1: DECENA = "DIEZ"
                    2: DECENA = "VEINTE"
                    3: DECENA = "TREINTA"
                    4: DECENA = "CUARENTA"
                    5: DECENA = "CINCUENTA"
                    6: DECENA = "SESENTA"
                    7: DECENA = "SETENTA"
                    8: DECENA = "OCHENTA"
                    9: DECENA = "NOVENTA"
               Fin Segun
               Si UNI <> 0 Entonces
                    Segun UNI Hacer
                         1: UNIDAD = "UNO"
                         2: UNIDAD = "DOS"
                         3: UNIDAD = "TRES"
                         4: UNIDAD = "CUATRO"
                         5: UNIDAD = "CINCO"
                         6: UNIDAD = "SEIS"
                         7: UNIDAD = "SIETE"
                         8: UNIDAD = "OCHO"
                         9: UNIDAD = "NUEVE"
                    Fin Segun
                    Si DEC = 1 Entonces
                         DECENA = "DIECI"
                    FinSi
                    Si DEC = 2 Entonces
                         DECENA = "VENTI"
                    FinSi
                    Si DEC > 2 Y DEC < 10 Entonces
                         Escribir DECENA "Y" UNIDAD
                    SiNo
                         Escribir DECENA "" UNIDAD
                    FinSi
               SiNo
                    Escribir DECENA
               Fin Si
          Fin Si
     SiNo
          Escribir "NÚMERO INCORRECTO !!!..."
     Fin Si
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

      
Algoritmo Seleccion08
     Definir Num, DEC, UNI como Entero;
     Definir DECENA, UNIDAD como Caracter;
     Escribir "Ingrese Número de Hasta 2 Cifras : ";
     Leer Num;
     Si Num > 0 Y Num < 100 Entonces
          Si Num > 10 Y Num < 16 Entonces
               Segun Num Hacer
                    11: Escribir "ONCE";
                    12: Escribir "DOCE";
                    13: Escribir "TRECE";
                    14: Escribir "CATORCE";
                    15: Escribir "QUINCE";
               FinSegun
          SiNo
               DEC <- (Num - (Num MOD 10))/10;
               UNI <- Num MOD 10;
               Segun DEC Hacer
                    1: DECENA <- "DIEZ";
                    2: DECENA <- "VEINTE";
                    3: DECENA <- "TREINTA";
                    4: DECENA <- "CUARENTA";
                    5: DECENA <- "CINCUENTA";
                    6: DECENA <- "SESENTA";
                    7: DECENA <- "SETENTA";
                    8: DECENA <- "OCHENTA";
                    9: DECENA <- "NOVENTA";
               FinSegun
               Si UNI <> 0 Entonces
                    Segun UNI Hacer
                         1: UNIDAD <- "UNO";
                         2: UNIDAD <- "DOS";
                         3: UNIDAD <- "TRES";
                         4: UNIDAD <- "CUATRO";
                         5: UNIDAD <- "CINCO";
                         6: UNIDAD <- "SEIS";
                         7: UNIDAD <- "SIETE";
                         8: UNIDAD <- "OCHO";
                         9: UNIDAD <- "NUEVE";
                    FinSegun
                    Si DEC = 1 Entonces
                         DECENA <- "DIECI";
                    FinSi
                    Si DEC = 2 Entonces
                         DECENA <- "VENTI";
                    FinSi
                    Si DEC > 2 Y DEC < 10 Entonces
                         Escribir DECENA, "Y", UNIDAD;
                    SiNo
                         Escribir DECENA, "", UNIDAD;
                    FinSi
               SiNo
                    Escribir DECENA;
               FinSi
          FinSi
     SiNo
          Escribir "NÚMERO INCORRECTO !!!...";
     FinSi
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

      
#include<stdio.h>
int main(){	
	
	int num, uni, dec, xuni, xdec;
	char unidad[10][9]={"UNO","DOS","TRES","CUATRO","CINCO","SEIS","SIETE","OCHO","NUEVE"};
	char decena[12][10]={"DIEZ","VEINTE","TREINTA","CUARENTA","CINCUENTA","SESENTA","SETENTA","OCHENTA","NOVENTA","DIECI","VENTI",""};
		
	printf("Ingrese numero de hasta dos cifras : ");	
	scanf("%i",&num);
	
	if(num > 0 && num < 100){
		if(num > 10 && num < 16){
			switch(num){
				case 11:printf("ONCE \n"); break;
				case 12:printf("DOCE \n"); break;
				case 13:printf("TRECE \n"); break;
				case 14:printf("CATORCE \n"); break;
				case 15:printf("QUINCE \n"); break;
			}
		}else{
			dec=(num-(num%10))/10;
			uni=(num%10);
						
			switch(dec){
				case 1:xdec=0; break;
				case 2:xdec=1; break;
				case 3:xdec=2; break;
				case 4:xdec=3; break;
				case 5:xdec=4; break;
				case 6:xdec=5; break;
				case 7:xdec=6; break;
				case 8:xdec=7; break;
				case 9:xdec=8; break;
				default: xdec = 11;
			}
			if(uni!=0){
				switch(uni){
					case 1: xuni=0;break;
					case 2: xuni=1;break;
					case 3: xuni=2;break;
					case 4: xuni=3;break;
					case 5: xuni=4;break;
					case 6: xuni=5;break;
					case 7: xuni=6;break;
					case 8: xuni=7;break;
					case 9: xuni=8;break;					
				}
				if (dec==1){
					xdec=9;
				}
				if (dec==2){
					xdec=10;
				}
				if (dec > 2 && dec < 10){
					printf("\n%sY%s\n", decena[xdec],unidad[xuni]);
				}else{
					printf("\n%s%s\n", decena[xdec],unidad[xuni]);
				}		
			}else{
				printf("\n%s\n", decena[xdec]);
			}			
		}		
	}else{
		printf("NUMERO INCORRECTO !!!... \n");
	}
			
	return 0;
}	
    

C++ DESCARGA CÓDIGO

      
#include<iostream>
using namespace std;
int main(){	
	
	int dec, num, uni;
	string decena, unidad;
		
	cout << "Ingrese numero de hasta dos cifras : ";
	cin >> num;	
		
	if(num>0 && num<100){
		if(num > 10 && num < 16){
			switch(num){
				case 11:cout << "ONCE"; break;
				case 12:cout << "DOCE"; break;
				case 13:cout << "TRECE"; break;
				case 14:cout << "CATORCE"; break;
				case 15:cout << "QUINCE"; break;
			}
		}else{
			dec=(num-(num%10))/10;
			uni=(num%10);
						
			switch(dec){
				case 1:decena = "DIEZ"; break;
				case 2:decena = "VEINTE"; break;
				case 3:decena = "TREINTA"; break;
				case 4:decena = "CUARENTA"; break;
				case 5:decena = "CINCUENTA"; break;
				case 6:decena = "SESENTA"; break;
				case 7:decena = "SETENTA"; break;
				case 8:decena = "OCHENTA"; break;
				case 9:decena = "NOVENTA"; break;				
			}
			if(uni!=0){
				switch(uni){
					case 1: unidad = "UNO"; break;
					case 2: unidad = "DOS"; break;
					case 3: unidad = "TRES"; break;
					case 4: unidad = "CUATRO"; break;
					case 5: unidad = "CINCO"; break;
					case 6: unidad = "SEIS"; break;
					case 7: unidad = "SIETE"; break;
					case 8: unidad = "OCHO"; break;
					case 9: unidad = "NUEVE"; break;			
				}
				if (dec==1){
					decena="DIECI";
				}
				if (dec==2){
					decena="VENTI";
				}
				if (dec > 2 && dec < 10){
					cout << endl << decena << "Y" << unidad << endl;
				}else{
					cout << endl << decena << unidad << endl;
				}		
			}else{
				cout << endl << decena << endl;
			}			
		}		
	}else{
		printf("NUMERO INCORRECTO !!!... \n");
	}
			
	return 0;
}	
    

Python DESCARGA CÓDIGO

      
if __name__ == '__main__':
     print("Ingrese Número de Hasta 2 Cifras : ")
     num = int(input())
     if num > 0 and num < 100:
          if num > 10 and num < 16:
               if num==11:
                    print("ONCE")
               elif num==12:
                    print("DOCE")
               elif num==13:
                    print("TRECE")
               elif num==14:
                    print("CATORCE")
               elif num==15:
                    print("QUINCE")
          else:
               dec = (num-(num%10))/10
               uni = num%10
               if dec==1:
                    decena = "DIEZ"
               elif dec==2:
                    decena = "VEINTE"
               elif dec==3:
                    decena = "TREINTA"
               elif dec==4:
                    decena = "CUARENTA"
               elif dec==5:
                    decena = "CINCUENTA"
               elif dec==6:
                    decena = "SESENTA"
               elif dec==7:
                    decena = "SETENTA"
               elif dec==8:
                    decena = "OCHENTA"
               elif dec==9:
                    decena = "NOVENTA"
               if uni!=0:
                    if uni==1:
                         unidad = "UNO"
                    elif uni==2:
                         unidad = "DOS"
                    elif uni==3:
                         unidad = "TRES"
                    elif uni==4:
                         unidad = "CUATRO"
                    elif uni==5:
                         unidad = "CINCO"
                    elif uni==6:
                         unidad = "SEIS"
                    elif uni==7:
                         unidad = "SIETE"
                    elif uni==8:
                         unidad = "OCHO"
                    elif uni==9:
                         unidad = "NUEVE"
                    if dec==1:
                         decena = "DIECI"
                    if dec==2:
                         decena = "VENTI"
                    if dec > 2 and dec < 10:
                         print(decena,"Y",unidad)
                    else:
                         print(decena,"",unidad)
               else:
                         print(decena)
     else:
          print("NÚMERO INCORRECTO !!!...")
    

Java NetBeans DESCARGA CÓDIGO

      
package Seleccion;
import java.util.Scanner;
public class Seleccion8 {
    public static void main(String[] args) {
        int num, dec, uni;
            String decena="", unidad="";
        Scanner ingreso=new Scanner(System.in);
        System.out.print("Ingrese Número de hasta 2 cifras : ");
        num = Integer.parseInt(ingreso.next());
        if(num > 0 && num < 100){
            if(num > 10 && num < 16){
                switch(num){
                    case 11: System.out.println("ONCE"); break;
                    case 12: System.out.println("DOCE"); break;
                    case 13: System.out.println("TRECE"); break;
                    case 14: System.out.println("CATORCE"); break;
                    case 15: System.out.println("QUINCE"); break;
                }
            }else{
                dec = num / 10;
                uni = num - (dec * 10);
                switch(dec){
                    case 1: decena = "DIEZ"; break;
                    case 2: decena = "VEINTE"; break;
                    case 3: decena = "TREINTA"; break;
                    case 4: decena = "CUARENTA";break;
                    case 5: decena = "CINCUENTA"; break;
                    case 6: decena = "SESENTA"; break;
                    case 7: decena = "SETENTA"; break;
                    case 8: decena = "OCHENTA"; break;
                    case 9: decena = "NOVENTA"; break;
                }
                if(uni != 0){
                    switch(uni){
                        case 1: unidad = "UNO"; break;
                        case 2: unidad = "DOS"; break;
                        case 3: unidad = "TRES"; break;
                        case 4: unidad = "CUATRO"; break;
                        case 5: unidad = "CINCO"; break;
                        case 6: unidad = "SEIS"; break;
                        case 7: unidad = "SIETE"; break;
                        case 8: unidad = "OCHO"; break;
                        case 9: unidad = "NUEVE"; break;
                    }
                        if(dec == 1){
                            decena = "DIECI";
                        }
                        if(dec == 2){
                            decena = "VENTI";
                        }
                        if(dec > 2 && dec < 10){
                            System.out.println(decena + "Y" + unidad);
                        }else{
                            System.out.println(decena + "" + unidad);
                        }
                }else{
                    System.out.println(decena);
                }
            }
        }else{
            System.out.println("NÚMERO INCORRECTO");
        }
    }
}
    

Java Script DESCARGA CÓDIGO

      
<html>
<head>
<title>Ejercicio Selección en JS - 08:</title>
<script language="JavaScript" type="text/javascript">
    function fletras(){
        var xnum = ejercicio8.num.value;
        var decena = "";
        var unidad = "";
        if(parseInt(xnum) > 0 && parseInt(xnum) < 100 ){
            if(parseInt(xnum) > 10 && parseInt(xnum) < 16 ){
                switch(parseInt(xnum)){
                    case 11: document.getElementById('nivel').value="ONCE"; break;
                    case 12: document.getElementById('nivel').value="DOCE"; break;
                    case 13: document.getElementById('nivel').value="TRECE"; break;
                    case 14: document.getElementById('nivel').value="CATORCE"; break;
                    case 15: document.getElementById('nivel').value="QUINCE"; break;
                }
            }else{
                var dec = parseInt(xnum) / 10;
                var uni = parseInt(xnum) - (parseInt(dec) * 10);
                switch(parseInt(dec)){
                    case 1:decena="DIEZ"; document.getElementById('nivel').value="DIEZ"; break;
                    case 2:decena="VEINTE"; document.getElementById('nivel').value="VEINTE"; break;
                    case 3:decena="TREINTA"; document.getElementById('nivel').value="TREINTA"; break;
                    case 4:decena="CUARENTA"; document.getElementById('nivel').value="CUARENTA"; break;
                    case 5:decena="CINCUENTA"; document.getElementById('nivel').value="CINCUENTA"; break;
                    case 6:decena="SESENTA"; document.getElementById('nivel').value="SESENTA"; break;
                    case 7:decena="SETENTA"; document.getElementById('nivel').value="SETENTA"; break;
                    case 8:decena="OCHENTA"; document.getElementById('nivel').value="OCHENTA"; break;
                    case 9:decena="NOVENTA"; document.getElementById('nivel').value="NOVENTA"; break;
                }
                if(parseInt(uni) != 0){
                    switch(parseInt(uni)){
                        case 1: unidad="UNO"; document.getElementById('nivel').value="UNO"; break;
                        case 2: unidad="DOS"; document.getElementById('nivel').value="DOS"; break;
                        case 3: unidad="TRES"; document.getElementById('nivel').value="TRES"; break;
                        case 4: unidad="CUATRO"; document.getElementById('nivel').value="CUATRO"; break;
                        case 5: unidad="CINCO"; document.getElementById('nivel').value="CINCO"; break;
                        case 6: unidad="SEIS"; document.getElementById('nivel').value="SEIS"; break;
                        case 7: unidad="SIETE"; document.getElementById('nivel').value="SIETE"; break;
                        case 8: unidad="OCHO"; document.getElementById('nivel').value="OCHO"; break;
                        case 9: unidad="NUEVE"; document.getElementById('nivel').value="NUEVE"; break;
                }
                if(parseInt(dec) == 1){
                    decena = "DECI";
                }
                if(parseInt(dec) == 2){
                    decena = "VENTI";
                }
                if(parseInt(dec) > 2 && parseInt(dec) < 10){
                    document.getElementById('nivel').value=decena + " Y " + unidad;
                }else{
                    document.getElementById('nivel').value=decena + unidad;
                }
            }else{
                document.getElementById('nivel').value=decena;
            }
        }
    }else{
        document.getElementById('nivel').value="NÚMERO INCORRECTO";
    }
}
</script>
</head>
<body>
    <form method="get" name="ejercicio8">
        INGRESE NÚMERO 2 CIFRAS : <input name="num" type="text" > <br>
        <input type="button" value="MOSTRAR" onClick="fletras()" > <br>
        VALOR EN LETRAS : <input name="nivel" id="nivel" type="text">
    </form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module8
    Dim Num, Dec, Uni
    Dim Decena, Unidad As String
    Sub Main()
        Write("Ingrese Número de 2 Cifras : ")
        Num = ReadLine()
        If ((Num > 0) And (Num < 100)) Then
            If ((Num > 10) And (Num < 16)) Then
                Select Case Num
                    Case 11 : Write("ONCE")
                    Case 12 : Write("DOCE")
                    Case 13 : Write("TRECE")
                    Case 14 : Write("CATORCE")
                    Case 15 : Write("QUINCE")
                End Select
            Else
                Dec = Num \ 10
                Uni = Num - (Dec * 10)
                Select Case Dec
                    Case 1 : Decena = "DIEZ"
                    Case 2 : Decena = "VEINTE"
                    Case 3 : Decena = "TREINTA"
                    Case 4 : Decena = "CUARENTA"
                    Case 5 : Decena = "CINCUENTA"
                    Case 6 : Decena = "SESENTA"
                    Case 7 : Decena = "SETENTA"
                    Case 8 : Decena = "OCHENTA"
                    Case 9 : Decena = "NOVENTA"
                End Select
                If (Uni <> 0) Then
                    Select Case Uni
                        Case 1 : Unidad = "UNO"
                        Case 2 : Unidad = "DOS"
                        Case 3 : Unidad = "TRES"
                        Case 4 : Unidad = "CUATRO"
                        Case 5 : Unidad = "CINCO"
                        Case 6 : Unidad = "SEIS"
                        Case 7 : Unidad = "SIETE"
                        Case 8 : Unidad = "OCHO"
                        Case 9 : Unidad = "NUEVE"
                    End Select
                    If (Dec = 1) Then
                        Decena = "DIECI"
                    End If
                    If (Dec = 2) Then
                        Decena = "VENTI"
                    End If
                    If ((Dec > 2) And (Dec < 10)) Then
                        Write(Decena & " Y " & Unidad)
                    Else
                        Write(Decena & Unidad)
                    End If
                Else
                    Write(Decena)
                End If
            End If
        Else
            Write("NÚMERO INCORRECTO")
        End If
        ReadLine()
    End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site