Mostrar vocal o consonante

¡Haz clic para puntuar este proyecto!
(Votos: 4 Promedio: 4.8)

Se pide ingresar una letra del alfabeto y mostrar si dicha letra es vocal o consonante

¿En que programa quieres ver el Código? :

    Diagrama de flujo : Que muestra si es vocal o consonante

    PSeInt - FLEXIBLE

      
    Algoritmo Seleccion04
        Escribir "Ingrese una Letra :"
        Leer Letra
        Segun Letra Hacer
            "A": Escribir "VOCAL"
            "E": Escribir "VOCAL"
            "I": Escribir "VOCAL"
            "O": Escribir "VOCAL"
            "U": Escribir "VOCAL"
            De Otro Modo:
               Escribir "CONSONANTE"
        Fin Segun
    FinAlgoritmo
    

    Lenguaje C

    #include <stdio.h>
    int main(){	
    	char l;
    	printf("Ingrese una letra : ");	
    	scanf("%c",&l);
    	switch(l){
    	case 'a':
    		printf("\nVOCAL"); break;		
    	case 'e':
    		printf("\nVOCAL"); break;		
    	case 'i':
    		printf("\nVOCAL"); break;		
    	case 'o':
    		printf("\nVOCAL"); break;		
    	case 'u':
    		printf("\nVOCAL"); break;			
    	default:		
    		printf("\nCONSTANTE");			
    	}		
    	return 0;
    }	
    

    C++

      
    #include<iostream>
    using namespace std;
    int main(){
    	char l;
    	cout << "Ingrese una letra : ";	
    	cin >> l;
    	switch(l){
    	case 'a':
    		cout << "\nVOCAL"; break;		
    	case 'e':
    		cout << "\nVOCAL"; break;		
    	case 'i':
    		cout << "\nVOCAL"; break;		
    	case 'o':
    		cout << "\nVOCAL"; break;		
    	case 'u':
    		cout << "\nVOCAL"; break;		
    	default:		
    		cout << "\nCONSTANTE";
    	}
    	return 0;
    }	
    

    Python 

     
    print("04. MOSTRAR SI ES VOCAL O CONSONANTE.")
    l = input("Ingrese una Letra : ")
    if l.lower()=="A" or l.upper()=="E" or l.upper()=="I" or l.upper()=="O" or l.upper()=="U":
        print("VOCAL")
    else:
        print("CONSONANTE")
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir