Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

Mostrar vocal o consonante

04. Se pide ingresar una letra del alfabeto y mostrar si dicha letra es vocal o consonante.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++





Diagrama de flujo(DFD) que muestra si es vocal o consonante:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

      
Algoritmo Seleccion04
    Escribir "Ingrese una Letra :"
    Leer Letra
    Segun Letra Hacer
        "A": Escribir "VOCAL"
        "E": Escribir "VOCAL"
        "I": Escribir "VOCAL"
        "O": Escribir "VOCAL"
        "U": Escribir "VOCAL"
        De Otro Modo:
           Escribir "CONSONANTE"
    Fin Segun
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

      
Algoritmo Seleccion04
    Definir L como Entero;
    Escribir "Ingrese una Letra : ";
	Escribir "1. A";
	Escribir "2. E";
	Escribir "3. I";
	Escribir "4. O";
	Escribir "5. U";
    Leer L;
    //SEGUN SÓLO ACEPTA VALORES NUMÉRICOS
	Segun (L) Hacer
		1,2,3,4,5:Escribir "VOCAL";		
	De Otro Modo:
		Escribir "CONSONANTE";	
	FinSegun
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

    
#include <stdio.h>
int main(){	
	char l;
	
	printf("Ingrese una letra : ");	
	scanf("%c",&l);
		
	switch(l){
	case 'a':
		printf("\nVOCAL"); break;		
	case 'e':
		printf("\nVOCAL"); break;		
	case 'i':
		printf("\nVOCAL"); break;		
	case 'o':
		printf("\nVOCAL"); break;		
	case 'u':
		printf("\nVOCAL"); break;			
	default:		
		printf("\nCONSTANTE");			
	}		
	return 0;
}	
    

C++ DESCARGA CÓDIGO

      
#include<iostream>
using namespace std;
int main(){
	char l;
	
	cout << "Ingrese una letra : ";	
	cin >> l;
		
	switch(l){
	case 'a':
		cout << "\nVOCAL"; break;		
	case 'e':
		cout << "\nVOCAL"; break;		
	case 'i':
		cout << "\nVOCAL"; break;		
	case 'o':
		cout << "\nVOCAL"; break;		
	case 'u':
		cout << "\nVOCAL"; break;		
	default:		
		cout << "\nCONSTANTE";
	}
	return 0;
}	
    

Python DESCARGA CÓDIGO

      
if __name__ == '__main__':
    print("Ingrese una Letra :")
    l = input()
    if l=="A" or l=="E" or l=="I" or l=="O" or l=="U":
        print("VOCAL")
    else:
        print("CONSONANTE")
    

Java NetBeans DESCARGA CÓDIGO

      
package Seleccion;
import java.util.Scanner;
public class Seleccion4 {
    public static void main(String[] args) {
        String letra;
        Scanner ingreso=new Scanner(System.in);
        System.out.print("Ingrese una letra : ");
        letra = ingreso.next();
        switch(letra){
            case "A": System.out.println("VOCAL"); break;
            case "E": System.out.println("VOCAL"); break;
            case "I": System.out.println("VOCAL"); break;
            case "O": System.out.println("VOCAL"); break;
            case "U": System.out.println("VOCAL"); break;
            default : System.out.println("CONSONANTE");
        }
    }
}
    

Java Script DESCARGA CÓDIGO

      
<html>
<head>
<title>Ejercicio Selección en JS - 04:</title>
<script language="JavaScript" type="text/javascript">
    function er(){
        var xnum = ejercicio4.num.value;
        switch(xnum) {
            case "A": document.getElementById('result').value="VOCAL"; break;
            case "E": document.getElementById('result').value="VOCAL"; break;
            case "I": document.getElementById('result').value="VOCAL"; break;
            case "O": document.getElementById('result').value="VOCAL"; break;
            case "U": document.getElementById('result').value="VOCAL"; break;
            default: document.getElementById('result').value="CONSONANTE"; break;
        }
    }
</script>
</head>
<body>
    <form method="get" name="ejercicio4">
        INGRESE LETRA : <input name="num" type="text" > <br>
        <input type="button" value="OPERAR" onClick="er()" > <br>
        RESULTADO : <input name="result" id="result" type="text" size="27" > <br>
    </form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module4
    Dim Letra As String
    Sub Main()
        Write("Ingrese Letra : ")
        Letra = ReadLine().ToUpper
        Select Case Letra
            Case "A" : Write("VOCAL")
            Case "E" : Write("VOCAL")
            Case "I" : Write("VOCAL")
            Case "O" : Write("VOCAL")
            Case "U" : Write("VOCAL")
            Case Else
                Write("CONSONANTE")
        End Select
        ReadLine()
    End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site