Ingresar una letra y mostrar su LP

¡Haz clic para puntuar este proyecto!
(Votos: 0 Promedio: 0)

Cree una variable dónde almacena sólo la letra inicial de los siguientes lenguajes de programación:

Visual Basic, Pascal, C#, Java, Fortran; dependiendo de la letra ingresada mostrar el lenguaje de programación correspondiente por pantalla, si la letra no corresponde a ningún lenguaje de programación mostrar un error por pantalla.

¿En que programa quieres ver el Código? :

    Diagrama de flujo : Que muestra en nombre del LP

    PSeInt - FLEXIBLE

      
    Algoritmo Seleccion10
        Escribir "LENGUAJES DE PROGRAMACIÓN"
        Escribir "========================="
        Escribir "Ingrese una de las Sguientes Letras (V - P - C - J - F): "
        Leer Letra
        Segun Letra Hacer
            "V": Escribir "VISUAL BASIC"
            "P": Escribir "PASCAL"
            "C": Escribir "C#"
            "J": Escribir "JAVA"
            "F": Escribir "FORTRAN"
        De Otro Modo: Escribir "LETRA MAL INGRESADA"
        Fin Segun
    FinAlgoritmo
    

    PSeInt - ESTRICTO

     
    Algoritmo Seleccion10
        Definir Letra como Caracter;
        Escribir "LENGUAJES DE PROGRAMACIÓN";
        Escribir "=========================";
        Escribir "Ingrese una de las Sguientes Letras (V - P - C - J - F): ";
        Leer Letra;
        Si Letra="V" Entonces
            Escribir "VISUAL BASIC";
        FinSi
        Si Letra="P" Entonces
            Escribir "PASCAL";
        FinSi
        Si Letra="C" Entonces
            Escribir "C#";
        FinSi
        Si Letra="J" Entonces
            Escribir "JAVA";
        FinSi
        Si Letra="F" Entonces
            Escribir "FORTRAN";
        SiNo
            Escribir "LETRA MAL INGRESADA";
        FinSi
    FinAlgoritmo
    

    Lenguaje C

      
    #include<stdio.h>
    int main(){	
    	char letra;
    	printf("LENGUAJES DE PROGRAMACION\n");
    	printf("=========================\n");
    	printf("Ingrese una de las siguientes letras (V-P-C-J-F) : ");	
    	scanf("%c",&letra);
    	switch(letra){
    		case 'V' : printf("\nVISUAL BASIC"); break;
    		case 'P' : printf("\nPASCAL"); break;
    		case 'C' : printf("\nC#"); break;
    		case 'J' : printf("\nJAVA"); break;
    		case 'F' : printf("\nFORTRAN"); break;
    		default  :  printf("\nLETRA MAL INGRESADA"); 
    	}
    	return 0;
    }
    

    C++

     
    #include<iostream>
    using namespace std;
    int main(){	
    	char letra;
    	cout << "LENGUAJES DE PROGRAMACION" << endl;
    	cout << "=========================" << endl;
    	cout << "Ingrese una de las siguientes letras (V-P-C-J-F) : ";	
    	cin >> letra;
    	switch(letra){
    		case 'V' : cout << endl << "VISUAL BASIC" << endl; break;
    		case 'P' : cout << endl << "PASCAL" << endl; break;
    		case 'C' : cout << endl << "C#" << endl; break;
    		case 'J' : cout << endl << "JAVA" << endl; break;
    		case 'F' : cout << endl << "FORTRAN" << endl; break;
    		default  : cout << endl << "LETRA MAL INGRESADA" << endl; 
    	}
    	return 0;
    }
    

    Python

      
    print("10. SEGÚN LA PRIMERA LETRA MOSTRAR EL NOMBRE DEL PROGRAMA.")
    print("LENGUAJES DE PROGRAMACIÓN")
    print("=========================")
    letra = input("Ingrese una Letra (V - P - C - J - F): ")
    if letra=="V":
        print("VISUAL BASIC")
    elif letra=="P":
        print("PASCAL")
    elif letra=="C":
        print("C#")
    elif letra=="J":
        print("JAVA")
    elif letra=="F":
        print("FORTRAN")
    else:
        print("LETRA MAL INGRESADA")
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir