Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

Ingresar una letra y mostrar su LP.

10. Cree una variable dónde almacena sólo la letra inicial de los siguientes lenguajes de programación:

Visual Basic, Pascal, C#, Java, Fortran; dependiendo de la letra ingresada mostrar el lenguaje de programación correspondiente por pantalla, si la letra no corresponde a ningún lenguaje de programación mostrar un error por pantalla.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++





Diagrama de flujo(DFD) que muestra en nombre del LP:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

      
Algoritmo Seleccion10
    Escribir "LENGUAJES DE PROGRAMACIÓN"
    Escribir "========================="
    Escribir "Ingrese una de las Sguientes Letras (V - P - C - J - F): "
    Leer Letra
    Segun Letra Hacer
        "V": Escribir "VISUAL BASIC"
        "P": Escribir "PASCAL"
        "C": Escribir "C#"
        "J": Escribir "JAVA"
        "F": Escribir "FORTRAN"
    De Otro Modo: Escribir "LETRA MAL INGRESADA"
    Fin Segun
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

      
Algoritmo Seleccion10
    Definir Letra como Caracter;
    Escribir "LENGUAJES DE PROGRAMACIÓN";
    Escribir "=========================";
    Escribir "Ingrese una de las Sguientes Letras (V - P - C - J - F): ";
    Leer Letra;
    Si Letra="V" Entonces
        Escribir "VISUAL BASIC";
    FinSi
    Si Letra="P" Entonces
        Escribir "PASCAL";
    FinSi
    Si Letra="C" Entonces
        Escribir "C#";
    FinSi
    Si Letra="J" Entonces
        Escribir "JAVA";
    FinSi
    Si Letra="F" Entonces
        Escribir "FORTRAN";
    SiNo
        Escribir "LETRA MAL INGRESADA";
    FinSi
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

      
#include<stdio.h>
int main(){	
		
	char letra;
		
	printf("LENGUAJES DE PROGRAMACION\n");
	printf("=========================\n");
	printf("Ingrese una de las siguientes letras (V-P-C-J-F) : ");	
	scanf("%c",&letra);
		
	switch(letra){
		case 'V' : printf("\nVISUAL BASIC"); break;
		case 'P' : printf("\nPASCAL"); break;
		case 'C' : printf("\nC#"); break;
		case 'J' : printf("\nJAVA"); break;
		case 'F' : printf("\nFORTRAN"); break;
		default  :  printf("\nLETRA MAL INGRESADA"); 
	}
		
	return 0;
}
    

C++ DESCARGA CÓDIGO

      
#include<iostream>
using namespace std;
int main(){	

	char letra;
		
	cout << "LENGUAJES DE PROGRAMACION" << endl;
	cout << "=========================" << endl;
	cout << "Ingrese una de las siguientes letras (V-P-C-J-F) : ";	
	cin >> letra;
		
	switch(letra){
		case 'V' : cout << endl << "VISUAL BASIC" << endl; break;
		case 'P' : cout << endl << "PASCAL" << endl; break;
		case 'C' : cout << endl << "C#" << endl; break;
		case 'J' : cout << endl << "JAVA" << endl; break;
		case 'F' : cout << endl << "FORTRAN" << endl; break;
		default  : cout << endl << "LETRA MAL INGRESADA" << endl; 
	}
		
	return 0;
}
    

Python DESCARGA CÓDIGO

      
if __name__ == '__main__':     print("LENGUAJES DE PROGRAMACIÓN")
    print("=========================")
    print("Ingrese una de las Siguientes Letras (V - P - C - J - F): ")
    letra = input()
    if letra=="V":
        print("VISUAL BASIC")
    if letra=="P":
        print("PASCAL")
    if letra=="C":
        print("C#")
    if letra=="J":
        print("JAVA")
    if letra=="F":
        print("FORTRAN")
    else:
        print("LETRA MAL INGRESADA")
    

Java NetBeans DESCARGA CÓDIGO

      
package Seleccion;
import java.util.Scanner;
public class Seleccion10 {
    public static void main(String[] args) {
        String letra;
        Scanner ingreso=new Scanner(System.in);
        System.out.println("LENGUAJE DE PROGRAMACIÓN");
        System.out.println("========================");
        System.out.print("Ingrese (V - P - C - J - F) : ");
        letra = ingreso.next();
        switch(letra){
            case "V": System.out.println("VISUAL BASIC"); break;
            case "P": System.out.println("PASCAL"); break;
            case "C": System.out.println("C#"); break;
            case "J": System.out.println("JAVA"); break;
            case "F": System.out.println("FORTRAN"); break;
            default : System.out.println("LETRA MAL INGRESADA");
        }
    }
}
    

Java Script DESCARGA CÓDIGO

      
<html>
<head>
    <title>Ejercicio Selección en JS - 10:</title>
<script language="JavaScript" type="text/javascript">
    function lenguajep(){
        var xletra = ejercicio10.letra.value;
        switch(xletra){
            case "V": document.getElementById('lenguaje').value="VISUAL BASIC"; break;
            case "P": document.getElementById('lenguaje').value="PASCAL"; break;
            case "C": document.getElementById('lenguaje').value="C#"; break;
            case "J": document.getElementById('lenguaje').value="JAVA"; break;
            case "F": document.getElementById('lenguaje').value="FORTRAN"; break;
        }
    }
</script>
</head>
<body>
    <form method="get" name="ejercicio10">
        "LENGUAJES DE PROGRAMACIÓN" <br> <br>
        INGRESE UNA DE LAS SIGUIENTES <br>
        LETRAS (V - P - C - J - F): <input name="letra" size="3" type="text" > <br> <br>
        <input type="button" value="MOSTRAR" onClick="lenguajep()" > <br> <br>
        LENGUAJE : <input name="lenguaje" id="lenguaje" type="text"> <br>
    </form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module10
    Dim Letra As String
    Sub Main()
        WriteLine("LENGUAJES DE PROGRAMACIÓN")
        WriteLine()
        Write("Ingrese una de las Siguientes letras (V - P - C - J - F): ")
        Letra = ReadLine()
        Select Case Letra
            Case "V" : Write("Visual Basic")
            Case "P" : Write("Pascal")
            Case "C" : Write("C#")
            Case "J" : Write("Java")
            Case "F" : Write("Fortran")
            Case Else
                Write("Letra MAL Ingresada")
        End Select
        ReadLine()
    End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site