Costo según su edad y el sexo

¡Haz clic para puntuar este proyecto!
(Votos: 5 Promedio: 4.6)

En la ciudad de Lima, una agencia de seguros para automóviles asigna costos basados en el sexo y la edad del conductor.

- Los varones menores de 25 años pagan los precios más altos, S/.1000 soles.
- Los hombres de 25 años a más pagan 700 soles.
- Las mujeres de menos de 21 años ó más pagan 500 soles.

Escribe el algoritmo del programa que imprima la edad del conductor, sexo y el pago correspondiente para los clientes de la aseguradora.

¿En que programa quieres ver el Código? :

    Diagrama de flujo : Agencia de seguros.

    PSeInt - FLEXIBLE

      
    Algoritmo Seleccion05
        Escribir "Ingrese el Sexo:"
        Leer Sexo
        Escribir "Ingrese la Edad:"
        Leer Edad
        Segun Sexo Hacer
            "H":
                Si Edad < 25 Entonces
                    Costo = 1000
                SiNo
                    Costo = 700
                Fin Si
            "M":
                Si Edad < 21 Entonces
                    Costo = 500
                Fin Si
        Fin Segun
        Escribir "EDAD : ", Edad
        Escribir "SEXO : ", Sexo
        Escribir "PAGO : ", Costo
    FinAlgoritmo
    

    Lenguaje C

     
    #include<stdio.h>
    #include<string.h>
    #define MAX_STRLEN 256
    int main(){	
    	float costo;
    	int edad, interruptor;
    	char sexo[MAX_STRLEN];
    	printf("Ingrese el Sexo (H/M) : ");	
    	scanf("%s",sexo);
    	printf("Ingrese la Edad : ");	
    	scanf("%i",&edad);
    	
    	if(strcmp(sexo,"H")==0){
    		interruptor = 1;
    	}else{
    		interruptor = 2;
    	}
    	costo = 0;
    	switch(interruptor){
    		case 1:			
    			if(edad < 25){
    				costo = 1000;
    			}else{
    				costo = 700;
    			}
    			break;
    		case 2:			
    			if(edad < 21){
    				costo = 500;
    			}
    			break;
    	}
    	printf("\n EDAD : %i\n", edad);	
    	printf("\n SEXO : %s\n", sexo);	
    	printf("\n PAGO : %2.f\n", costo);	
    	return 0;
    }	
    

    C++

      
    #include<iostream>
    using namespace std;
    int main() {
    	float costo;
    	int edad, interruptor;
    	string sexo;
    	cout << "Ingrese el Sexo (H/M) : ";
    	cin >> sexo;
    	cout << "Ingrese la Edad : ";	
    	cin >> edad;
    	if(sexo == "H"){
    		interruptor = 1;
    	}else{
    		interruptor = 2;
    	}
    	costo = 0;
    	switch(interruptor){
    		case 1:			
    			if(edad < 25){
    				costo = 1000;
    			}else{
    				costo = 700;
    			}
    			break;
    		case 2:			
    			if(edad < 21){
    				costo = 500;
    			}
    			break;
    	}
    	cout << "\n EDAD : " << edad;	
    	cout << "\n SEXO : " << sexo;	
    	cout << "\n PAGO : " << costo;		
    	return 0;
    }
    

    Python

      
    print("05. DAR COSTOS BASADOS EN LA EDAD Y EL SEXO.")
    sexo = input("Ingrese el Sexo (H/M) : ")
    edad = int(input("Ingrese la Edad : "))
    if sexo=="H":
        interruptor = 1
    else:
        interruptor = 2
        costo = 0
    if interruptor==1:
        if edad < 25:
            costo = 1000
        else:
            costo = 700
    elif interruptor==2:
        if edad < 21:
            costo = 500
    print()
    print("EDAD : ",edad)
    print("SEXO : ",sexo)
    print("PAGO : ",costo)
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir