Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

Costo según su edad y el sexo.

05. En la ciudad de Lima, una agencia de seguros para automóviles asigna costos basados en el sexo y la edad del conductor.

- Los varones menores de 25 años pagan los precios más altos, S/.1000 soles.
- Los hombres de 25 años a más pagan 700 soles.
- Las mujeres de menos de 21 años ó más pagan 500 soles.

Escribe el algoritmo del programa que imprima la edad del conductor, sexo y el pago correspondiente para los clientes de la aseguradora.


DESCARGA EL CÓDIGO EN :

  Algoritmo - DFD
  PSeInt
  C - C++





Diagrama de flujo(DFD) agencia de seguros:



PSeInt - FLEXIBLE DESCARGA CÓDIGO

      
Algoritmo Seleccion05
    Escribir "Ingrese el Sexo:"
    Leer Sexo
    Escribir "Ingrese la Edad:"
    Leer Edad
    Segun Sexo Hacer
        "H":
            Si Edad < 25 Entonces
                Costo = 1000
            SiNo
                Costo = 700
            Fin Si
        "M":
            Si Edad < 21 Entonces
                Costo = 500
            Fin Si
    Fin Segun
    Escribir "EDAD : ", Edad
    Escribir "SEXO : ", Sexo
    Escribir "PAGO : ", Costo
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

      
Algoritmo Seleccion05
    Definir Sexo como Caracter;
    Definir Interruptor, Edad como Entero;
    Definir Costo como Real;
    Escribir "Ingrese el Sexo (H/M):";
    Leer Sexo;
    Escribir "Ingrese la Edad:";
    Leer Edad;
    Si Sexo="H" Entonces
        Interruptor <- 1;
    SiNo
        Interruptor <- 2;
    FinSi
    Costo <- 0;
    Segun Interruptor Hacer
        1:
            Si Edad < 25 Entonces
                Costo <- 1000;
            SiNo
                Costo <- 700;
            FinSi
        2:
            Si Edad < 21 Entonces
                Costo <- 500;
            FinSi
    FinSegun
    Escribir "EDAD : ", Edad;
    Escribir "SEXO : ", Sexo;
    Escribir "PAGO : ", Costo;
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

      
#include<stdio.h>
#include<string.h>
#define MAX_STRLEN 256
int main(){	
	float costo;
	int edad, interruptor;
	char sexo[MAX_STRLEN];
	
	printf("Ingrese el Sexo (H/M) : ");	
	scanf("%s",sexo);
	printf("Ingrese la Edad : ");	
	scanf("%i",&edad);
	
	if(strcmp(sexo,"H")==0){
		interruptor = 1;
	}else{
		interruptor = 2;
	}
	
	costo = 0;
	
	switch(interruptor){
		case 1:			
			if(edad < 25){
				costo = 1000;
			}else{
				costo = 700;
			}
			break;
		case 2:			
			if(edad < 21){
				costo = 500;
			}
			break;
	}
	printf("\n EDAD : %i\n", edad);	
	printf("\n SEXO : %s\n", sexo);	
	printf("\n PAGO : %2.f\n", costo);	
	
	return 0;
}	
    

C++ DESCARGA CÓDIGO

      
#include<iostream>
using namespace std;

int main() {
	float costo;
	int edad, interruptor;
	string sexo;
		
	cout << "Ingrese el Sexo (H/M) : ";
	cin >> sexo;
	
	cout << "Ingrese la Edad : ";	
	cin >> edad;
	
	if(sexo == "H"){
		interruptor = 1;
	}else{
		interruptor = 2;
	}
	
	costo = 0;
			
	switch(interruptor){
		case 1:			
			if(edad < 25){
				costo = 1000;
			}else{
				costo = 700;
			}
			break;
		case 2:			
			if(edad < 21){
				costo = 500;
			}
			break;
	}
	cout << "\n EDAD : " << edad;	
	cout << "\n SEXO : " << sexo;	
	cout << "\n PAGO : " << costo;		

	return 0;
}

    

Python DESCARGA CÓDIGO

      
if __name__ == '__main__':
    print("Ingrese el Sexo (H/M):")
    sexo = input()
    print("Ingrese la Edad:")
    edad = int(input())
    if sexo=="H":
        interruptor = 1
    else:
        interruptor = 2
    costo = 0
    if interruptor==1:
        if edad < 25:
            costo = 1000
        else:
            costo = 700
    elif interruptor==2:
        if edad < 21:
            costo = 500
    print("EDAD : ",edad)
    print("SEXO : ",sexo)
    print("PAGO : ",costo)
    

Java NetBeans DESCARGA CÓDIGO

      
package Seleccion;
import java.util.Scanner;
public class Seleccion5 {
    public static void main(String[] args) {
        String sexo;
        int edad;
        Double costos=0.0;
        Scanner ingreso=new Scanner(System.in);
        System.out.print("Ingrese el Sexo : ");
        sexo = ingreso.next();
        System.out.print("Ingrese la edad : ");
        edad = Integer.parseInt(ingreso.next());
        switch(sexo){
            case "H":
                if(edad < 25){
                    costos = 1000.0;
                }else{
                    costos = 700.0;
                }
                break;
            case "M":
                if(edad < 21){
                    costos = 500.0;
                }
                break;
        }
        System.out.println("EDAD : " + edad);
        System.out.println("SEXO : " + sexo);
        System.out.println("PAGO : " + costos);
    }
}
    

Java Script DESCARGA CÓDIGO

      
<html>
<head>
<title>Ejercicio Selección en JS - 05:</title>
<script language="JavaScript" type="text/javascript">
    function costos(){
        var xsexo = ejercicio5.sexo.value;
        var xedad = ejercicio5.edad.value;
        switch(xsexo) {
            case "H":
                if(xedad < 25){
                    document.getElementById('result').value=1000;
                } else{
                    document.getElementById('result').value=700;
                }
                break;
            case "M":
                if(xedad < 21){
                    document.getElementById('result').value=500;
                }
                break;
        }
    }
</script>
</head>
<body>
    <form method="get" name="ejercicio5">
        INGRESE EDAD : <input name="edad" type="text" > <br>
        INGRESE SEXO : <input name="sexo" type="text" > <br>
        <input type="button" value="OPERAR" onClick="costos()" > <br>
        PAGO : <input name="result" id="result" type="text" size="27" > <br>
    </form>
</body>
</html>
    

Visual Basic .Net - Consola DESCARGA CÓDIGO

      
Imports System.Console
Module Module5
    Dim Sexo As String
    Dim Edad As Integer
    Dim Costos As Decimal
    Sub Main()
        Write("Ingrese Sexo H - M : ")
        Sexo = ReadLine().ToUpper
        Write("Ingrese Edad : ")
        Edad = ReadLine()
        Select Case Sexo
            Case "H"
                If (Edad < 25) Then
                    Costos = 1000
                Else
                    Costos = 700
                End If
            Case "M"
                If (Edad < 21) Then
                    Costos = 500
                End If
        End Select
        WriteLine("EDAD : " & Edad)
        WriteLine("SEXO : " & Sexo)
        WriteLine("PAGO : " & Costos)
        ReadLine()
    End Sub
End Module
    


Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site